Recalbox won't start any rom!



  • Hi!

    Thanks in advance!

    I'm new to all this... have a raspberry pi 3, with recalbox 4.0.2

    I downloaded the OS from the recalbox site link to github, and it was working.
    Them i connected to the wifi to install some roms and was asked to upgrade.
    So i did.

    Now, after the upgrade completed, no rom is working.
    They all seem to start but come back to emustation screen/menu right back again.

    I'm trying SNES, N64, PSX, MAME... none of them in any rom works...

    Am i missing some configuration?

    Searched everywhere, but did not find any answer.


  • Translator
    Translation Master

    @Frederico-Rabelo Did you make sure you use the correct file extensions? .zip are not allowed for example.



  • @lackyluuk

    Yes, all extensions are as mentioned in the "readme" file in each rom folders.

    I did a reboot and installed 4.0.1 version again.
    Default roms were working.
    Installed all roms back again, and now none of them works.


  • Translator
    Translation Master

    @Frederico-Rabelo strange..all demo roms work you said, right?
    Maybe you have corrupted roms?
    Try to change the videomode to your monitors preferred mode, update to 4.0.2 (stable). For some systems like PSX, Mame etc you also need the correct BIOS files.

    I am sorry, I do not have the right answer for this behavior :(



  • I will update now, and see if i have the bios!
    Thanks for all the help!



  • If the default roms work and not yours ... Then your romset is faulty. If you don't even mention which systems you're trying to emulate, you won't get much help ...



  • Hi @Substring !

    @lackyluuk, I did the recovery mode, and installed the 4.0.1 version, and uploaded to 4.0.2.
    No rom (running only stock) worked. All roms went to black screen (with recalbox logo on the bottom) for a few moments and back.

    Did the recovery mode again, installed 4.0.1 version, and now some systems work, as follows:
    (running only default roms)

    • SNES works - Donkey Kong Classic
    • None of the NES rom works
    • Game Boy Advanced - all roms works at the first run, but them gets stuck in black screen. works fine again for one time after system reset (via run jumper).
    • Sega MasterSystem - same thing as Game Boy Advanced
    • PCEngine - same thing as Game boy Advanced
    • Doom works fine

    Does it have anything to do with the way i'm quiting the system?
    I'm quiting via HOTKEY + START

    @lackyluuk, what do you mean by "videomode to your monitors preferred mode"? the Game ratio (e.g 4:3)?

    will try installing BIOS now.



  • Funny!
    Thanks @Substring !!

    Found a similar thread through the thread's tags (wich i was not awear untill now):
    https://forum.recalbox.com/topic/4095/all-games-wont-start-up
    in wich you propose seting
    global.videomode=default

    Mine was = HDMI 4 or something
    Changed and now every thing works!

    Thank everybody for the help!!!



  • Ok, I'm going crazy...

    Installed a bulk of roms (SNES, N64, PSX, MAME, and SEGA MEGA CD), and now no roms works anymore!

    What am I doing wrong!?

    Still runing 4.0.1


  • Moderator
    Team
    Moderator
    Translator

    @Frederico-Rabelo try doing a new, complete clean installation, formatting the whole card again. You haven't tried anything out of the ordinary wirh the installation, right?



  • I have the same problem... mine was working really well.



  • @paradadf
    Formated the SD card, did a clean install. No fancy stuff in installation.

    Now i think i recognised the pattern:
    The roms works for one time, and them stop working (black screen forever). For every core the same thing. The game works fine for the first "boot" and them stops working.
    I'm using a regular microsoft keyboard, and using "esc" to leave the game.
    If i restart the system, the roms work again for the first time, and them black screen forever.

    SD card is a Samsung EVO + 32GB.
    Raspiberry 3


  • Moderator
    Team
    Moderator
    Translator

    @Frederico-Rabelo you first told you were quitting the games with HK+Start, which is only possible from a gamepad, but now wrote that you are using a keyboard. What is your setup exactly?

    You should read the wiki and set the prefered video mode for your tv like suggested before.
    https://github.com/recalbox/recalbox-os/wiki/Video-configuration-detailled-(EN)



  • @paradadf
    i'm using both ps3 clone controller GASIA and kerboard.
    As i said before, already tried setting video mode, but no lucky.


  • Moderator
    Team
    Moderator
    Translator

    @Frederico-Rabelo did you already updated to 4.0.2? If not, do it.



  • @frederico-rabelo I have the same problem when i upgrade to 17-12-02 the latest. Al rom stop working. did you find any solution to the problem?



  • hi guys, I had same problem and fix it by removing files the path:
    /recalbox/share/system/configs/retroarch/retroarchcustom.cfg
    /recalbox/share/system/configs/retroarch/content_history.lpl
    /recalbox/share/system/configs/retroarch/cores/retroarch-core-options.cfg

    sorry my english su##



  • @leyfelipe said in Recalbox won't start any rom!:

    hi guys, I had same problem and fix it by removing files the path:
    /recalbox/share/system/configs/retroarch/retroarchcustom.cfg
    /recalbox/share/system/configs/retroarch/content_history.lpl
    /recalbox/share/system/configs/retroarch/cores/retroarch-core-options.cfg

    sorry my english su##

    I'm having the same issue and neither solution worked for me.

    I did copy my shared folders/files over from a pi 2 to a pi3.

    Oddly, the one game that works is mvsc2 but it it goes to a memory card "create file" screen and I can't even exit the emulator.



  • Can't help without a support archive



Want to support us ?

Join us on :

643
Online

30875
Users

15088
Topics

113602
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.