Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Logitech F310 USB controller does not work in games (but works in Recalbox menu)



  • Hi everyone,

    I have a new Pi with Recalbox 4.0.0 and when my Logitech F310 is plugged in, I can use it to control the main Recalbox menus and everything. When I configure the controller, I do have some issues with the L2/R2 buttons (same as reported here: https://forum.recalbox.com/topic/2034/logitech-f310-l2-and-r2-button-configuration-problems) but I can still use it without any problems.

    However, the controller doesn't do anything at all when I'm in a game. I tried many games, many systems (GB, GBA, NES, SNES, MAME), but I can't get any game to start, no response when I press any button on the F310. The only way to get out of it again is to hit ESC on my keyboard.

    I did try switching from X to D on the back, but when it's on D, it doesn't respond at all anymore, not even in the Recalbox menu. It only works when it's set to X the moment I boot up and don't change it anymore.

    I hate asking this (because I have the feeling I'm missing something very simple, and as a newbie I'm scared that someone will point me to a post/article where this exact issue is explained), but any help would be appreciated.

    I'm also considering to just get a second hand Xbox 360 controller, since that seems to work out of the box for everyone, but if I can get my F310 to work, I won't try that.

    Thanks everyone! 🙂

    mS



  • @Senff Hi !

    As a rule of thumb : use the search function ... and ... https://forum.recalbox.com/topic/5441/logitech-f310-not-working 😛

    Maybe you'd just need to remap your pad once it's switched to direct input (use the virtual gamepad if you miss a pad to do so)



  • @Substring Thanks for guiding me, appreciate the help.

    However, I did see that post and the solution described in there (switching from X to D) didn't work for me, which is why I mentioned that in my original post. I should have included that I did see that post I guess! 😉

    Remapping the pad doesn't work, because when its in direct mode, nothing happens at all. It simply doesn't recognize any buttons I press.

    Not sure what you mean about the Virtual Gamepad but I'll look into that.

    Thanks again!



  • @Senff The virtual gamepad (RTFM hahaha) is something you can start on your phone to be used as a rescue pad. This is very helpful to reconfigure a pad that got messed. You can reach it on your PC at http://recalbox:8080 (or http://recalbox.local:8080 for mac/linux). If you wanna do it from your phone, you have to replace the named part with its IP address.

    So my guess is that your pad is "already known" but with the wrong configuration. When it's in direct input mode, can you at least navigate through ES to reconfigure it (with the help of the virutal gamepad eventually) ?



  • TL;DR

    • in "D" mode, the F310 does nothing, anywhere, ever. In "X" mode, it works in ES, but not in any games
    • an Xbox 360 controller works, but only after making a small adjustment in recalbox.conf

    The longer story:

    So.......long story: no, when the F310 is in Direct mode, I can not navigate use it at all. It simply doesn't get detected. Even when I use the virtual gamepad or another controller (I got an Xbox 360 controller today), the F310 just doesn't get detected in any way when it's set to "D". It's like it's off.

    If I set the F310 to "X", it does get detected in ES.

    So I noticed that with the Xbox controller, no button presses get detected within any games either....UNTIL I press the left shoulder button. That's like "activating" it, and then it all works. This same method doesn't work for the F310 though.

    Then I checked this thread and it suggests to edit recalbox.conf. I disabled the PS3 one and enabled the Xbox one, and that makes the Xbox controller work perfectly. Still no change in the F310 though.

    I guess I will just accept that my F310 is broken (or incompatible with Recalbox) and will just stick to the Xbox 360 one, but if anyone has any further ideas, please let me know.

    Thanks for your help and pointers, it's really appreciated a lot.


  • Developer
    Team
    Global moderator
    Translator

    @Senff try changing the global.inputdriver in recalbox.conf from auto to sdl2 (or udev, I don't remember) with the mode that works on ES but not in-game.





Want to support us ?

187
Online

78.5k
Users

20.0k
Topics

147.5k
Posts