N64 roms not launching in Recalbox v4.0 and RPI3 (even after changing the n64.videomode)



  • Re: N64 not working on recalbox4.0

    Hy,

    I can't manage to make my N64 roms work with recalbox 4.0 on a RPI3, i did change the n64.videomode=DMT 4 HDMI to n64.videomode=CEA 1 HDMI but it's still not working. Previously I had a recalbox v4 beta on a RPI2 and my N64 games were working. What should I do ?

    Thanks in advance.

    P.S. By the way, I'm using 8bitdo SFC30 pads



  • To go further in my tests:

    I did set the recalbox.conf like this : global.videomode=CEA 1 HDMI, in order to force the display to a 640x480.

    Then i used putty to test the resolution while in emulationstation with : tvservice -s, and here is what i get : state 0x12000a [HDMI CEA (4) RGB lim 16:9], 1280x720 @ 60.00Hz, progressive

    So it seems that the /recalbox/share/system/recalbox.conf, confiuration for the videomode is not taken into account, as the tvservice -s should show me a 640x480 CEA1 HDMI mode ? Or am I not understanding something.

    Could someone help me ?

    P.S. I don't understand why the videomode are changing properly with all the other emulators (retroarch based) but not with mupend64plus.



  • No one has any clue ?? Some people might have endured this issue !

    Thanks in advance for your precious help !!


  • Translation Master
    Team

    First of all, you should set your global.videomode to the preferred mode of your TV/Monitor, which can be seen using tvservice -m CEA and tvservice -m DMT and leave the n64.videomode in its default config.

    Further you should make sure that your N64 Roms are Byteswappend and not Little Endian, or Big Endian. "tool64" is your program of choice for this.

    Do this and report back, please.



  • Thanks for your answer, unfortunately I already tested to do this, in my case the preferred settings of my TV is a CEA 16 HDMI (1920x1080), and all of my N64 roms are indeed Byteswapped, yet it's still not working :s (I let the n64.videmode=DMT 4 HDMI, I also tried n64.videmode=CEA 1 HDMI but it's the same issue)

    I don't know what to change, if you have any idea, I'll gladly take it !!!

    Thanks in advance for your help :)


  • Translation Master
    Team

    @eightkiller I'll give it a try on my 4K TV later today and let you know what happens, because as of now I'm using my Bartop for everything (1280x1024, 19", 5:4)


  • Translation Master
    Team

    Soooo @eightkiller

    Look at this
    0_1487781565228_DSC_0260 Kopie Kopie.JPG

    N64 on my PI2 (for testing purposes), with recalbox 4.0.2 on my 60", 4k UHD, LG 60UH8509, running in fullscreen without any problems, being connected via HDMI.

    • Shaders are set to none
    • Pixel Perfect is deactivated

    My TV has "Mode 16 CEA" as preferred mode, which I have put in my recalbox.conf so the two important parts look like this

    ## Set game resolution for emulators
    ## select your mode from the command : tvservice -m [MODE]
    ## CEA 5 HDMI : 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced 
    ## CEA 4 HDMI : 1280x720 @ 60Hz 16:9, clock:74MHz progressive
    ## use 'default' for using the default resolution
    ## (string)
    global.videomode=CEA 16 HDMI
    

    and

    ## N64 emulator is configured to display a screen with a 640x480 resolution (native n64 resolution)
    ## So you must use one of these video modes (DMT 4 HDMI,CEA 1 HDMI).
    ## If your screen is not compatible with one of these video modes, please check the recalbox's wiki.
    n64.videomode=DMT 4 HDMI
    ## If you are using a CRT screen, please change the setting above with this one : 
    # n64.videomode=default
    

    Everything else is left untouched



  • @Nachtgarm Thanks for your help.

    I have the same config as you except i'm using a RPI 3 , my N64 was working perfectly on my old RPI2 with recalbox 3.x,
    I Switched to a RPI 3 with the 4.x.x versions of recalbox.

    So it might be a an issue due to the RPI 3 ?

    I have the exact same config :(

    ## Set game resolution for emulators
    ## select your mode from the command : tvservice -m [MODE]
    ## CEA 5 HDMI : 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced 
    ## CEA 4 HDMI : 1280x720 @ 60Hz 16:9, clock:74MHz progressive
    ## CEA 1 HDMI : 640x480 @ 60Hz 4:3, clock:25MHz progressive
    ## CEA 2 HDMI : 720x480 @ 60Hz 4:3, clock:27MHz progressive
    
    ## use 'default' for using the default resolution
    ## (string)
    global.videomode=CEA 16 HDMI
    
    ## Shader set 
    ## Automatically select shaders for all systems
    ## (none, retro, scanlines)
    global.shaderset=none
    
    ## Once enabled, your screen will be cropped, and you will have a pixel perfect image (0,1)
    global.integerscale=0
    

    and

    ## N64 emulator is configured to display a screen with a 640x480 resolution (native n64 resolution)
    ## So you must use one of these video modes (DMT 4 HDMI,CEA 1 HDMI).
    ## If your screen is not compatible with one of these video modes, please check the recalbox's wiki.
    n64.videomode=DMT 4 HDMI
    ## If you are using a CRT screen, please change the setting above with this one : 
    # n64.videomode=default
    

    and my preferred mode :

    (prefer) mode 16: 1920x1080 @ 60Hz 16:9, clock:148MHz progressive 3D:SbS-HH
    

    I'm using a LG 42LW4500 TV Screen

    What's going on ??!!!


  • Translation Master
    Team

    Could you please backup your data, make a clean install, leave everything unchanged and start a N64 game?



  • I did a clean install just a few days ago, and only changed the .configfiles of other emulators (snes, megadrive, etc...) in the recalbox.conf

    I'am also using a NAS to load my ROMs (so I've just added a line in the fstab and renamed my S31Emulationstation in S92emulationstation, that's all I modified. And everything is working flawlessly except for N64.


  • Moderator
    Team
    Moderator
    Translator

    @eightkiller one very important recommendation users should know is how to follow instructions. He was clear about you launching a n64 game without ANY other modifications. You haven't tried that yet.
    WHY did he ask you to do that...? Because the solution is not evident and you need to go step by step to see what broke n64. If it doesn't work with the very standard way, then there is no need to look any further in the chain of possible issues. So please, be so kind to follow the instructions.



  • @paradadf @Nachtgarm

    My bad, I'm a deadbrain guy :'(, I found what was wrong and it was pretty damn stupid... I forgot to unzip the n64 roms and had them in .zip format instead of .n64, I was using my old bestset I had with an old RetroPie version I think. The fresh reinstall I just did as you suggested made me realize that.

    Thanks for your help guys, and sorry for the trouble, fake problems like that are often the hardest to solve xD

    See your on the forum.


  • Translation Master
    Team

    @eightkiller DUUUUUUUUUUUUUUUUuuuuuuuuuuuuuuuude.......
    0_1488182955802_f32.jpg

    ;-)



  • N64 emulator is configured to display a screen with a 640x480 resolution (na$

    So you must use one of these video modes (DMT 4 HDMI,CEA 1 HDMI).

    If your screen is not compatible with one of these video modes, please check$

    n64.videomode=CEA 1 HDMI

    If you are using a CRT screen, please change the setting above with this one$

    n64.videomode=default

    Configurations generated by Recalbox

    global.integerscale=0
    n64.emulator=default
    n64.core=default
    n64.ratio=4/3


  • Moderator
    Team
    Moderator
    Translator

    @leandro-siqueira this is a very old topic and you haven‘t made any question. I‘m closing this.



Want to support us ?

Join us on :

295
Online

27412
Users

14115
Topics

107121
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.