Problem with Argon One + PI 4B



  • Hi all! 🙂
    I've just created my account here, looking for some help. I hope it's ok to directly post something like this.
    Recently a friend told me he had bought a retro console. I got curious, since I hadn't heard anything of "Raspberry Pi" before (yeah, I'm living under a rock) and he agreed to lend me that wonderful box over the weekend. It consists of a Raspberry Pi 3 B+ in a Retroflag case (Superpi) with Recalbox version 18.07.13 on a Micro SD card. My friend even allowed me to fool around with the box a little, and since I had an unused Micro SD card lying around, I downloaded the latest Recalbox version (7.1.1. reloaded), plugged it in and everything was fine.
    In fact, I totally fell in love with the idea of having such a retro console myself and decided to build my own, so I did quite a research (or at least I thought so...) on the web and finally ordered a Raspberry Pi 4B 4GB and a case which seems to be considered one of the best cases at the moment, the Argon One case. It is the V2 version, which means there is a black module you have to connect to the Pi itself and which kind of converts the two micro HDMI ports of the Pi 4 into two regular sized HDMI ports.
    So far, so good. I connected everything the way the manual told me to, formatted my SD card, installed a fresh version of Recalbox 7.1.1 reloaded (this time, the Pi4 version) on it, inserted it and started console.
    But in spite of the console clearly booting up, I didn't see anything. I tried a few times, then I read online that the two HDMI ports of the Pi4 work differently. This time, I plugged the HDMI-cable in the second HDMI port and in fact, there it was, the Emulation Station menu. BUT:

    1. No sound (regardless of the settings in the ES menu)
    2. The overall resolution is horrible, compared to the (older?) Pi and Recalbox version of my friend.

    I decided to focus on the sound problem first and I found the information online that only one of the Pi 4's HDMI ports supports sound by default. But since there was only one functioning, but obviously silent port and neither sound nor any image on the other port, I re-opened the whole console, removed the black Argon platine which converts the micro HDMI to regular HDMI, and used a micro HDMI adapter to link the naked Pi 4 directly to the TV instead. This time, I got an image on both ports, and sound + image on the first port. However, the image quaity still is miserable. I don't get this, because on my friend's box, with my own SD and Recalbox 7.1.1, the resolution immediately was perfect.
    So, all in all, I have a Raspberry Pi 4 which is either mute and ugly or simply not working at all when stuck in the case, or a naked Raspberry whose image quality still is a mess.

    I tried to find a solution for this or similar problem postings, but this specific case just seems to be perfect for everyone else, it just seems to be plug and play: unbox the Raspberry, unbox the case, plug them together, cables, there you go, perfect image, have fun.

    Am I missing something? Like... do you first have to install something ONTO the Raspberry Pi itself to be able to properly use the HDMI ports? I mean, in my friend's case, he had a functional console and all I did was exchanging the SD.
    But the Recalbox instructions also say: Install on SD, plug SD in, play.

    Could it be that my Argon One case or the module is broken?

    It is so annoying, I did read so many reviews for different cases, and the Argon One just seemed to be the best choice.
    Do I have to change something in the config files? Which ones? Which changes?

    Any help would be appreciated, I just wish to get this tiny, but great thing to work 😞

    Cid



  • There is a resolution bug if its connected to a 4k tv.

    If you put your microSD card in a laptop / PC and on the share drive,look in the system\ folder, and edit the recalbox.config file, ideally using the free software Notepad++

    If you need help getting microSD card recognised in a PC, read this : https://forum.recalbox.com/topic/22741/transferring-roms-directly-to-microsd-card-it-works?_=1611492045304

    Change line 54 ish to read :

    system.es.videomode=CEA 4 HDMI

    That forces it to display 720p (you do NOT want 1080p as it eats up the video RAM)

    In there, Id also put "rewind" off, as this kills the speed of lots of emulators. Its around line 320 ish - change to :

    ##Set rewind for all emulators (0,1)
    global.rewind=0

    As for audio, lines 205 ish have the following, which may help:

    #-------------C - Audio ------------ #
    Set the audio device (auto, hdmi, jack)

    audio.device=hdmi
    Set system volume (0..100)
    audio.volume=90
    Enable or disable system sounds in ES (0,1)
    audio.bgmusic=0

    As for games, almost none will work unless you :
    A) have the BIOS files for all the emulators
    B) have all the rom / game files you want (obtained from, ahem, wherever) for each system.

    As a guide, on the share drive, in the bios\ folder, I have 2484 files, so good luck getting them, as its.....a journey!

    You can boot up Recalbox and on the front end, once you have configured your controller, press start to bring up the sub menu and do the bios check from in there (cant remember the exact option, but its pretty obvious).

    Good luck !


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator



  • Thank you both very much!
    I will try all that, unfortunately, this week is filled with work, so I won't have much time before the weekend.
    And unfortunately, I don't speek a word French (I hope at least my English is enough, as I'm no native speaker), so I couldn't make out if my problem had been explained in French already ^^'

    Meanwhile (before you answered), I kinda got it to work, by messing around in the config file on the SD. Now, the first HDMI-port of the case still does nothing (no video, no sound), but at least the sound on the second one is working AND the resolution is fine now.
    BUT: Everytime I start the console now, the image is sort of cut off, like it's too big for my TV (just a regular, old basis LED by the way, no 4k TV), you can only see the upper left quarter of the screen. When I unplug the HDMI cable and plug it back in, the image adjusts itself and everything's fine, but I don't want to have to do this everytime. Now I need to figure out why the image isn't properly adjusted by default, but I guess it's just a matter of tuning in the config files, like you suggested.
    I mainly bought a Raspberry Pi 4 instead of a 3b +, because I wanted to be able to play N64-games on it, but still, most of the games suffer from lags. Maybe it's just the issue with 1080p instead of 720p and the Pi has to work more than necessary. I will follow your advice step by step on the weekend.
    I would say I get the basic idea of how everything works, for instance, even with the friend's console, I managed to use Putty and WinSCP to get access to all the folders of the Pi.
    What's weird is that when I used my Micro SD on my friend's console and installed the Pi3 version of Recalbox 7.1.1 reloaded on it, when I inserted the SD card into my PC, there were two drives: "Recalbox" and "Share". But this time, after installing the Pi 4 version of Recalbox 7.1.1 reloaded on the very same SD Card after formatting, only "Recalbox" shows up. I guess I will have to use Putty and WinSCP to gain access from my PC.
    Then there are some other issues. On my friend's console, Zelda Majora's Mask would lag too much. Now, on my own Pi 4, it runs just fine, but I can't select items from the inventory (using the analog stick just immediately browses through the different inventory screens without the chance to select anything), which makes the game essentially unplayable.
    But I think all of that will be just a matter of some lines in some files I don't know of yet.

    Again, thank you so much for your detailed advice and links, I will try them out and report if I can fix the problems 🙂


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @CidHigwind If you already know how to use WinSCP, and already know how to edit the config.txt file, you already have a good idea of ​​how to modify it as needed.
    The problem has already been solved in French, but when you read the topic calmly, you will see that the resolution is in English.
    To adjust the screen size, you can do this by videomode, or by overscan, read these tutorials:

    About disconnecting and reconnecting the HDMI cable for the resolution to be correct, this is because your TV is not communicating correctly with the RPi, usually if you turn on the TV before Recalbox solves the problem. It's an EDID problem (search for EDID on google and you'll understand).

    About the controls: usually mapping the joystick on the Emulationstation resolves.

    About the SHARE partition not appearing in windows: it is usually a Windows bug, if you are in computer management, disk management, and assign a letter to the partition, it becomes visible in Explorer.



  • @RustyMG
    @Zing

    I had some unexpected freetime today and used that to try out your tipps and links - and boy, what a help you were!
    No more bad resolution, no cut-off intro video which required to mess around with the HDMI cable, sound is working, I assigned a drive letter to my "Share" folder and have access now...
    Great!
    I've replaced the menu music and the intro video to customize everything.
    I also got the case fan installed (but the cooling of the case is so efficient that the temperature never seems to reach 55°C, at which point the fan would start) and connected my Controller via bluetooth using a dongle.

    I would like to thank you for your advice! 🙂 🙂

    Now there are just some minor problems, but I'm sure I will get rid of them, too:

    1. The booting seems to need too much time. All together, it takes less than a minute from pressing the power button to navigating through the Emulation Station. But what puzzles me is the fact that after pressing the power button, the console takes 19 seconds to do - nothing at all. There's just a black screen. After that, the intro video is played, after that, you see the official Recalbox logo (the one with the Pacman ghosts) for like a second, and then there is a short loading bar (3-5 seconds) and there you go, Emulation station. I know how to change the intro video and it's length, but what about these 19 seconds of nothing at the very beginning? My friend's box with a Pi 3 B + and Recalbox 18.07.13 only took like 5 seconds and then there was the intro video. Weird.

    2. Some (N64) games still lag too much, but I guess that's a known issue, I find complains about it everywhere...

    3. My controller does not seem to work right. Well, it DOES (I don't know how to put it). I tried remapping all the buttons, but still, the N64's Zelda inventory won't work. Additionally, sometimes the response from input is delayed beyond belief, even in the file manager. And in some games, some special inputs just don't work. For example, in Starfox 64, "C left" makes your ship boost for a short period, but if you pull up the ship at the same moment (Down + C left) you would normally do a somersault / looping. But regardless of what I try, the ship will just boost while flying up a little, but a can't do that manouver. All these problems appear regardless of the bluetooth connection, if I use the cable, I still can't do a somersault in Starfox or use the inventory in Zelda, and I guess these won't be the only games with issues.
      I don't understand it, because overall, these two games run much smoother now than they did on the Pi 3, and overall, the control works perfectly - it's just these very instances where it doesn't. I'm using the exact same dongle and PS4 Controller I've used with the Pi3.

    Well, I will browse through this forum, maybe I'll find an answer.

    So far, thank you for your help!


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator



  • @Zing

    1. I fixed the controller issue, in Retroarch there was an option for Gamepad 1 that would somehow link the analog stick to the D-Pad. When I turn it off, I can now use the inventory in Zelda like intended. For some reason, the game now freezes after 3-5 minutes (in fact, the whole console crashes). Maybe it's the ROM, I will try another one.

    As for 2: Thanks, I will check that out!

    1. Yes, unfortunately, the abnormally long boot has been present all the time, even when I used my SD card with the latest Recalbox version on my friend's Pi 3 B +. When my Pi 4 B came, even before I applied the case or anything else, I just formatted the SD card, installed a fresh version of Recalbox and put it in, without any ROMs, modifications or whatever. Still, about 20 seconds after the PI starts, there's nothing.
      Could it be my SD card? My friend had a red Samsung 64 GB card which reads "EVO plus", while I have a green Samsung 128 GB card which reads "EVO select".
      I've read online that the "select" version is slightly slower than "plus", but that's supposed to apply only for the writing speed, while the reading speed is supposed to be almost identical.
      All in all, the console needs 32 seconds now from pressing the power button to navigating the Emulation Station. I've deleted all intro videos but the shortest one (I like to have a video being played completely), it's just weird that there's nothing happening at first for sooo long.


  • Little Update:

    Zelda works now, it really was the ROM.

    But geez, this resolution issue... I'm too stupid for that, I suppose. I had changed everything (recalbox.conf in "Share" and config in "Recalbox") to CEA 4 HDMI yesterday according to the French thread and all was well, except the lag in some N64 games. So, I tried "DMT 4 HDMI" and "CEA 1 HDMI", but the lag remained and since "CEA 4 HDMI" looked best, I changed everything back to that. But now, for no apparent reason, the screen is no longer centered and there are glitches everywhere. What the heck.


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @CidHigwind As I already said, I don't have an Rpi4 (unfortunately), but, as far as I know, in Rpi4 the N64 is really not very good, I believe there will be improvements in the next version, but, for now, unfortunately there is no solution for that:

    https://forum.recalbox.com/topic/23263/n64-videomode-doesn-t-work-in-recalbox-conf



  • @Zing
    Yep, seems like that, as I said, most people seem to have problems with N64, especially on the Pi 4. Still, N64 games run a LOT better on my 4 than they did on the Pi 3B of my friend. Maybe it's because there, the resolution settings for the N64 weren't set correctly. Or maybe it was because that Pi 3B wasn't overclocked.
    Yesterday, I managed to find the issue: While messinga round with CEA and DMT, I also tried some different settings in Retroarch, and one of the options HAS to be on or everything goes crazy (I think it was framebuffer emulation). Now, all games work properly again (for all this time, the ES and all other emulators kept working great, so it really is just a N64 issue), however, I must say, N64 worked best when Recalbox still was freshly installed with the only change being the change to CEA 1. That means there is likely some chance to improve the overall performance by some settings in Retroarch, but I really don't get most of them (Latency, filtering, framebuffer emulation, store to CPU cache, GPU / CPU usage etc. - hell, what IS all that!? :D). But since messing around with all the options is half the fun, I'm happy 🙂
    Most of the (few) N64 games I would like to play run playable or perfectly already, so I will just wait for a new Recalbox version patiently.

    I have ordered a new SD card, the exact same my friend uses for the PI 3B, maybe that will reduce the long boot up time. And having 2 micro SDs allows for more freedom while trying out and comparing the best settings. I won't have to worry about messing things up, because I still have a functioning version as a backup.

    By the way, I found out about the tvservice -m CEA / DMT thing and did that in Putty to find out the prefered resolution on my TV, but in BOTH cases, it says "0 options in this group" or something like that. But... it's just a regular Full HD TV, so shouldn't it be 1080p? Anyway, CEA 4 HDMI for overall settings and CEA 1 HDMI for the N64 seems to work best.

    I keep enjoying this project, it's just awesome.


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @CidHigwind said in Problem with Argon One + PI 4B:

    By the way, I found out about the tvservice -m CEA / DMT thing and did that in Putty to find out the prefered resolution on my TV, but in BOTH cases, it says "0 options in this group" or something like that. But... it's just a regular Full HD TV, so shouldn't it be 1080p? Anyway, CEA 4 HDMI for overall settings and CEA 1 HDMI for the N64 seems to work best.

    This is strange, are you sure you typed correctly?

    Test again, just in case, with both commands
    tvservice -m CEA
    tvservice -m DMT

    If none work, just test tvservice and see the list of command options available for tvservice, see if any help you.



  • @Zing
    Yes, I typed everything correctly. I suppose it has something to do with the Argon One case and it's "translator" from micro HDMI to HDMI, because I once again lent the Pi 3B from my friend and tried the tvservice with the very same TV, and this time, there were different results. The prefered mode is CEA 16 (1080p), but since you said that would result in a slowdown, I'll stick with CEA 4.
    Right now, I'm formatting the new micro SD card to test if it will boot any quicker, but it will take a while: It came with exFat on it and I've read something about "use Fat32!", so I tried to formate the 64 GB card, but right after that long process was finished, it said "volume is too big for Fat32" and now I have to format it with exFat again. All the other cards were formatted in exFat, too, so I think using that will be okay.


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @CidHigwind

    from micro HDMI to HDMI

    Yes, of course, that adapter micro HDMI to HDMI must be the problem.

    The prefered mode is CEA 16 (1080p), but since you said that would result in a slowdown, I'll stick with CEA 4.

    With your current level of knowledge about videomode, I believe that you can test CEA 16 and analyze if there is any slowness that affects you, a Pi4 4Gb may not feel any slowness, and, if it really slows down, you already know how to go back.

    It came with exFat on it and I've read something about "use Fat32!"

    Currently, exFat is the standard format for the SHARE partition, it is recognized by Linux, Windows, MAC, and I see no need to use FAT32. Some people insist that FAT32 is better, and if you wanted to format in FAT32 and Windows is limiting, use a specific formatting tool (not the standard Windows tool), or, format with Linux gparted.



  • @Zing
    I just hope that during the conversion from micro HDMI to regular HDMI, no image quality or performance is lost. I can't do anything about it, because it is not an adapter, but part of the case (which I would like to keep, because all in all, the Argon One case is great!).

    I'll stick to CEA 4 HDMI, it's fine, and some N64 games lag already, so I think I'll just let it be.

    The new micro SD card didn't do anything, by the way, it still needs like 20 seconds until the intro video comes up. Maybe that will change with a newer Recalbox version, too, it's okay.

    (Small) Problems seem to keep coming up (sometimes the PS4 controller reacts veeery delayed which can only be countered by a reboot, after which everything is fine), but as I said, that's part of the fun for me 🙂



  • Update:

    Well, I thought it was "solved", but here's something strange: A friend of mine was so impressed by my Argon One + Pi4 console that he wanted me to build one for him, too.
    So, I ordered the exact same parts from Amazon that I used for my console, the only difference was that I used a micro SD card from SanDisk instead of Samsung.
    As you can see in the beginning of this very thread here, I had quite a troublesome start with my own console, adjusting the video output, so when the parts for my friend's console arrived, I prepared for the same ordeal. But: plug and play, the image was perfect at the very first start and there were no sound problems at all. So I thought, maybe my SD card is the problem and exchanged his console with my own (same cables) and put his SD card in my console - which resulted in a cut-off image and missing sound, just like in the very beginning.
    What the actual hell is going on? It was my understanding that there is no data at all on the Pi itself, so his console and mine should function absolutely identical when using the very same cables and SD card, shouldn't they?
    The only thing I did different with my own is that in the very beginning, when I wanted to install Recalbox on the SD card for the very first time with the imager 1.5, I was too stupid and merely installed Raspbian instead of Recalbox. I booted my console and wondered why it looked like a regular Windows desktop, so I formatted the SD card and found out you have to actually pick Recalbox in the imager.
    So...
    Could it be that with that very first try (Raspbian instead of Recalbox) I somehow installed something onto my Pi which causes all kind of problems?

    Also, I encountered another problem involving the controllers: I've bought a Shanwan PS3 controller copy which works quite well (only now I found out that you don't need a Bluetooth dongle at all...) as long as you use a cable. When connected via bluetooth, all the buttons still work great, but the vibration doesn't. So I changed PS3 driver in recalbox.conf from "bluez" to "Shanwan" and now everything works fine, except the fact that the control is going nuts in Dosbox. So, all in all, I have to chose between "works for every system but without rumble" or "works with rumble but not for Dosbox" when used via bluetooth.

    Maybe anybody knows a link to this whole Shanwan issue, especially concerning Dosbox?


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @CidHigwind

    Could it be that with that very first try (Raspbian instead of Recalbox) I somehow installed something onto my Pi which causes all kind of problems?

    I believe it has no relation.

    What the actual hell is going on? It was my understanding that there is no data at all on the Pi itself, so his console and mine should function absolutely identical when using the very same cables and SD card, shouldn't they?

    I have no way of knowing what exactly happened, but, I can say that your hardware is not necessarily exactly identical to his (although I am sure the technical specifications are the same):
    For example, some time ago there was an update for my smartphone, I updated it, and my screen looked strange. At this point I discovered that there were 2 manufacturers for the screen, with 2 different drivers, and, identical technical specifications, but only half of the users had the problem (only those from manufacturer "X"). I had to stay almost a month with the strange screen, until they corrected it in a later update. - I don't think that's it, but there is always that possibility.
    There is also the possibility that you have different revisions of the board, and / or different versions of the Firmware.
    There is also the possibility that you just have a lot of bad luck: going back to the example of my smartphone, I have been with it for about 2 years and I have not had any serious problems, but I know of acquaintances who bought the same model and mentioned several problems that I never had (and these people ended up buying another smartphone in less than 6 months).

    So, all in all, I have to chose between "works for every system but without rumble" or "works with rumble but not for Dosbox" when used via bluetooth.

    Sorry, but my first recommendation is: Running DOS games on the keyboard is better, I recommend that you use a keyboard (I know it's not what you want, but it's ideal, DOS games were not programmed for joysticks ).

    My second recommendation is: try to remap the joystick, perhaps directly in DOsbox:
    https://recalbox.gitbook.io/documentation/emulators/computosaures/dosbox

    If it still doesn't work, see if it helps:



  • @Zing
    Thank you again for your detailed response!

    Yeah, hm, concerning the different video output behaviour, I have no clue. I could disassemble both consoles and try if it's that adapter platine of the Argon One case, maybe mine doesn't work properly. But I think I can't give it back to Amazon, it's been too long already. And my console DOES work properly now, it's just strange that I had to do all kind of tricks for my own console and none of them for my second try. But despite this, the performance is the same with both consoles, so it's okay. I think I'm just afraid that my own console could be broken.

    As for the controller: I'm using Dosbox just for some oldschool platform games like Commander Keen which I have on Steam, and it's brilliant on TV with a controller. I already used the mapper (keyboard + mouse, Ctrl + F1 etc.) and it works perfectly, but only as long as I use a cable. I think it has something to do with the fact that the controller seems to be recognised as two different controllers: When I use an USB cable, Recalbox says "Shanwan PS3 Gamepad found", but when I remove the cable and connect the controller via bluetooth, it says "Playstation 3 Dualshock controller found". That's no problem as long as I keep the PS3 controller driver "bluez", the buttons I mapped in Dosbox work with and without the cable. But when I switch the driver to "Shanwan", the bluetooth version is totally screwed up, it's like all the buttons are numbered differently. Obviously, I should keep the "bluez" driver, but then the rumble feature doesn't work when I use bluetooth. Maybe I should try the other driver options like "official", too.


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @CidHigwind

    I think I'm just afraid that my own console could be broken.

    I have no way of giving a guarantee, BUT, in my opinion your console is not broken, and you were just unlucky to have to configure it (or, if you are optimistic, consider that: "you were lucky to have an opportunity to learn how to configure everything, and now you don't even need help" 😁 )

    But, about the joystick, the available options are to change the drivers by testing the 3 available, and choose the most functional.
    If you use an original joystick this should not happen, it is impossible for developers to test ALL possible hardware, so some driver incompatibilities end up happening...

    I don't think I can help you, but it may be useful to read:


Log in to reply
 

Want to support us ?

293
Online

82.0k
Users

22.5k
Topics

163.0k
Posts