Recalbox 4.0.1 + TV Cathodique VGA + RPi3



  • Bonjour,

    Je cherche désespérément comment configurer correctement Recalbox 4.0.1 tournant sur mon RPi3 et branché sur ma TV cathodique 4/3 à l'aide d'un câble Jack/VGA

    Après la lecture de multiples topic, j'ai modifié les fichiers config.txt et recalbox.conf et j'ai réussi à afficher l'image sur l'écran 4/3.
    Malheureusement, l'image saute/se décale.

    Je n'arrive pas à trouver comment changer la résolution dans recalbox et/ou les émuateurs afin de voir si cela améliorerait les choses... (tous les topics que j'ai lu/trouvé sont soit pour le RPi3, soit pour Recalbox 3 et donnent des lignes à modifier qui ne sont pas dans les fichiers recalbox.conf ou config.txt...)

    Qui peut m'aider?


  • Moderator
    Team

    @retlaw Salut,

    Tu peux nous donner ton /boot/config.txt ?



  • Pas de soucis !

    Alors, voici mon fichier config.txt

    uncomment if you get no picture on HDMI for a default "safe" mode

    #hdmi_safe=1

    disable_overscan=1

    uncomment to force a specific HDMI mode (this will force VGA)

    #hdmi_group=1
    #hdmi_mode=1

    comment to get jack audio

    #hdmi_drive=2

    config_hdmi_boost=0

    force hdmi while the tv can take time before sending the signal on the hdmi output

    #hdmi_force_hotplug=1

    uncomment for composite PAL

    sdtv_mode=2
    hdmi_ignore_hotplug=1

    uncomment for lirc-rpi

    #dtoverlay=lirc-rpi

    if you plug your tv at the same time as your rpi and that the rpi switches from the hdmi or give a low resolution because tv had no enough time to initialize it

    boot_delay=3

    uncomment if you don't want the rainbow at startup

    disable_splash=1

    Overclock

    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=512

    avoid_safe_mode=1

    kernel=zImage

    NOOBS Auto-generated Settings:

    #hdmi_force_hotplug=1
    overscan_scale=0

    Et le recalbox.conf au cas ou il vous soit utile.

    System Variable

    You can configure your recalbox from here

    To set a variable, remove the first ; on the line

    ------------ A - System Options -----------

    Uncomment the system.power.switch you use

    system.power.switch=PIN56PUSH # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    system.power.switch=PIN56PUSH # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    system.power.switch=PIN56PUSH # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    system.power.switch=PIN56PUSH # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    system.power.switch=PIN56PUSH # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    system.power.switch=PIN56PUSH # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    system.power.switch=PIN56PUSH # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)

    Recalbox Manager (http manager)

    system.manager.enabled=1

    Recalbox API (REST)

    system.api.enabled=0

    EmulationStation menu style

    default -> default all options menu

    none -> no menu except the game search menu

    bartop -> less menu, only needed for bartops

    system.es.menu=default

    Emulator special keys

    default -> default all special keys

    nomenu -> cannot popup the emulator menu

    none -> no special keys in emulators

    system.emulators.specialkeys=default

    Show or hide kodi in emulationstation (0,1)

    kodi.enabled=1

    Start kodi at launch (0,1)

    kodi.atstartup=0

    set x button shortcut (0,1)

    kodi.xbutton=1

    Kodi can wait for a network component before starting

    waithost is the ip or hostname that must answer to a ping to validate the availability

    waittime is the maximum time waited when kodi boots

    if waitmode is required, kodi will not start if the component is not available

    if waitmode is wish, kodi will start if the component is not available

    if waitmode is not set or has another value, kodi will start immediately

    ;kodi.network.waitmode=required
    ;kodi.network.waittime=10
    ;kodi.network.waithost=192.168.0.50

    ------------ B - Network ------------

    Set system hostname

    system.hostname=RECALBOX

    Activate wifi (0,1)

    wifi.enabled=1

    Wifi SSID (string)

    wifi.ssid=Retlaw********

    Wifi KEY (string)

    Escape your special chars (# ; $) with a backslash : $ => $

    wifi.key=****************

    Samba share

    system.samba.enabled=1

    Virtual Gamepads

    system.virtual-gamepads.enabled=1

    SSH

    system.ssh.enabled=1

    ------------ C - Audio ------------

    Set the audio device (auto, hdmi, jack)

    audio.device=jack

    Set system volume (0..100)

    audio.volume=92

    Enable or disable system sounds in ES (0,1)

    audio.bgmusic=1

    -------------- D - Controllers -----------------

    Enable support for standard bluetooth controllers

    controllers.bluetooth.enabled=1

    Please enable only one of these

    -------------- D1 - PS3 Controllers ------------

    ##Enable PS3 controllers support
    controllers.ps3.enabled=1

    Choose an driver between official, shanwan and gasia if you have dualshock clones (official,shanwan,gasia)

    controllers.ps3.driver=official

    ------------ D2 - XBOX Controllers ------------

    Xbox controllers are already supported, but xboxdrv can solve some compatibility issues

    Enable xboxdrv driver, disable this if you enabled ps3 controllers (0,1)

    controllers.xboxdrv.enabled=0

    Set the amount of controllers to use with xboxdrv (0..4)

    controllers.xboxdrv.nbcontrols=2

    ------------ D3 - GPIO Controllers ------------

    GPIO Controllers

    enable controllers on GPIO with mk_arcarde_joystick_rpi (0,1)

    controllers.gpio.enabled=0

    mk_gpio arguments, map=1 for one controller, map=1,2 for 2 (map=1,map=1,2)

    controllers.gpio.args=map=1,2

    DB9 Controllers

    Enable DB9 drivers for atari, megadrive, amiga controllers (0,1)

    controllers.db9.enabled=0

    db9 arguments

    controllers.db9.args=map=1

    Gamecon controllers

    Enable gamecon controllers, for nes, snes psx (0,1)

    controllers.gamecon.enabled=0

    gamecon_args

    controllers.gamecon.args=map=1

    XGaming's XArcade Tankstik and other compatible devices

    controllers.xarcade.enabled=1

    ------------ F - Language and keyboard ------------

    Set the language of the system (fr_FR,en_US,en_GB,de_DE,pt_BR,es_ES,it_IT,eu_ES,tr_TR,zh_CN)

    system.language=fr_FR

    set the keyboard layout (fr,en,de,us,es)

    ;system.kblayout=fr

    Set you local time

    Select your timezone from : ls /usr/share/zoneinfo/ (string)

    ;system.timezone=Europe/Paris

    ------------ G - UPDATES ------------

    Automatically check for updates at start (0,1)

    updates.enabled=1

    Update type : default to stable

    set to unstable at your own risk to get the development version.

    updates.type=stable

    ------------ H - HERE IT IS - GLOBAL EMULATOR CONFIGURATION ------------

    The global value will be used for all emulators, except if the value

    is redefined in the emulator

    Set game resolution for emulators

    select your mode from the command : tvservice -m [MODE]

    CEA 5 HDMI : 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced

    CEA 4 HDMI : 1280x720 @ 60Hz 16:9, clock:74MHz progressive

    use 'default' for using the default resolution or 'CEA 4 HDMI' pour HDMI (à faire aussi plus bas pour snes et n64

    (string)

    global.videomode=default

    Shader set

    Automatically select shaders for all systems

    ## (none, retro, scanlines)
    global.shaderset=none

    Once enabled, your screen will be cropped, and you will have a pixel perfect image (0,1)

    global.integerscale=0

    Set gpslp shader for all emulators (prefer shadersets above). Absolute path (string)

    global.shaders=

    Set ratio for all emulators (auto,4/3,16/9,16/10,custom)

    global.ratio=4/3

    Set smooth for all emulators (0,1)

    global.smooth=0

    Set rewind for all emulators (0,1)

    global.rewind=1

    Set autosave/load savestate for all emulators (0,1)

    global.autosave=1

    Enable retroarchievements (0,1)

    Set your www.retroachievements.org username/password

    Escape your special chars (# ; $) with a backslash : $ => $

    global.retroachievements=0
    global.retroachievements.username=
    global.retroachievements.password=

    Set retroarch input driver (auto, udev, sdl2)

    If you don't have issues with your controllers, let auto

    global.inputdriver=auto

    If you do not want recalboxOS to generate the configuration for all emulators (string)

    ;global.configfile=/path/to/my/configfile.cfg

    ------------ I - EMULATORS CHOICES -----------

    You can override the global configuration here

    Here is the snes example

    ;snes.videomode=default
    snes.core=snes9x_next
    ;snes.shaders=/recalbox/share/shaders/shaders_glsl/mysnesshader.gplsp
    snes.ratio=4/3
    ;snes.smooth=0
    ;snes.rewind=1
    ;snes.autosave=0
    ;snes.emulator=libretro
    ;snes.integerscale=0

    If you do not want recalboxOS to generate the configuration for the emulator :

    ;snes.configfile=/path/to/my/configfile.cfg

    Default cores for RPi3

    snes.core=snes9x_next
    gba.core=mgba
    mame.core=mame078
    nes.core=fceunext

    NeoGeo emulator

    You can use pifba or a libretro core (fba2x,libretro)

    neogeo.emulator=fba2x

    If you set libretro as neogeo.emulator, the line below sets the retroarch core (fba,imame4all)

    neogeo.core=fba

    N64 emulator is configured to display a screen with a 640x480 resolution (native n64 resolution)

    So you must use one of these video modes (DMT 4 HDMI,CEA 1 HDMI).

    If your screen is not compatible with one of these video modes, please check the recalbox's wiki.

    n64.videomode=default

    If you are using a CRT screen, please change the setting above with this one :

    n64.videomode=default

    Configurations generated by Recalbox

    odyssey2.emulator=libretro
    odyssey2.core=o2em
    segacd.emulator=libretro
    segacd.core=picodrive
    pcengine.emulator=default
    pcengine.core=mednafen_supergrafx
    pcenginecd.emulator=libretro
    pcenginecd.core=mednafen_supergrafx
    pcenginecd.autosave=0
    pcenginecd.rewind=0
    pcenginecd.smooth=0



  • Personne ne peux m'aider?

    Une chose surprenante que j'ai remarqué, c'est que quand l'économiseur d'écran se met en marche (l'écran s'assombrit un peu), l'image se stabilise !

    Si cette dernière remarque peut aider quelqu'un à m'aider...


  • Moderator
    Team

    @retlaw Essaie de passer l'affichange du Pi en NTSC



  • Merci substring.

    J'ai donc modifié les paramètres pour mettre "sdtv_mode=0". = Il y a du mieux, mais c'est loin d'être ça.

    Ce qui est nettement amélioré :

    • Le petit logo de lancement de recalbox et de chargement de jeux (manette blanche sur fond noir) ne bondit plus du bas de l'écran jusqu'en haut de manière répétée
    • L'image dans les jeux n'est plus décalée

    Cependant, ce qui ne fonctionne toujours pas correctement (cf vidéo en bas de post) :

    • Dans les jeux, l'image sautille de 1-2 centimètres, légèrement en diagonale vers la droite, et ce quel que soit l'émulateur
    • L'écran de chargement recalbox/Emulstation part en vrille
    • L'image dans le menu principal de Recalbox est stable mais divisée en 2, le bas de l'écran apparait en haut et le haut en bas, lorsque je navigue entre les logo des émulateur, l'image est centrée correctement
    • La police d'écriture des jeux est quasiment illisible.

    Une petite vidéo (filmée à la va vite) qui montre bien les soucis : https://www.youtube.com/watch?v=GknvpNhLe2k

    En espérant que cela puisse vous aider à m'aider


  • Moderator
    Team

    @retlaw e mémoire tu es bien le premier à avoir ce problème ... Tu es sûr de ta TV ? pas un réglalge propre à ta TV qui serait à l'origine ?


  • Moderator
    Team

    Bonjour
    j'ajouterai peut être es tu sûr de ton cable ?


  • Moderator
    Team

    Humm ça sent le problème de masse/vidéo inversé sur le jack du câble.
    Prends un multimètre et contrôle ton câble.

    cable_composite

    J'ai dernièrement acheté un lot de câbles composites en vrac dans un emmaus histoire de me faire un petit stock.
    Sur tout le lot, aucun n'était ok pour une utilisation sur le rpi (câble de camescope etc...).
    J'ai du tous les modifier.



  • Merci pour votre aide

    Côté câble :
    J'avais un problème de masse inversée avec un autre câble, l'image était alors en noir et blanc (en plus des problèmes décrits ci dessus).

    Avec le câble actuel, image en couleur sans avoir à trafiquer quoi que ce soit.
    (J'ai juste dû brancher le rouge du jack sur le jaune de la péritel (comme avec le premier câble), mais c'est une chose très commune à ce que j'ai lu sur internet...)

    Côté TV :
    J’avoue que je ne sais pas trop ce qu'elle vaut... J'ai acheté la borne d'arcade avec cet écran. Le mec qui m'a vendu la borne m'avait montré quelle fonctionnait à l'aide d'un PC branché dessus faisant tourner Hyperspin. Je n'avais constaté aucun problème...
    Je n'ai malheureusement pas la télécommande pour aller dans le menu cacher pour voir les réglages...

    Je vais continuer à chercher de ce côté là histoire de voir. Au pire, je dois avoir 2 vieilles TV cathodiques qui doivent trainer dans un grenier et qui fonctionnent parfaitement, je tenterai avec celle là, mais je devrais attendre mi septembre pour les récupérer...

    Sinon, il y à bien l'option Pi2scart. Mais les vendeur disent tous qu'il faut une version spécifique de recalbox ou de retropie et donnent le lien vers ces versions lors de la vente... Je ne sais pas trop quel suivi il y a la dessus, ni si cela résoudrait mon problème... Alors acheter sans savoir, j'hésite pas mal...


  • Moderator
    Team

    Pas forcément besoin d'un crt pour tester, les TV modernes ont également des entrés composites.



  • Sur TV moderne, aucun soucis, image stable à 100%


  • Moderator
    Team

    Ok dans les mêmes conditions ? Signal composite, config du rpi, etc ... ?
    Si oui alors très certainement problème avec ton crt.
    As tu essayé de lui envoyer autre chose que du PAL dans la tronche ?

    sdtv_mode defines the TV standard for composite output (default=0)
    sdtv_mode=0    Normal NTSC
    sdtv_mode=1    Japanese version of NTSC – no pedestal
    sdtv_mode=2    Normal PAL
    sdtv_mode=3    Brazilian version of PAL – 525/60 rather than 625/50, different subcarrier
    


  • Pour tester CRT vs LCD (58"), je débranche simplement les 3 câbles de la péritel sur le CRT pour les brancher sur mon LCD sans toucher à quoi que ce soit.

    Sur le CRT, j'ai testé sdtv_mode=0/1/2 :

    • 0 et 1 donnent le résultat visible sur la vidéo
    • 2 donnent le résultat décrit au début (=horrible)

    Ce qui m'étonne aussi, c'est l'image qui se stabilise quand je vais d'un émulateur à l'autre dans le menu principal de recalbox, alors qu'elle se décale une fois l'émulateur choisi... (visible sur la vidéo)


  • Moderator
    Team

    @retlaw si je comprends bien c'est pi -> jack/RCA -> adaptateur peritel -> TV ? Si oui, ta TV n'attendrait pas un truc genre SVideo sur cette entrée ? tu n'aurais pas une entrée RCA composite ?



  • Merci de continuer à m'aider !

    C'est un vieux cathodique, il n'y a donc que 2 prises péritel à l'arrière. pas d'autres entrées (ni RCA, ni Svideo)

    Je suis donc obligé de passer par le montage que tu as dis : pi -> jack/RCA -> adaptateur peritel -> CRT.
    Du coup, si la TV attends effectivement un signal Svidéo via la péritel, je ne peux pas lui fournir avec mon équipement actuel.

    En revanche, il est vrai que quand j'ai branché le RPi sur mon LCD pour tester, je dégageais l'adaptateur péritel et branchais directement sur les entrées RCA du LCD... Test fait à l'instant avec EXACTEMENT le même montage via la péritel du LCD (pi -> jack/RCA -> adaptateur peritel -> LCD) : contrairement au CRT, le résultat nickel... Il semblerait donc que cela ne soit pas un problème de signal svideo ou RCA attendu (à moins que je n'ai rien compris aux signaux vidéo ou que les LCD corrigent automatiquement les signaux reçus...)

    Du coup, si le montage pi -> jack/RCA -> adaptateur peritel -> CRT ne fonctionne pas, comment dois-je brancher mon RPi sur ma prise péritel de mon CRT ?

    • Dois-je acheter un adaptateur pi2scart ?
    • Ou bien un RetroTink ?
    • Ou autre chose ?
    • Edit : Je viens de voir sur ce site : http://www.journaldulapin.com/2017/03/21/peritel-vga-raspberry/ un adaptateur Rpi => VGA à brancher sur les GPIO qui est relié via un câble Cable RGB-SCART VGA sur la péritel. Cela pourrait-il fonctionner ?

  • Moderator
    Team

    @retlaw tu as essayé les 2 peritels ? Moi sur la mienne (bon apas avec ce cable), une entrée déconne un peu pareil, faut que je mette sur l'autre péritel. Genre la 1 marche, pas la 2



  • Merci de la suggestion, malheureuseent, déjà testé.

    • Une des 2 péritel n'affiche rien (on voit que quelque chose tente de s'afficher, mais rien n'apparait)
    • Celle qui affiche quelque chose donne le résultat de la vidéo

    :(



Want to support us ?

Join us on :

319
Online

28075
Users

14385
Topics

108946
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.