Recalbox crash avant la page Emulstation sur ecran PC VGA



  • Bonjour à tous,

    Mon problème est que ma Recalbox se lance correctement sur mon écran TV (HDMI) mais pas sur mon écran d'ordinateur (convertisseur HDMI to VGA) intégré dans mon Bartop.

    Je m'explique, sur mon écran TV (port HDMI), le lancement de la Recalbox est correct, tout va bien.
    Mais lorsque que j'essaie de lancer la Recalbox sur un écran d'ordinateur 4/3 (celui que j'ai monté dans mon bartop), celle-ci se lance et "crash" juste avant l'affichage de l'écran "Emulstation".
    (Je précise que l'écran est fonctionnel. il marche avec une tour d'ordinateur et arrive à afficher le lancement de la Recalbox. Ce n'est pas un écran noir. J'ai également essayé sur un autre écran TV (HDMI) et la Recalbox se lance correctement).

    Par étape, lorsque j'active mon Bartop :

    • J'active l'interrupteur du Bartop (Relier au Raspberry pi3 et à l'écran).
    • Un carré de couleurs rouge, jaune, bleu clair, bleu foncé apparaît sur tout l'écran.
    • Puis une fenêtre blanche avec la manette et le logo Recalbox s'affiche avec écrit "For recovery mode hold [SHIFT]".
    • Puis l'écran affiche "plus de signal" et c'est reparti pour une boucle infinie jusqu'à ce que j'appuie sur l'interrupteur du Bartop pour stopper le courant.

    Je précise que l'écran de mon bartop est un écran plat 4/3 et qu'il est branché au Raspberry par l'intermédiaire d'un convertisseur HDMI to VGA acheté sur le site "Smallcab" http://www.smallcab.net/convertisseur-hdmi-vers-pour-raspberry-p-995.html.

    Je précise également que j'ai essayé d'utiliser un autre écran d'ordinateur mais le résultat est le même que pour celui de mon Bartop.

    J'ai eu beau lire pendant des heures le forum Recalbox, je ne trouve pas la solution à mon problème.
    J'espère avoir été compréhensible et que quelqu'un pourra m'aider.

    Merci d'avance.



  • Bonjour,

    Il faut que tu règle le paramètre vidéo en défaut dans le recalbox.conf

    je peut, peut être me tromper mais je pense pas que ce soit bien grave.

    Un petit lien : Configuration pour bartop



  • Merci pour cette réponse.

    J'ai lu le lien que vous m'avez envoyé.
    J'ai réussi à ouvrir le fichier "recalbox.conf" avec le logiciel Notepad ++. Jusque la rien de compliqué.
    J'ai réussi à trouver la ligne "set game résolution" mais une fois arrivé à ce stade, je ne vois pas ce qu'il faut faire. Je ne vois pas ce qu'il y a à modifier. Tout semble par défaut.

    De plus, il me semble que ces paramètres servent à la résolution graphique des émulateurs de jeux et non à l'interface graphique de la Recalbox (du démarrage jusqu'à l'apparition de la fenêtre ou l'en peut naviguer pour choisir la console sur laquelle l'on veut jouer. Mais ce n'est qu'une supposition de ma pars).


  • Moderator
    Team

    Bonjour
    il y a de nombres sujets sur les adaptateurs hdmi dvi une simple recherche t'aurait déjà beaucoup aidé.

    Voici quelques réglages à faire connectes-toi via ssh ou winscp pour modifier les fichiers.
    https://github.com/recalbox/recalbox-os/wiki/acces-via-WinSCP-(FR)

    1. Mettre la partition en écriture en écriture
      mount -o remount,rw /boot

    2. editer config.txt , modifier cette ligne
      hdmi_drive=2 en #hdmi_drive=2

    3. Editer recalbox.conf , modifier cette ligne
      global.videomode=CEA 4 HDMIen global.videomode=default

    Sauvegarder et rebooter le raspberry
    Liens wiki :
    https://github.com/recalbox/recalbox-os/wiki/partition-en-ecriture-(FR)
    https://github.com/recalbox/recalbox-os/wiki/Connectez-votre-recalbox-à-un-écran-DVI-(FR)
    https://github.com/recalbox/recalbox-os/wiki/recalbox.conf-(FR)`



  • Bonjour,

    J'avais déjà eu connaissance de l'étage 2 et 3 que vous avez cité.
    J'ai déjà essayé de faire les modifications relative à ces 2 étapes et cela n'avait pas fonctionné pour mon cas.

    J'ai réessayé les 3 étapes suite à votre commentaire, mais le résultat reste le même.



  • @geoone06 nope. Ce paramètre est pour la résolution des émulateurs, donc APRÈS lancement de ES. Le symptôme ressemble à celui des DVI, donc il faut appliquer ce que dit acris :)



  • @Dweilf tu DOIS faire l'etape 2 justement. Sinon il faut que tu nous donne led références de ton moniteur pour qu'on te dise quoi d'autre changer si cette etape 2 ne te permet pas d'arriver au moins à EmulationStation



  • L'étape 2 est fait. Aucuns changements.
    Par moniteur vous entendez "l'écran PC" ?
    Le problème est que pour monter cette écran dans la box de mon Bartop, j'ai enlevé tous les plastiques afin de gagner de la place. Je n'ai donc aucunes indication sur l'appareil.


  • Moderator
    Team

    Bonjour
    en ssh essaie d obtenir le résultat de la commande tvservice voir en bas de page: https://github.com/recalbox/recalbox-os/wiki/Video-configuration-detailled-(EN)



  • Pas sur que tvservice renvoie un résultat probant puisque qu'il se rate sur le mode "preferred". D'où le besoin de connaitre la marque et le modèle



  • La commande tvservice sert à voir les caractéristique du moniteur ?
    Mais sur mon "écran PC", je ne peux pas me connecter à la Recalbox. La Recalbox s'éteint et se rallume toutes les minutes. Je suis obligé de passer par mon écran TV.

    Je ne comprends pas quand vous me dites "en ssh".
    J'ai fait :
    \RECALBOX\share\system\ssh
    Mais dans ce dossier sont présent 3 fichiers dropbear_xxx_host_key.
    Dois-je faire quelques choses avec eux ?

    Pour faire la commande "tvservice", je dois passer par le logiciel "winSCP" ?
    J'ai essayé de passer par ce logiciel et par la commande "Ouvrir une console" et copier/ coller la commande "# tvservice --help" comme dans le lien que vous m'avez donné, un message apparaît "L'hôte n'a pas communiqué depuis 15 secondes".

    Merci d'avance.



  • @Dweilf bon alors : tu peux editer el config.txt en appuyant sur shift quand noobs te le propose. Et profite pour regarder quelle résolution ton moniteur affiche, ca pourra nous renseigner

    Et ajoute @subs stp quand tu me réponds, ca ira plus vite pour moi retrouver les messages :)



  • @subs Désolé je ne savais pas.

    J'ai laissé toutes les connectiques de l'écran (boutons démarrage, volume, paramètre etc).
    Une fois avoir appuyé sur [SHIFT], la Recalbox arrête de redemarrer et je peux appuyer sur le bouton "paramètre" de l'écran.
    La résolution de l'écran est 1024x768.
    0_1472459821296_IMG_20160829_103544.jpg

    Voici une photo du config.txt avec la Recalbox branchée sur l'écran du Bartop.
    0_1472459526116_IMG_20160829_102036.jpg
    Désolé pour la qualité.



  • @Dweilf c'est ce que je pensais : le hdmi2vga que tu as n'est pas "si bien" que ca car il indique mal au pi les résolutions gérables par ton moniteur.

    donc, une fois à l'édition du config.txt, tu peux mettre :

    hdmi_group=2
    hdmi_mode=18
    

    Je te conseille de lire le wiki en anglais https://github.com/recalbox/recalbox-os/wiki/Video-configuration-detailled-(EN) Pour tout bien comprendre



  • @subs Je viens de lire le lien wiki pour essayer de comprendre.
    J'ai fait les modifications proposées mais le soucis n'est pas réglé.

    J'ai bien compris pour le "hdmi_group=2" mais le "hdmi_mode=18" m'échappe.

    Je me demande si le fait d'avoir modifier "recalbox.conf" n'y est pas pour quelques chose ?
    0_1472462979240_Capture.PNG



  • @Dweilf non le recalbox.conf n'intervient pour le coup que pour le lancement des émulateurs. Toi tu n'arrives même pas jusque là.

    La liste des modes DMT : http://elinux.org/RPiconfig

    On dit simplement au pi de démarrer en 1024x768 parce que ton adaptateur VGA est à la masse pour le coup.



  • @subs
    Mon soucis est réglé.
    Le problème venait à la fois des valeurs "hdmi_group=2, hdmi_mode=18".
    Maintenant je comprends mieux le fonctionnement et je saurai m'en sortir si je dois changer d'écran (On ne sait jamais).

    De plus, lors de mon achat du convertisseur HDMI2VGA, je n'avais pas remarqué qu'il était doté d'une prise micro usb. Il semblerai que le convertisseur n'est pas assez alimenté en électricité pour le raspberry pi 3. Ayant une multiprise dans mon bartop, j'ai connecté le cable usb à une prise secteur. C'est un petit bidouillage mais ça fonctionne.

    Un grand merci à tous pour votre aide !!!



  • super alors, impec :)



Want to support us ?

Join us on :

197
Online

28828
Users

14644
Topics

110698
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.