Recalbox 7.0

GameBoy depuis 6.1.1: les shaders retro font ramer



  • Bonjour, de puis la 6.1.1 en fresh install les 3 filtres dot green font ramer grave l'émulateur par default.

    Une idée de la cause ?



  • @jrbaka Salut
    Perso je suis en dot-green, sur Gambatte, et ca tourne en 59.70 constants...
    tu as essayé déjà en désactivant le Wifi, le Recalbox manager... voire en modifiant le core à MGBA (fonctionne bien pour moi également...) ?
    A noter que sur ma config je suis sur un OC à 1050 (dans fichier config) avec plaque de cuivre...
    Mais étrange que la maj fasse ramer si utilisation d'un filtre...


  • Screenscraper
    Developer
    Global moderator
    Team

    @jrbaka Oui nous avons pu en trouver la cause.

    Suite a quelques crash aléatoire de certains cores Retroarch (certains crachaient au gré des bump, ou simplement aléatoirement...), et sur recommandation de Retroarch, nous avons forcé le settings video_threaded à 0.
    Mais en effet, avec certains shaders gourmands, le GPU ne tourne plus en parallèle du CPU ce qui peut causer quelques lags/ralentissements.

    Il y a une solution plutôt simple, avec les nouvelles surcharges de la 6.1:

    Créer un fichier nommé .retroarch.cfg, soit dans le repertoire roms général (pour réactiver l'option pour tous les émulateurs, mais je le déconseille fortement!), soit dans le(s) repertoire(s) concernés (GameBoy dans notre cas).
    Puis dans ce fichier, insérer la ligne: video_threaded = true (avec un retour chariot en fin de ligne par sécurité 😉 )

    Et c'est tout. Ce fichier surchargera la configuration de façon dynamique, à chaque lancement de jeu.

    Il est conseillé de n'activer l'option que pour les cores qui le requièrent, et uniquement si on ne constate aucun crash aléatoire. Dans le cas contraire, utiliser un shader moins gourmand pourra également résoudre le soucis 😉



  • @bkg2k sans effet chez moi cette manip

    au cas ou, mon archive quand un jeu gb tourne: archive


  • Screenscraper
    Developer
    Global moderator
    Team

    @jrbaka Ooops, au temps pour moi, c'est video_threaded = true et non pas threaded_video = true
    Edit: Du coup, j'ai corrigé dans ma première réponse pour les futurs lecteurs qui auraient le même soucis.



  • @bkg2k une correction sera faite dans une prochaine version ?


  • Screenscraper
    Developer
    Global moderator
    Team

    @tatieu Si aucun crash n'est remonté après avoir activé l'option, nous pourrons envisager de la réactiver uniquement pour cet émulateur dans les versions prochaines.



  • @bkg2k j'ai eu la PS1 qui a ramé aussi avec le shader hq2.

    Cela dépend des jeu utilisé


  • Screenscraper
    Developer
    Global moderator
    Team

    @tatieu Dans l'absolu, la meilleure solution serait de trouver des shaders plus rapides.

    Si vraiment, il n'y en a pas, on peut réactiver l'option, émulateur par émulateur.
    Après, j'avoue que j'ai personnellement perdu beaucoup de temps, à bumper et tenté de trouver les raisons de crash plus ou moins aléatoires sur certains core (Atari ST entre autre), jusqu'à ce qu'enfin, je tombe sur la raison de tous mes soucis 😉



  • @Bkg2k parfait, merci ! En tout cas pour la GameBoy c'est parfait



  • Bonjour,

    Moi aussi j'ai du faire la manip car mes jeux snes, neogeo, mame ..... étaient injouables pourtant je n'utilise aucun sgader, juste des overlays, est-ce normal ?

    XU4 6.1.1 Fresh install / tout sur micro SD

    ------------ H - HERE IT IS - GLOBAL EMULATOR CONFIGURATION ------------

    The global value will be used for all emulators, except if the value

    is redefined in the emulator

    Set game resolution for emulators

    Please don't modify this setting

    This arch does not support the video mode switch

    (string)

    global.videomode=CEA 1 HDMI

    Shader set

    Automatically select shaders for all systems

    (none, retro, scanlines)

    global.shaderset=none

    Once enabled, your screen will be cropped, and you will have a pixel perfect image (0,1)

    global.integerscale=0

    Set gpslp shader for all emulators (prefer shadersets above). Absolute path (string)

    global.shaders=

    Set ratio for all emulators (auto,4/3,16/9,16/10,custom)

    global.ratio=auto

    Set smooth for all emulators (0,1)

    global.smooth=1

    Set rewind for all emulators (0,1)

    global.rewind=0

    Set autosave/load savestate for all emulators (0,1)

    global.autosave=0



  • @Evan02 bizarre par ce que ceux la passe bien chez moi avec shaders crt-pi et overlay...
    Les seul que j'au du modifié sont:
    FBA neo (pour les jeux gourmand genre CPS3)
    GameBoy (shader dot-green3)
    VirtualBoy (shader scanline)
    PrBoom
    PSX (pour les jeux en 3D)



  • Je viens d’installer la 6.1.1 justement pour ce nouveau shader Game Boy et depuis la Game Boy rame (sur Raspberry 3b+). Je suis obligé en jeu de rentrer à chaque fois dans les options de retroarch et de désactiver le shader (ce qui d’ailleurs me plaît mieux pour cette console finalement sans shader).

    Je ne suis pas doué et je n’ai pas compris ce qu’il faut faire dans ce que vous expliquez plus haut. 😭


  • Themer

    je confirme la meme chose que ce qui a ete dit, la Gameboy (noir et blanc) rame avec le shader "retro" alors qu'avant la mise a jour il ne ramait pas.
    C'est le seul émulateur impacté, les autres que j'utilise n'ont pas été impactés.
    La Gameboy Color ne rame pas avec le shader "retro" par exemple.

    PS : Tests réalisés sans éclair jaune apparents, ni du symbole de surchauffe



  • La cause et la solution sont un peu plus haut dans cette page.

    Voilà bisous



Want to support us ?

197
Online

79.1k
Users

20.3k
Topics

149.1k
Posts