Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Atari 7800 / Recalbox Raspberry 3+



  • Bonjour a tous, je viens de faire une nouvelle install sur mon Raspberry 3 de RecallBox 6.1 et tout semble bien fonctionner a l'exception de l'émulation de l'atari 7800.
    Je vois bien la liste des jeux et lorsque j'en sélectionne un et que je le lance un jeu (j'en ai testé une 12zaine) écran noir avec le logo atari dont les couleurs défilent, l'image atari est degeu et le chargement boucle...
    Cela peut il venir du bios copier dans le RB ? ou une autre idée peut être? 0_1570731470652_IMG_20191009_220959_resized_20191009_101030330.jpg


  • Screenscraper
    Developer
    Global moderator
    Team

    Le bios n'est pas compatible avec les roms EU ou US (je ne me rappelle plus de tête 😉 ).
    Donc c'est soit les roms US qui fonctionnent, soit les roms EU, mais pas les deux 🙂



  • ok merci ca explique mon problème , je vais essayer de trouver un bios US



  • Bonjour,
    J'ai constaté le même problème .... mais mon bios (U) est validé par Recalbox.
    Or mes jeux 7800 fonctionnait il me semble avant la version 6.0, je devais donc utiliser le bios (E).
    N'y a t-il pas de possibilité au moins de choisir le bios (E) ou (U) ? j'ai compris qu'on ne pouvait pas avoir les 2, mais au moins qu'on puisse choisir.
    Et pour nous français, ce serait plus logique d'avoir la version (E) qui fonctionne 😉

    Autre point sur les roms Atari 5200, est-ce que certaines personnes constatent comme moi un crachouillement qui couvre le son ? je précise pareil que mon bios 5200.rom est validé par Recalbox.


  • Tester

    @cyril92 said in Atari 7800 / Recalbox Raspberry 3+:

    Autre point sur les roms Atari 5200, est-ce que certaines personnes constatent comme moi un crachouillement qui couvre le son ? je précise pareil que mon bios 5200.rom est validé par Recalbox.

    Oui, ce souci est connu des devs (et réglé pour la prochaine version 6.1.1 si je ne m'abuse)



  • @chrebie Je te confirme qu'il faut que tu changes tes bios.J'avais ce soucis et depuis tout refonctionne. Par contre il y a 2 bios à mettre: le bios (U) et le bios (E).



  • @bkg2k said in Atari 7800 / Recalbox Raspberry 3+:

    Le bios n'est pas compatible avec les roms EU ou US (je ne me rappelle plus de tête 😉 ).
    Donc c'est soit les roms US qui fonctionnent, soit les roms EU, mais pas les deux 🙂

    Bonjour @Bkg2k ,
    Ce souci pourra-t-il être corrigé dans la version 6.1.1 ? Je pourrais comprendre qu'un seul bios ne puisse être utilisé (bien que cela reste dommage qu'on ne puisse pas forcer un bios sur un jeu en particulier), mais au moins qu'on puisse avoir le choix sur le bios par défaut EU ou US ?



  • Bonjour,

    Je me permets de remonter ce sujet car il n'y a pas eu de réponse.

    Après avoir installé la 6.1.1, certaines de mes roms Atari 7800 ne fonctionnent plus. Ceci est dû , je l'ai compris, au BIOS qui ne prend en compte que les roms US.
    Ce qui me 'contrarie' c'est que la 6.0 prenait les roms EU, ce qui me convient étant français forcément, et 90% de mes roms étaient donc EU.
    Je n'ai donc plus qu'une petite quantité de roms qui fonctionnent, et je n'ai donc vraiment pas envie de retélécharger à nouveau les roms que j'ai en US.

    Y a-t-il un moyen, même manuel de revenir en roms EU ? Stratégiquement parlant dans Recalbox, je touve que c'est une erreur de privilégier les roms US.

    P.S : je précise que j'ai quand même placé les 2 bios US et EU dans le repertoire des bios.

    Autre question sur les roms Atari 800/8 bits : les roms ne fonctionnent pas, bien que j'avoue ne pas avoir fouillé. Quelqu'un a-t-il une solution ou une marche à suivre pour arriver à les lancer ?

    Merci d'avance à la communauté.


  • Screenscraper
    Developer
    Global moderator
    Team

    Pour l'Atari 7800, le mieux est encore de retirer les bios. Tous les jeux fonctionneront sans soucis.

    Pour les Atari 800XL, l'émulateur prends un nombre de format assez conséquents. J'ai personnellement testé une bonne 50aines de jeux sur cette plateforme, sans rencontrer le moindre soucis (principalement des .xex et des .atr)


  • Themer

    Les roms EU a la place de US je suis pas trop d'accord car la sortie par défaut du RPI est en 60hz (idem sur PC) et donc faut manuellement forcer le 50hz si on veut pas de scrolling haché.(décalage entre la rom et l'affichage)
    Ça sera jamais parfait pour tout le monde peu importe les choix fait par l'équipe...



  • @Bkg2k L'Atari 800XL est bugger sur la 6.1.1 RPI3b, il y a de gros problème de son et parfois l'émulateur ne lance pas le jeu.


  • Screenscraper
    Developer
    Global moderator
    Team

    @secamfr Comme dit plus haut, personnellement, je ne rencontre aucun problème. Pour les problèmes de son, si mes souvenirs sont bons, ça vient du NTSC, passer l’émulateur en PAL devrait régler le problème (ou vice versa 😉 )

    Quand au jeux qui ne se lancent pas... Comme tous les émulateur, ça reste un émulateur. Il n'est pas parfait, et parfois un jeu ne passe pas dans un format mais passe dans un autre.

    Nous mettons à jours les émulateurs à peu prés à chaque version, mais les émulateurs comme celui ci évoluent très lentement. Il y a donc très peu de chances qu'il soit plus buggué dans la 6.1.1 que dans la 6.1 ou même la 6.0. Ce n'est pas exclu bien sur, mais c'est un émulateur que j'utilise souvent et je ne constate aucun dysfonctionnement important.



  • @Bkg2k merci pour ta réponse,

    Je teste dès que possible tes solutions 7800 et 800XL


Log in to reply
 

Want to support us ?

162
Online

78.7k
Users

20.2k
Topics

148.0k
Posts