Émulateur Amiga et TV grand écran



  • Bonjour 🙂

    Une nouvelle fois, je reviens vers vous pour essayer de résoudre un problème que je rencontre concernant l'utilisation de l'émulateur AMIGA.

    J'ai effectué quelques recherches, mais ce que j'ai pu trouver ne correspondait pas à mon besoin.

    Le problème: j'utilise l'émulateur AMIGA avec des roms WHDL (HLA) qui fonctionnent très bien lorsque la recalbox est connectée à un écran d'ordi (ceux sur lesquels j'ai essayé n'excèdent pas 22' de diagonale).
    Lorsque j'essaye de faire la même chose, sans rien modifier, en branchant sur une TV grand écran (testé sur 2 modèles différents), le chargement s'arrête après l'écran présentant le logo Amiberry.

    Je crois comprendre qu'il doit y avoir un problème de résolution, ou peut être de type d'écran sur lequel est branchée la recalbox. Je précise que je n'ai pas de fichiers UAE dans mon répertoire Amiga2000 (uniquement les roms lha, qui fonctionnent sur les écrans d'ordi).

    Dans ce sujet, il est évoqué des modifications à faire sur recalbox.conf pour "déclarer" un type d'écran. Est ce que cette directive peut s'adapter aux fichiers UAE? Si oui, est-ce qu'il faudra modifier ces fichiers à chaque fois que je changerai d'écran?
    J'ai également consulté ce sujet expliquant comment paramétrer un fichier UAE, mais ça ne correspond pas vraiment à mon cas de figure.

    Ma config:

    • RPI 3B+, non OC
    • Recalbox dernière version compatible avec le 3B+, soit 6.0


  • Complément à mon précédent message: le problème ne se pose que pour l'émulateur AMIGA. Pour les autres, tout fonctionne bien quel que soit l'écran.


  • Banned

    AH ben ca alors ! C'est ça mon pb alors ? Un pb d'écran ! J'ai le même pb avec whd uniquement



  • @ninjaw said in Émulateur Amiga et TV grand écran:

    AH ben ca alors ! C'est ça mon pb alors ? Un pb d'écran ! J'ai le même pb avec whd uniquement

    Si ça marche sur un écran d'ordi, c'est probablement le même problème 🙂

    Je pense qu'il y a quelquechose à faire du coté de la "déclaration" de l'écran dans le fichier uae.


  • Staff
    Global moderator
    Team

    Bonjour
    On se plait mais on a aucune information sur le modele exacte de la tv ni sur le nom du ou des jeux ni le ou les contenus du fichier uae si utilisé.....et aucune archive de support nest fourni lorsque le problème se présente.



  • @acris said in Émulateur Amiga et TV grand écran:

    Bonjour
    On se plait mais on a aucune information sur le modele exacte de la tv ni sur le nom du ou des jeux ni le ou les contenus du fichier uae si utilisé.....et aucune archive de support nest fourni lorsque le problème se présente.

    En effet, je me rends compte qu'il manque pas mal de chose (sauf l'uae, cf plus haut, je n'en utilise pas).

    Je regarde en parallèle pour vous faire une vidéo.


  • Staff
    Screenscraper
    Developer
    Global moderator
    Team

    Sur du 4K il se pourrait qu'il y ait des problèmes de mémoire vidéo. La resolution est forcée pour l'amiga ou pour le global? si c'est le cas, quel mode?



  • @Bkg2k

    J'ai laissé tous les paramètres par défaut, il doit donc s'agir également du mode par défaut.


  • Staff
    Screenscraper
    Developer
    Global moderator
    Team

    Essayer de mettre global.videomode à la valeur CEA 4 HDMI dans recalbox.conf (accessible via le webmanager)



  • @bkg2k

    Je viens de vérifier mon fichier recalbox.conf, apparemment, c'était déjà parametré comme ça:

    0_1555930902792_Capture d’écran 2019-04-22 à 12.59.19.png


  • Banned

    Pour ma part je viens de finir une serie de test sans succes:
    -J'ai enlevé l'overscan
    -J'ai teste 3 global.videomode avec reboot
    -J'ai tenté pas mal de reglages live dans amiberry avec reset

    Mais rien n'y fait, on dirait presque que le desarchivage ne se fait pas correctement, à ce sujet, c'est normal que nous voyons le gros logo amiberry exclusivement avec WHD ?



  • @Asaiel @ninjaw Salut, est-ce que par hasard vous utilisez les mêmes manettes sur votre TV que sur votre écran PC ?
    Moi j'ai eu le même problème mais sans changer d'écran, si j'utilise une 8bitdo NES30 Pro pas de souci, par contre si je passe sur une manette sans stick analogique (le pad de la playstation classic) il arrive que les WHDL (et uniquement ceux la) ne se lance plus !


  • Banned

    @secamfr said in Émulateur Amiga et TV grand écran:

    @Asaiel @ninjaw Salut, est-ce que par hasard vous utilisez les mêmes manettes sur votre TV que sur votre écran PC ?
    Moi j'ai eu le même problème mais sans changer d'écran, si j'utilise une 8bitdo NES30 Pro pas de souci, par contre si je passe sur une manette sans stick analogique (le pad de la playstation classic) il arrive que les WHDL (et uniquement ceux la) ne se lance plus !

    Effectivement ! C'etait bien mon pad, j'ai joué sans pad (recalbox manager) et l'outil "whdload pour amiberry" est apparu a moi immediatement pour la premiere fois. Cela signifie qu'on etait bloqué à l'etape zero, je ne l'avais jamais vu.

    Mon pad est la xbox sans fil avec dongle pc, je viens de booter avec la manette filaire freebox sans probleme



  • @secamfr

    Idem pour moi, je viens de faire deux tests suite à ton post:

    • Télécharger une rom au format .adf (Alfred Chicken)
    • Utiliser un joypad avec stick analogique (Xbox 1ère gen. avec adaptateur USB). J'utilisais auparavant les manettes pour boitier Snes de chez Retroflag.

    Résultats:

    • Sur l'écran d'ordi, adf et hla se lancent, et ce avec les deux manettes.
    • Sur le grand écran (thomson), le fichier adf se lance bien, mais pas le hla (blocage du chargement).

    Si je branche la manette Xbox, tout fonctionne sur grand écran, y compris les roms hla!!

    Un grand merci à @Secamfr, car je n'aurais jamais eu l'idée de changer les manettes, et à tous les contributeurs de ce sujet!



  • @ninjaw @Secamfr je profite de ce sujet pour vous demander si vos sauvegardes savestates fonctionnent depuis l'interface d'amiberry? Ca ne fonctionne pas pour les hla dans mon cas, mais c'est OK pour les adf (cf ce sujet).


  • Banned

    Je n'ai pas essayé, mais vu la specifité du whdloader ca ne m'etonne pas.
    Par contre on dirait que toi ca marche avec la meme manette ? pourrais tu detailler ? c'est une manette sans fil (xbox) ?
    Aussi branche tu tes moniteurs en hdmi ? se pourrait il que ce soit un conflit CEC ?



  • @ninjaw

    Tous mes moniteurs sont branchés en HDMI.

    Pour les manettes, outre celle que j’ai mentionnée plus haut, l’autre manette est filaire. C’etait une manette pour Xbox 1ere génération avec adaptateur USB.


  • Banned

    Ok la mienne est sans fil avec le dongle pc.
    J'ai essayé de desactiver le CEC mais ca n'a servi a rien, a chaque fois que le whdloader amiberry demarre avec la xbox il freeze, par contre si je demarre avec mes deux manettes ca passe, meme si j'ai lancé recalbox avec la xbox en priorité, amiberry ne le prend jamais en manette numero 1. Si je force les settings une fois en jeu je retrouve ma xbox en whdload.



  • @ninjaw @Asaiel @acris @Bkg2k Ok donc ce n'est pas un problème d'écran mais de manette, si la manette n'a pas de stick analogique ça à l'air de poser problème, je laisse Bkg2k regarder ça 😉


  • Staff
    Global moderator
    Team

    @Secamfr
    Effectivement
    Jai une tv 4k er une manette avec stick analogique et jai aucun probleme.


Log in to reply
 

Want to support us ?

317
Online

81.5k
Users

22.3k
Topics

161.6k
Posts