Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

[SOFT] Skraper



  • @bkg2k said in [SOFT] Skraper:

    Try the latest beta:
    https://www.skraper.net/download/beta/SkraperUI_Beta7.4.2.x86.7z
    https://www.skraper.net/download/beta/SkraperUI_Beta7.4.2.x64.7z

    Hi I found a bug in the latest 1.0.19164 Build #3609

    It's not possible to scrape roms (it says 0 games found) when on of the folders starts with a dot like this

    D:\Emulationstation.Neu.emulationstation\roms

    As i use Emulationstation as Windows portable version I need to keep this notation. Is it possible to fix this?


  • Staff
    Moderator
    Team

    It's not a bug, it's a feature (and for once, it's true).

    Skraper deliberately ignores 'hidden' folders à la linux and we cannot "fix" it as many users rely on this feature.


  • Revisor

    @lmerckx said in [SOFT] Skraper:

    @Bkg2k A big thanks for this tool. Very useful and, for me, the best scaper to use with Recalbox !

    I just made a small correction in the mix "ArcadeMoon":
    In ArcadeMoon.xml and ArcadeMoonPlus.xml, the first point of Vertical presentation (Portrait) should be 84,167.

    Hello @Bkg2k I downloaded the last version of Skraper (still a super-useful application).
    I'm not sure that the correction quoted above has been taken into account.
    Am I right ?



  • Too bad it was possible to use the folder structure in one of the older builds. The folder D:\Emulationstation.Neu.emulationstation\roms not hidden.

    As Universal XML Scraper is not supported anymore maybe you can put an option in one of the future builds?


  • Staff
    Moderator
    Team

    @lmerckx Yes you're right lol



  • Bonjour,

    Je viens d'installer skraper beta7.
    Au premier lancement pas de soucis, j'ai pu entrer mes identifiants screenscraper, et commencer la configuration.
    J'ai abandonné la configuration en cours de route.

    Maintenant quand je relance skraper, je n'arrive plus à entrer mon compte screenscraper : "l'authentification à échoué! 1 moteur par défaut"
    et si je clique sur suivant pour commencer la configuration j'ai le message "Impossible de télécharger la liste des systèmes de screenscraper !" et skraper se ferme.

    J'ai supprimé complètement le répertoire skraper et décompressé à nouveau l'archive bet7, mais c'est toujours pareil.

    J'arrive bien à m'authentifier sur le site screenscraper.fr

    Sauriez-vous où est le problème ?



  • Je pense que les serveurs ne fonctionnent de nouveaux plus, impossible de télécharger la liste des système aussi


  • Staff
    Moderator
    Team

    @xanax
    le week end les serveurs sont saturés inutile de scrapper.



  • @acris Effectivement, j'ai reussi à relancer skraper, mais je vais attendre un moment plus calme. Merci



  • Salut BKg2K je te fais part d'un soucis que j'ai sur mes scrapes Master System en .ZIP aucune image ne se fixe, en revanche si je les dézippes (.sms) ça marche nickel, le soucis est qu'il y a parfois des jeux avec deux fichiers .sms qui me donne deux fois la même image.

    Sinon super logiciel je l'ai adopté, mais pas encore dompté :)


  • Staff
    Moderator
    Team

    @Biblo
    Un zip = une rom
    Si tu as de multiples roms ça buggera.



  • oui quand c'est le cas notamment pour mes jeux PC FX je recompile en un seul .chd mais quand est il pour mes 1zip 1rom master system qui ne fonctionne pas?
    En faite le plus important est de savoir si je suis le seule à avoir se problème si c'est le cas alors c'est moi le problème ^^



  • Bonjour à tous,

    Je rencontre un soucis. Dans Skraper il est indiqué que j'ai droit à 2 moteurs de scrap. Sur screenscraper.fr, il est indiqué que j'ai droit à 7 threads. Comment faire coïncider ce chiffre (7) avec le nombre de moteurs autorisés dans Skraper ?

    J'ai essayé de relancer l'assistant et de mettre un autre utilisateur bidon avant de remettre mon utilisateur mais cela n'a rien changé.

    Une autre questions : quel est le bon format pour les "auto-cachés" et les "auto-exclus" dans "Liste de jeux" ? Dans le tutoriel vidéo de Recalbox ils disent de mettre une barre verticale (|) entre chaque mot. Exemple : "bios|demo|proto". Cela n'a pas l'air de fonctionner (j'utilise Skraper sous Linux à toute fin utile). Quand je mets juste "bios", le bios de la Neo Geo Pocket, par exemple, est bien caché. Si je mets "bios|demo|proto", le même bios n'est pas caché.

    Merci pour vos aides !



  • Un autre soucis sous Skraper (beta 8 - version 1.0.19164 Build #3609) : la génération des Mix "recalbox v1" semble contenir un bogue...

    Voici par exemple les 3 mixes de "Goof Troop" pour la SNES. Il semblerait qu'il y ait comme un soucis dans les zones transparentes, comme si d'anciens scraps y figuraient encore.

    France :
    Goof Troop (France).png

    Allemagne :
    Goof Troop (Germany).png

    Japon :
    Goofy to Max - Kaizoku-jima no Daibouken (Japan).png


  • Tester

    @tungstène "j'utilise Skraper sous Linux à toute fin utile"
    sous mono ou wine ?



  • @glook said in [SOFT] Skraper:

    @tungstène "j'utilise Skraper sous Linux à toute fin utile"
    sous mono ou wine ?

    Sous mono.


  • Tester

    bah c'est normal alors... ;)
    perso, ça tourne à peu prés sous mono depuis la version 6.4.0.198 de mono, avant ça faisait comme toi
    il reste des soucis, faut pas cliquer sur "vider le cache", les mixes sont foirés depuis peu (avant ça marchait) mais le scrape fonctionne...
    sous wine +dotnet, pas de souci



  • @glook Merci pour cette confirmation du bogue d'affichage. On ne peut pas dire que ce soit "normal" pour autant... Peut-être que les mots "repéré", "connu", "en cours de résolution" seraient plus adaptés ? ;-)

    Pour le nombre de threads incorrect, tu as aussi constaté cela ?


  • Tester

    @tungstène bah c'est surtout que depuis quelques temps, les libs png sont tatillonnes sur le format et mono les gérait à l'ancienne ;) , ça commence à fonctionner avec les nouvelles versions de Mono
    pour les threads, je viens de véirifer, c'est ok, ton souci est surement lié au changement des serveurs de ScreenScraper et pas à Skraper
    juste avant une nouvelle mise à jour de Mono, j'avais les mixes



  • @Bkg2k une fonctionnalité à améliorer : la gestion des erreurs de la WEBAPI. Par exemple les erreurs 400 (notamment celles dues au dépassement du nombre de requêtes quotidiennes autorisées) ne sont pas gérées. Du coup, Skraper termine ses scraps en roue libre (au lieu de s'interrompre et d'afficher un message explicite sur la cause du problème).

    (Je suis passé sous Windows pour mes derniers essais).


Log in to reply
 

Want to support us ?

227
Online

58808
Users

18415
Topics

138564
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.