Help setting up 8bitdo N30 pro to be used for N64 games



  • Hello,

    Very new to Recalbox and I’m very impress at how well the n64 games play out, but I can’t seem to set up my 8bitdo N30 Controller to work with the n64 layout. There is no option for the C buttons. Im running the latest version of recalbox 4.1.0 and I’m using a Mac to configure. Any help is greatly appreciated.


  • Moderator
    Team
    Moderator
    Translator

    @kguzm251 on the title you wrote about the NES30 PRO...
    If that‘s your case, the C Buttons are mapped to the right analog stick automatically, there is bo need to change anything.



  • @paradadf how can I test this? When I click on configure a controller there is no option to map those buttons. I tried testing it on super mario smash bros which to my knowledge the C buttons are used for jumping but nothing happens. Was I not suppose to configure the controller and yes it is the 8bitdo NE30 Pro. Thanks in admvance


  • Moderator
    Team
    Moderator
    Translator

    @kguzm251 first of all, the controller was configured by default. But you can always reconfigure it anyway. And THERE IS an option in the sequence to map the right analog in the ES menu. You configure just two directions (the axes).



  • @paradadf I apologize for my lack of knowledge, but when I configure the control the very first option is the D pad which I configure with their perspective arrows then I believe there is an option for Joy Stick and it only shows Left Up and Left Left.

    I don’t have the screen in front of me, but I believe it reads something a long the lines of if you don’t have a joy stick hold A to skip. So i skip this option and continue on to A, B, X, Y, L1, R2, L2, R2, L3, R3, but do not see right or left analog. On the retropie I recall seeing these options, but not on recalbox.

    If like you say it is configure by default I will “forget Bluetooth” re-paired it and try it without manual configuration.

    I will add a picture of the options made available when configuring later on to show you what I’m talking about, now it is very possible that when you connect an N64 USB controller those options become available. On retropie the system doesn’t recognize the type of controller simply reads USB Gamepad whereas recalbox recognizes the type of device and I’m guessing it display the buttons for them.


  • Moderator
    Team

    @kguzm251 You should understand that configuring a pad is made on the most common layout, which is SNES + PS3/XBOX. The N64 pad is totally out of that scheme.

    In your case, you need to write a custom mapping file for N64, which is not an easy play. We have to update the wiki according to 4.1, had no time yet.



  • @paradadf @substring Do you or anyone here can provide some insight on writing the custom mapping file? I would love to get back into Zelda Ocarine of Time, but at the present moment this limitation is holding me back. I did come a cross an old thread which addressed this problem, but according to the wiki it is meant for V3.3.0 ONLY and I'm guessing that it will not work on the current version 4.1.0


  • Moderator
    Team

    @kguzm251 for now, I really don't have time for some help about that. There are some good hints on the wiki + Recalbox 4.1 has sdl2-jstest that will help to find button numbers. Or just write down the current config and "reassemble" in the order you wish


  • Moderator
    Team
    Moderator
    Translator

    @substring there is no need to write a custom config with the nes30 pro. @kguzm251 just needs to configure his pad properly on ES and use the right analog stick for the C-Buttons.
    For every analog stick you just have to configure two axes (directions).


  • Moderator
    Team
    Moderator
    Translator



  • @paradadf I was able to connect the Nes30 pro via BT, one time and as you mentioned the right analog stick, function as the C-Buttons, however after a while I could not re-connect via BT anymore. I tried deleting paired BT devices and nothing. I even formatted the SD card and installed a fresh copy of NOOBS with recalbox. Is there a way to complete wipe the control configs off the system without doing a complete reimage? Also I tried to follow @Substring advice and testing the button, but when I tried to run the jstest I receive a message "Command not found" this also happens on my Mac Pro. on the raspberry pie 3 I get as far as determining which devices I have, but the last command does not work.
    -jstest /input/dev/js*
    -then jstest /input/dev/js0 > "Command not found"


  • Moderator
    Team

    @kguzm251 I never said jstest but sdl2-jstest



  • @substring Yes that's what I meant "sdl2-jstest". On my Mac after I enter this command I'm prompted for a password. When I enter my admin pw I get command not found.


  • Moderator
    Team

    @kguzm251 ssh to your recalbox to do that command ;)



Want to support us ?

Join us on :

319
Online

28101
Users

14394
Topics

108985
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.