Cannot pair Dualshock 4 controller in 4.1



  • Hi everyone,

    First of all thanks for the great work that went into the final release of version 4.1. I was especially excited since the changelog mentioned that Dualshock 4 controllers were funny supported via Bluetooth. It is hard going back to DS3 controllers after playing with DS4 controllers for a while so I tried to pair one of my DS4s yesterday but did not have any luck. I put the controller into pairing mode and a controller was recognised but I always got the message that recalbox was unable to pair the controller.

    Is there something I am missing? I have read that people with the generation 2 DS4 (the one with light on the touchpad) were successfully pairing these even in the unstable version.

    I'd like to hear if anyone managed to get his/hers too work and if there is a certain step I am missing.

    Any help would be appreciated.

    Thank you.



  • Yep, i have the same problem. May be someone have an answer for this question???



  • DS4 have been tested and reported working. When everything fails, you can still try https://github.com/recalbox/recalbox-os/wiki/Connect-bluetooth-controller-manually-(EN)#if-your-recalbox-version-is-41x-or-later



  • Thanks for this explanations, but i have still an another big problem. Now i can pair my dualshock 4 v2 through Bluetooth (without special dongle) directly to my raspberry pi 3, but after restarting the system (or after shut down) - my dualshock 4 is disappear again... In previous version (4.0.2) - all is was OK



  • I had the same problem, but only when the rpi3 is overclock. when I put it back at 1200mhz, I can pair my ds4 v2.



  • On my Pi 3 after the 4.1 update downloaded the first time I tried pairing my DS4, it worked. Then when I plugged in the USB drive and rebooted it, my DS4 wouldn't pair. I ran into other problems so I did a fresh install, after which the DS4 still won't pair.



  • I have an update to my problem. I use the internal SD card just to install Recalbox on, then a USB flash drive for console roms, and another for arcade roms. As far as I can tell, pairing the controllers doesn't pair it to the Pi itself, but rather pairs it to each devices settings. The problem is when I tried to just pair it with the other drive, it didn't want to pair. When I hooked it up with a USB cable for a bit, then unplugged it, it let me pair it. However, when I tried that same method later, it wouldn't work again. Does anyone have any ideas?


  • Moderator
    Team
    Moderator
    Translator

    A friend brought yesterday his ps4 controller and I was able to pair it with recalbox 4.1 by doing the following.

    1. I pressed the PS button to start it and while blinking I pressed the little button behind the ps4 controller to reset its paired devices.

    2. I turned on the pairing mode of the controller by pressing PS+SHARE buttons simultaneously, until a very fast blinking is noticed.

    3. On recalbox I looked up for controllers to pair and "Wireless Controller" came up, chose pair and the controller worked out of the box without further configuration. The PS button is the hotkey by default by the way.



  • @paradadf said in Cannot pair Dualshock 4 controller in 4.1:

    A friend brought yesterday his ps4 controller and I was able to pair it with recalbox 4.1 by doing the following.

    1. I pressed the PS button to start it and while blinking I pressed the little button behind the ps4 controller to reset its paired devices.

    2. I turned on the pairing mode of the controller by pressing PS+SHARE buttons simultaneously, until a very fast blinking is noticed.

    3. On recalbox I looked up for controllers to pair and "Wireless Controller" came up, chose pair and the controller worked out of the box without further configuration. The PS button is the hotkey by default by the way.

    I'm following this exact setup and I still get cannot find controller, while the thing is right next to the box blinking ready to pair.
    Weird thing is, if I plug it in via usb, it works fine. And no, I tried pairing it while it was connected via cable and without, neither way worked. Anything else I can try? Seems some peoples "just works" and others ..well... doesn't.



  • I am in the same case as you, impossible to pair my ps4 controller ,
    I did what Paradadf said but unsuccessfully.
    The recalbox sees my controller but when I select it, it search ... then tells me "can not associate the controller"

    For info: Raspberry pi3 b +



  • @samzdrone You tried "forget bluetooth controller" on ES and try to pair again ?



  • @dam yes i tried, now i have another problem ... update requested by recalbox, i allow and after reboot: lighting
    yellow



  • @samzdrone with ps4 joystick that´s OK ? You used what version ?
    If update to new version crash you need to reinstall recalbox :(



Want to support us ?

Join us on :

271
Online

31071
Users

15116
Topics

113740
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.