Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Pi3 will not connect over wifi after switching to channel 13 (terrible pi3 integrated wifi support)



  • So I had my network in 12 and I thought that switching to 13 in my case would improve my wireless coverage, so I did and now recalbox won't connect to it anymore. I tried adding country=ES to try and force channel 13 connectivity in /etc/wpa_supplicant/wpa_supplicant.conf but it still won't work. It just says "wifi configuration error" and I don't know what else to do. I don't know of any way of upgrading the firmware not even in terminal with this distro as there is no rpi-update or raspi-config. Could anyone please help?

    Thanks

    edit: I tried downgrading it to channel 12 again and rebooting the pi and the router, and disabling and enabling wifi again in ES, but it just won't work anymore! all the changes i did was adding that text into wpa_supplicant.conf (which i have also deleted in case it was conflicting with anything). my pi3 is literally 1-2m away from the router and no networks i can find are around the same channels as my router's wifi at the moment. what the hell


  • Developer
    Team
    Global moderator
    Translator

    @webodan 1 minute search and you would have found out that channel 12 & 13 aren't supported.



  • @paradadf I've been using channel 12 for quite a while now and it always worked. ... or so said my router.

    Right now I had wifi disabled on the pi3, so I've bumped down to channel 11 (and 10 too) and tried enabling wifi again. Still same wifi configuration error. even if i restart with wifi disable and try to enable it again. Nothing.



  • @webodan I also lost my wifi updating recalbox, maybe your issue is not with your channel? https://github.com/recalbox/recalbox-os/issues/1221



  • @kurt_ I'm running recalbox 4.0.0, my wifi is has been running on channel 11 ever since. I tried restarting the router and enabling wifi in the recalbox settings again. All I get is an ipv6 assigned and this never happened before. It only works over ethernet



  • @webodan Do u use hidden SSID?



  • Same problem here while that Raspbian support all wifi channel.
    For me, on the last channel supported (ch 6) = bandwidth / 2 😕

    Version 4.1 correct/will correct this problem ?



  • @Pepe No. Still no wifi on the Pi whatsoever. The only thing I could try is reinstall Recalbox all over again but it will be a major pain to manually copy over everything I had. Still the same Recalbox 4.0.0, wifi in channel 11, 2.4ghz, rechecked that the password and the SSID were properly inputted and (just in case) that I didn't have anything blocking the SSID in the router's settings. Everything is fine and dandy and even my shitty conceptronic USB wifi dongle I use in a livingroom PC works perfectly. I tested every single device I had lying in my home that could run on WiFi and I have no problems at all. Just the damn Recalbox won't connect. Something indeed went horribly wrong on the wifi support since I can't even go back to my previous settings without some hours of reinstalling chores in the middle. @Substring



  • @webodan Using channel below 12, i think u could try this:
    https://github.com/recalbox/recalbox-os/wiki/Manual-IP-settings-(EN)



  • @Pepe in those commands should i use eth0 or wlan0?



  • @webodan Eth0 for wired connection, wlan0 for wifi.



  • @Pepe Thank you for your help.

    I followed the settings explained, but I only edited wlan0 with a static ip (as i don't plan to use ethernet). Same wifi configuration error.

    If i can't get any more help I'm gonna try restoring a backup, as I have an img file of the SD card before it somehow crapped out just by changing the wifi channel and changing it back.

    In recalbox.log all I see is that it starts wifi and then wifi times out.



  • @Pepe if ti doesn't connect, setting a fixed IP won't help 😉

    the thing is that i don't remember at all the manual commands to test wifi ... wpa-supplicant is not really "user friendly"



  • @Substring I have recommended following the manual ip management instructions since in version 4.0 with the previous connection manager there is a dhcp management problem in wifi in certain cases / configurations, which at its time I could solve in my case by setting ip fixed. The symptom was the same as mentioned here, does not connect via wifi. There are many causes that can give that result and this is one of them. It is not very clear what happens to the user, at least to me is not clear with what he is commenting and trying things always provides information. I keep in mind what happened and I will not recommend further tests to users, the intention was to help not to disturb. Sorry for the inconvenience.



  • @Pepe it's worth trying your solution anyway 🙂



  • @Substring okie dokie, ten four, copied, message received 😢



  • I restored a backup and the wifi came back, it had the same settings as my previously faulty install had. Weird.



Want to support us ?

125
Online

78.5k
Users

20.1k
Topics

147.6k
Posts