Problem when leaving a game and entering another game after upgrade


  • Themer

    Firstly, I would like to thank for this new version, it is loading my hdd much faster than it was before, the temperature throw was the icing on the cake.

    While I was playing NES Castlevania yesterday, my son asked to put another, and when I entered the Hero game of the SG-1000, I simply had the black screen and the sound worked perfectly, I rebooted the recalbox, I went back in the game and reappeared image , Then put my son to sleep, leave Hero and enter Castlevania again, and then the black screen appears again, but with its sound.

    It will be some new configuration that I do not know, because when you see the settings, they are all kept.


  • Staff
    Developer
    Team
    Global moderator
    Translator

    The issue has been already reported. For example here:
    https://forum.recalbox.com/topic/6423/bug-emulateur-nes

    It is weird and we don't know why this is happening.
    Can you please change the update type to unstable and update again. Maybe it is related to a a bad download of the files due to overload yesterday o just bad luck.
    Please, let us know if updating to the unstable version solved the problem.


  • Staff
    Global moderator
    Team

    Hello
    may be corruption gamelist.xml
    backup your gamelist.xml in your computer
    killall emulationstation in ssh
    delete gamelist.xml
    reboot et try again.


  • Themer

    I followed the method of @paradadf

    Worsened my problem, locked on the screen that speaks of the bugfixes with nes 30 controller, my controller xbox 360, snes 30 and keyboard did not work in any way, I am disassembling my snes, to be able to format the microsd and I will download version 4.0.1 direct to see.

    https://github.com/recalbox/recalbox-os/issues/1196

    @acris Before the upgrade until I backup, but I have not restored them, I will see this


  • Staff
    Developer
    Team
    Global moderator
    Translator

    o_O
    Very weird.



  • @paradadf Updated to the unstable 4.1 release. Still have same issue. Roms play audio, no visuals



  • Reporting same issue here using 'stable' version 4.0.1. I can play one NES game and get black screen with sound in the background trying the second one. Additionally, I can´t play any 32X game. Did you really test this version before launching? Doesn't look like an stable version for me.



  • @paradadf
    Bonsoir, je viens de faire la mise à jour vers la version 4.0.1 (raspberry pi 3) et divers problèmes sont apparus :
    D'abord emulation station s'affiche mais sans les jeux qui sont sur le nas
    puis après 1mn, ça "recharge" et la certains jeux (du nas) sont présents, mais pas tous...
    j'ai redemarré à nouveau et emulation station s'est lancé en espagnol...
    j'ai quand meme tenté de lancer le jeux FF8 (qui fonctionnait sou la version 4.0.0)
    mais ecran noir puis retour vers emulation station ET la, emulation station n'affiche pas les jeux du nas
    le doom ne se lance pas
    donkeykong classic fonctionne correctement

    pour le son, je ne peux rien dire, je ne l'utilise pas
    pour le scrappeur : tous les fichiers scrappés sont correctement affiché avec les images et les informations...

    je reste connecté si tu as besoin d'info complémentaire

    ps merci pour tout ce qui a été fait jusqu'à présent et continuez, c'est génial !!!
    bon courage pour la suite 😉


  • Staff
    Developer
    Team
    Global moderator
    Translator

    @ptijo i don't speak french, sorry.
    Anyway, the developers are aware of the issues and are trying to solve it asap.



  • @jsianes the 32X issue resolved using a different romset. Incompatibility of my previous romset with new 32X emu?


  • Themer

    Let's go to my diagnosis, I had to disassemble my SNES all to be able to pick up the microsd - Ha Ha Ha Ha

    I downloaded version 4.0.1 straight from github and to my surprise, my keyboard did not recognize it until I made it work with my controls, changing the recalbox.conf directly in linux, but my HDD for some reason did not access the roms, the recalbox did not It enabled it just like that, luckily I got the entire 4.0 system backed up with my romset, gamelist and mix images that took a lot of work to get done.

    What I did was reinstall version 4.0 and believe me I am installing again via recalbox to 4.0.1 to see if it works right this time, if it behaves the same way, I will have to be able to keep 4.0 until they correct this problem.

    Ahh put the drivers on my keyboard back - a microsoft 800 wired



  • The 32X issue is solved by using a new romset. but playing 32X games I'm experiencing the same issue reported with NES: when trying to play for the second time you can´t see anything in the screen while you can hear the game in the background. I'm thinking to rollback to 4.0.0 version. This new stable version isn´t it.



  • Can't confirm any of the scenarios. Everything is running just fine.

    Start NES Game -> Play -> Leave Game -> Start another NES Game
    Start NES Game -> Play -> Leave Game -> Start 32X Game
    Play 32X Games

    All is working just fine.

    PI3
    4.0.1
    Bartop with Xin-Mo Dual Arcade


  • Themer

    @Nachtgarm look this https://github.com/recalbox/recalbox-os/issues/1196

    but, rockaddicted solved the problem

    @rockaddicted said in Bug Emulateur NES:

    recalbox.conf -> global.videomode=CEA 4 HDMI à remplacer par global.videomode=default

    Le temps d'un fix via une update.



  • Thanks @azvarel . The video mode conf works! If you want to modify manually:

    Connect to your Recalbox via SSH:

    ssh root@recalbox

    Edit file recalbox.conf:

    mount -o remount,rw /
    vi recalbox.conf

    replace:

    global.videomode=CEA 4 HDMI

    with:

    global.videomode=default

    Exit saving (:wq! ENTER)
    Restart Recalbox:

    shutdown -r now

    For me, this is an issue during upgrade. It seems the upgrade process doesn´t take into account if you are using an external hard-drive for the game library, updating the files in the SD card but not in the external drive.

    Please, review carefully for the next launch (4.1)



  • @jsianes said in Problem when leaving a game and entering another game after upgrade:

    For me, this is an issue during upgrade. It seems the upgrade process doesn´t take into account if you are using an external hard-drive for the game library, updating the files in the SD card but not in the external drive.

    Indeed, we're digging into this one once 4.0.1 bugs are solved



  • @azvarel I'm running global.videomode = DMT 35 DVI and it's working



Want to support us ?

306
Online

81.4k
Users

22.2k
Topics

161.4k
Posts