web interface not working



  • Title says it all. I just can't get into the recalbox 4.0 web config (all my browsers on all my systems say connection refused every time even if i type in the IP and the recalbox is up and running and accepting connections over SSH). could someone toss me a hint on how to get it back up?

    Thanks in advance.


  • Translator
    Translation Master

    @webodan is the web manager disabled in your recalbox.conf?



  • I have the same problem here. config says that the manager is enabled. i can access the share-partition with the explorer and i am able to start the virtual gamepad at h11p://192.168.178.xx:8080/ , but there is no manager when i remove :8080 ?!?!
    using win10 netbook with ie11 recalbox 4.1 on rpi3, latest image "master-rpi3-build-9085147"

    what went wrong?


  • Moderator
    Team

    @Ratte why didn't you even think about saying you're not on 4.0 ?



  • Ratte said in web interface not working:

    using .... recalbox 4.1 on rpi3, latest image "master-rpi3-build-9085147"

    @Substring:
    As much detailed as i can.
    ;-)


  • Moderator
    Team

    @Ratte you're using an old build, it s been solved and even improved since grin


  • Moderator
    Team

    @webodan have you tried http://recalbox/ from Windows ?



  • @Ratte you're using an old build, it s been solved and even improved since grin

    Thanks!



  • @Substring Hi, I ended up fixing this flaw by deleting the shutdown button files that I was editing to have shutdown functionality (they were /recalbox/scripts/rpi-pin56-power.py powerswitch.sh in that same directory and the switch script in /etc/init.d , then proceeded to write my own shutdown routine which is what i've been attempting today, since I wasn't happy with the speed of the shutdown nor the fact that I had to push it twice so that it would work. I remember that right after deleting the aforementioned files and commenting the power.switch line back the web interface would work again. It's odd I know but I didn't do any other change regarding the filesystem or the settings.

    ... one thing that does not work though, is getting into it by using the hostname (in my case it is a different one) under Linux, I need to type in the IP of the Pi. Oh well whatever.


  • Moderator
    Team

    @webodan linux uses avahi, so you shpuld append .local to the hostname



  • @webodan I'm having the exact same issue for the exact same reason. And now I don't know what to do. :(


Log in to reply
 

Want to support us ?

Join us on :

328
Online

28196
Users

14434
Topics

109211
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.