Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Can't Connect



  • @mazur ok can you try a traceroute to recalbox.com, archive.recalbox.com and www.recalbox.com ? Thank you



  • When i use my pc with firefox, i also get a timeout error to connect to recalbox.com sever.



  • recalbox.com itself means nothing, should try with www.recalbox.com. And as your are on the forum, i guess the DNS does work

    ooops it does work for me :

    # ping recalbox.com
    PING recalbox.com (217.70.184.38): 56 data bytes
    64 bytes from 217.70.184.38: seq=0 ttl=53 time=7.614 ms
    64 bytes from 217.70.184.38: seq=1 ttl=53 time=7.370 ms
    64 bytes from 217.70.184.38: seq=2 ttl=53 time=7.448 ms
    64 bytes from 217.70.184.38: seq=3 ttl=53 time=7.336 ms
    64 bytes from 217.70.184.38: seq=4 ttl=53 time=7.521 ms
    64 bytes from 217.70.184.38: seq=5 ttl=53 time=7.438 ms
    64 bytes from 217.70.184.38: seq=6 ttl=53 time=7.607 ms
    64 bytes from 217.70.184.38: seq=7 ttl=53 time=7.504 ms
    ^C
    --- recalbox.com ping statistics ---
    8 packets transmitted, 8 packets received, 0% packet loss
    round-trip min/avg/max = 7.336/7.479/7.614 ms
    


  • try pinging www.recalbox.com instead please



  • Been searching : it pings recalbox.com to say if you're connected or not. I guess we'll change that in 4.1 as this DNS is not accurate and points to nothing special. So the message NOT CONNECTED is a mistake



  • @Substring Thanks very much!



  • @Substring

    Same problem.
    Network settings show "not connected".
    But connection via SSH is fine.

    Strange thing is that scraping of ROMs works and tracking with retroachievements server also work as it should. But no updates possible.

    Yes, w-lan settings are correct, also looked in the config.
    I can ping WWW.recalbox.com but not recalbox.com - same with firefox via laptop.

    recalbox pings recalbox.com to check if we're "connected".

    The "www" has to be in the address.

    So how do we update to 4.1 if we get no connection with 4.0?



  • @DannyOcean easy pal ...

    4.1 is not here, we are taking care of that dns thing. We'd still have a few tricks up our sleeve anyway. I'd like to say it should be solved by the weekend as we're working on it, but it does not only depend on us



  • @Substring always easy :)
    Also wanted to say a big THANK YOU to you and your colleagues. Coders, forum admins, translators etc... :)



  • blog.recalbox.com also not working.

    forum.recalbox.com is fine ... strange



  • the blog is dead for months already



  • @digitaLumberjack @Substring

    Sorry for double post, but I wanted to let you know that there might be an easy solution to fix the "no connection" problem.

    If your host (gandi.net ?) supports .htaccess there might be an easy solution.

    In ISPconfig the domain has to be "RECALBOX.COM" (without www) and auto-subdomain has to be "www"

    The A records in the DNS setting:
    IP for www.recalbox.com is 163.172.153.70
    IP for recalbox.com is 217.70.184.38

    That is why the update is not working and the recalbox shows "not connected"

    To fix the problem the IP for recalbox.com and www.recalbox.com just have to be the same.
    Check the DNS settings and see the A record for yourself.
    The hoster (gandi.net ?) should be able to fix it.

    You also have to add the following code to your root .htaccess file:

    This redirects all non-www requests to your site to the www version

    RewriteEngine on
    RewriteCond %{HTTP_HOST} !^www.
    RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]

    The second line means: if the HTTP_HOST does not (!) start with (^) "www.", then put it in memory for the next line. The next line says: from what was captured in the previous line, match everything (.*) from beginning (^) to end ($) and save everything (inside the parenthesis) as $1. Then replace $1 with ""; plus the HTTP_HOST variable.

    And this would redirect all www requests to your site to the non-www version
    RewriteEngine On
    RewriteCond %{HTTP_HOST} !^my-domain.com$ [NC]
    RewriteRule ^(.*)$ http://my-domain.com/$1 [R=301,L]

    I really hope this helps, and everyone will be able to update :)

    Cheers



  • I am having the exact same issue - emulationstation does not recognize it's connected because the ping to recalbox.com fails. But kodi works fine.

    Any updates on this?

    Thanks!!!



  • @fegemo Not yet.. Waiting for 4.1 version..



  • Ping to recalbox.com does work for me now.



  • Hey guys. I did one test here. It is somehow related to my ISP. Whenever I try to reach (ping, traceroute) recalbox.com from my home Internet connection (picture 1), the packets all get lost. But if I try to reach the same address using my 4G connection (picture 2), it works just fine.

    Do you guys have any idea on the cause of this strange ISP-specific behavior?

    Picture 1 (using my home connection):

    0_1482342581948_traceroute-recalbox-from-home.png

    Picture 2 (using my 4G connection):

    1_1482342581952_traceroute-recalbox-from-4g.png



  • @fegemo I think is really some ISP problem.. because i use GVT/VIVO too.. and i get no connection, but i can connect with 4G like you.

    I tried today with last RecalBox (Unstable 4.1.0 build 63), same problem again..



  • @mazur as we said : dns problem. @digitaLumberjack seems not t have taken care of it yet



  • SOLUTION UNTIL IT IS FIXED UPSTREAM :
    edit ~/.emulationstation/es_settings.cfg and replace <string name="UpdateServer" value="recalbox.com" /> with <string name="UpdateServer" value="archive.recalbox.com" />



  • @Substring THX to Substring this Solution worked for me :)


Log in to reply
 

Want to support us ?

246
Online

61605
Users

18634
Topics

140018
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.