recalbox booten beschleunigen?



  • Hallo liebe Recal-Gemeinde,

    ich habe lange überlegt ob ich den retroPie oder doch die recalBox installiere.
    Seit vorgestern habe ich die recalbox auf meinem Raspberry Pi B laufen.
    Die Installation war abgesehen von der Formatierung der SD Karte (da SD Formatter 4.0 nicht funktioniert hatte habe ich 3 Stunden lang diverse Foren durchsucht bis ich die nötigen Programme für WIN10 zusammen hatte) sehr einfach.

    Mein Problem ist jetzt jedoch, dass das booten fast genauso oder länger dauert als die eigentliche Installation.
    Ich habe den raspberry hinter meinem Fernseher hängen und wollte in der TV-Werbungunterbrechung mit der Recalbox mir die Zeit vertreiben.
    Eine Werbeunterbrechung dauert in der Regel zwischen 5 bis 7 Minuten.
    Die Zeit reicht gerade so, dass das OS Bootet und ich ein Snes Spiel starten kann... und dann kann ich die Box auch schon wieder ausschalten weil der Film weiterläuft.

    Wenn ich den Pi starte kommt zuerst ganz kurz ein roter Bildschirm, dann für ca 40 bis 50 Sekunden ein schwarzer Bildschirm auf dem die aktuelle recalbox Version unten links eingeblendet ist. Dann kommt ein weißer Bildschirm mit dem RecallBox lade Logo.
    Dieser weiße Bildschirm benötigt noch einmal drei bis vier Minuten zum starten.
    Wenn ich jetzt ein SNES Spiel auswähle benötigt dieses noch mal zwischen 30 und 50 Sekunden zum laden.
    Ich habe festgestellt, dass wenn ich den Netzwerkstecker nicht in der Box habe das Laden nochmal länger dauert als mit einer Internetanbindung.

    • Sind diese lange Ladezeiten normal?

    • Gibt es irgendwie eine Möglichkeit das Laden zu beschleunigen?
      Wie zB. unötige wifi oder blutooth Treiber zu deaktivern?
      (Da der Pi trotz passiver Kühlung schon relativ warm wird und ich nur SNES spiele, habe ich von einer Übertaktung bis jetzt abgesehen.)

    • Gibt es eine Recalbox Version die auf den Raspbeery 1 B zugeschnitten ist (bei retroPie gibt es ja auch zwei Versionen)

    Vielen Dank im voraus
    Euer Struppelpeter

    Meine Systeminformationen:
    RecalBox: 4.0.0 Beta 5
    Respbarry Pi: B
    Kühlung: passive Kühlkörper auf den Chips
    SD-Karte: SanDisk 32GB Ultra SDHC1 class 10 (40 MB/s)
    Netzteil: 1,8 A
    USB1: Tastatur
    USB2: Microsoft Wireless Sender mit zwei Controllern
    Angeschlossen über HDMI am TV
    NETZWERK: LAN ist nur wen nötig angeschlossen.


  • Translator
    Translation Master

    Hallo @Struppelpeter
    Herzlich Willkommen bei uns :)

    Ich denke da ist etwas schiefgelaufen bei der Installation. Ich habe das Raspberry Pi 3 mit recalbox und das Booten dauert 20 - 30 Sekunden. Klar, das neue Raspi ist schneller, aber einen solchen Unterschied ist schon merkwürdig.
    recalbox ist für jede einzelne Raspberry Version zugeschnitten (1, 2 und 3).

    Ich denke @Nachtgarm kann dir an dieser Stelle sicher besser weiterhelfen :)



  • Hallo,
    ich habe jetzt das System zum dritten mal neu aufgesetzt aber die Ladezeiten sind immer noch so lang.
    Ausserdem ist mir aufgefallen, daß das recalbox Menü manchmal hängt und andermal die Auswahl wie im Turbomodus durchrast.
    Außerdem funktioniert bei den SNES spielen, egal was ich beim Emulatior ändere, die Musik nicht richtig.
    Die Musik ist immer etwas langsamer und ruckliger (wie bei einer Leierorgel )und definitiv nicht syncron.
    Liegt all das wirklich an der geringem Leistung meines B Modelles?

    Grüsse


  • Translation Master
    Team

    Moin @Struppelpeter

    Was für einen Pi hast Du? Einen RPi1 und wie viele Spiele hast Du in etwa auf der SD Karte? Und was genau funktioniert mit dem SD Formatter nicht?



  • Hallo @Nachtgarm,

    Ich habe den Raspberry 1B (alle Systemkomponenten die ich nutze habe ich oben aufgelistet)

    Das anfängliche Problem (das wird in vielen Foren heißt diskutiert) war , dass
    nach der Formatierung mit SdFormater4 ("FORMAT SIZE ADJUSTMENT" set to "ON") bei der Installation von der recalBox immer die Fehlermeldung
    "Error: Resizing existing FAT partition"
    "Error: The FAT don't match" gemeldet wurde.

    Die Lösung war zuerst diskpart (clean Befehl) benutzen, dann SdFormater4.("FORMAT SIZE ADJUSTMENT" set to "ON") laufen lassen und zum Schluss nochmal mit guiformat.exe
    (Standardeinstellungen) drüber und die SD Karte wurde endlich angenommen.

    Aber das System ist so irre langsam.
    Ich habe jetzt nochmal die Zeit gestoppt.
    Roter ladeschirm = 3 Sekunden
    Schwarzer Ladeschirm = 46 Sekunden
    Weißer Ladeschirm =3,38 min
    Laden eines SNES-Roms = min.36 Sekunden

    Bis jetzt habe ich mal 14 SNES Roms draufgezogen wovon aber keins anständig läuft ( siehe oben Problem mit der Musik)
    Außerdem habe ich mal 3 Nintendo64 Roms aufgespielt die ruckeln aber total.


  • Translation Master
    Team

    Klingt ja alles sehr abenteuerlich. Vor allem das Formatieren der SD Karte... Ich habe/hatte noch nie Probleme mit dem SD Formatter 4.0 und SanDisk Karten, gleich welcher Größe und ich habe bereits zig SD Karten damit formatiert.

    Womit ich auch schon beim Fehler bin. Diese brutal langen Ladezeiten liegen definitiv an deiner SD Karte.

    Ein paar Fragen:

    1. Welches Betriebssystem benutzt Du?
    2. Bekommst Du auf dem PI ein regenbogenfarbenes Viereck in einer der Ecken des Bildschirm angezeigt?
    3. Wie verbindest Du die SD Karte mit deinem PC? USB Adater? SD Kartenleser?


  • Hallo,
    ich habe auf meinem Rechner Win10 & noch Win7 installiert
    jedoch hat dieser kein Lesegerät eingebaut.
    Deshalb habe ich die SD-Karte auf dem neuen HP-Laptop (Win10) meiner Frau formatiert - der hat einen eingebauten Kartenleser.

    Ja den Regenbogen bekomme ich direkt als erstes Bild beim Systemstart angezeigt, jedoch ist der nicht in einer Ecke sondern zentriert und das Bild füllt fast den ganzen Bildschirm aus.
    Anbei die Bilder des Ladevorganges.

    Dieser Link hat mir mit der formatierung weitergeholfen
    Artikel von raspberrypi.org0_1474741115567_Regenbogen Ladeschirm.jpg0_1474741382461_schwarzer Ladeschirm.jpg 0_1474741390374_weisser Ladeschirm.jpg


  • Translation Master
    Team

    Danke für die Bilder, aber den Screen ganz am Anfang meine ich nicht. Der ist normal. Ich meine das sog. "Rainbow Square" in der rechten oberen Ecke des Bildschirms im laufenden Betrieb:
    0_1474793168428_xuZSMq5.jpg

    Zum SD Karte Formatieren: Der Artikel, den Du gepostet hast, bezieht sich auf SD Karten die größer sind als 32 GB und dann macht das auch Sinn guiformat.exe zu benutzen.

    Mach mal bitte folgendes:

    1. SD Karte in den Laptop deiner Frau
    2. CMD als Administrator ausführen
    3. DISKPART starten und wie folgt vorgehen
      3.1 LIST DISK
      3.2 Nummer der SD Karte merken und SELECT DISK <Nummer der SD Karte aus der o.g. Liste>
      3.3 CLEAN
      3.4 CREATE PARTITION PRIMARY
      3.5 ACTIVE
      3.6 FORMAT FS=FAT32 QUICK
      3.7 EXIT
      3.8 EXIT
    4. Dann den SD Formatter starten und die SD Karte mit "QUICK FORMAT, FORMAT SIZE ADJUSTEMENT OFF" formatieren.
    5. Den Inhalt dieser ZIP auf die SD Karte entpacken

    Dann in den PI und das System installieren lassen und dann bitte nochmal Bescheid geben, ob es gleich schlimm bleibt, oder sich etwas gebessert hat. :-)

    Zu den N64 Games: Natürlich ruckeln die und das bleibt auch so auf nem RPI1. Nicht mal auf nem PC laufen alle Spiele flüssig. SNES hingegen sollte immer flüssig laufen.

    Randnotiz: Warum besorgst Du Dir keinen RPi3? Für nicht mal 40 € sollte das doch gehen, oder? ;)


  • Translator

    Wegen Übertaktung: Ich habe hier einen RPi1 B stehen und den auf 1GHz hochgetaktet. Er ist in einem Gehäuse, nicht zusätzlich gekühlt (weder aktiv noch passiv) und 24/7 am laufen. Dennoch wird das Ding selbst im Sommer nicht heißer als 50-60°C. Sollte also keine Probleme machen...



    • den „Rainbow Square“ sehe ich werder in der recalBox noch im Kodi.

    ...so ich habe alles genauso gemacht wie du gesagt hast, aber jetzt kommt leider wieder die altbekannte Fehlermeldung (Error resizing existing FAT partition Warning... :-(

    Habe dann deine Anleitung mit verschieden Variationen ausprobiert:
    diskpart direkt ohne die CMD Befehl gestartet – macht keinen erkennbaren Unterschied
    Habe deine Zip direkt auf die SD entpackt und ein andermal erst die Zip auf dem PC entpackt und dann auf die SD gezogen.- macht auch keinen erkennbaren Unterschied
    SD-Formater:
    FORMAT SIZE ADJUSTEMENT OFF oder ON - macht auch keinen Unterschied
    Full (overwride) - macht auch keinen Unterschied dauert aber ewig

    Danach habe ich alle Variationen nochmal mit der der Version vom Downloadbereich versucht...
    Und zuletzt alle Variationen noch mit der Vorgänger Version recalBox Beta4.
    Es kommt immer die gleiche Fehlermeldung siehe Foto.
    Wenn ich diese Meldung mit ENTER bestätige kommt ein endlos Ladebalken (siehe Foto).

    Randnotiz: Habe erst vor wenigen Tagen den PI extra zum SNES zocken gekauft.

    0_1474828670817_ERROR FAT Partition.jpg
    0_1474828682309_waiting for SD.jpg



  • Nachtrag:
    Da ich gedacht habe, dass es nun an meiner neuen 32 GB SD-Karte läge habe ich gerade noch eine alte 4GB und eine 8GB Scandisk SD-Karte ausprobiert...
    Es wird immer die gleiche Fehlermeldung (mal abgesehen dass die Clusters verschieden sind) angezeigt.


  • Translation Master
    Team

    Das ist ja wie verhext, @Struppelpeter.

    Bist Du Dir sicher, dass das Laptop deiner Frau wirklich SDHC Karten korrekt lesen und schreiben kann? Der Fehler den Du bekommst - und auch anhand der Screenshots die Du gezeigt hast - sagt ganz klar, dass deine SD Karte nicht korrekt formatiert wurde. Das Gleiche trifft auf die anderen beiden Karten zu. Hast Du das Formatieren mal an einem anderen Rechner probiert?

    Ich kann es mir sonst nicht erklären, warum 3!! SD Karten bei Dir nicht korrekt formatiert werden. Es muss an der Art un Weise liegen, wie der Laptop deiner Frau mit SDHC Karten umgeht.

    Also:

    1. SD Karte mit Windows an einem anderen Rechner formatieren (Rechte Maustaste auf Laufwerk -> Formatieren -> Gerätestandards Wiederherstellen -> Schnellformatierung an -> Starten)
    2. Dann den SD Formatter starten und die Karte mit "QUICK FORMAT, FORMAT SIZE ADJUSTEMENT ON" formatieren.
    3. Laufwerk (SD Karte) SICHER entfernen.
    4. Laufwerk (SD Karte) wieder einlegen
    5. Die Dateien aus der aktuellen beta ZIP entpacken und dann auf die Karte kopieren.
    6. Laufwerk (SD Karte) sicher entfernen
    7. In den PI legen und beten.

    Das mit dem "Laufwerk sicher entfernen" ist der wesentliche Teil hier. Solltest Du dabei die Fehlermeldung bekommen, dass das Laufwerk nicht entfernt werden kann, weil es noch in Benutzung ist, ist das mit eine mögliche Fehlerquelle.

    Zusammenfassung:

    • Dass Du den "Rainbow Square" nicht angezeigt bekommst ist sehr gut, denn sonst wäre dein PI "underpowered" und auch das kann zu extrem langen Ladezeiten führen (bei nicht korrekt arbeitender PSU, oder zu schwacher PSU)
    • Anderen Kartenleser probieren, da nicht jeder eingebaute SD Kartenleser auch wirklich SDHC Karten unterstützt und dass dann zu solchen "Effekten" führen kann-
    • SD Karten IMMER sicher entfernen. Keine Ausnahmen!
    • Die Windows Formatierung benutzen, weil die gut mit Filesystemen umgeht und diese (in der Regel) immer richtig erstellt (mit der Option Gerätestandards wiederherstellen)

    Danach sprechen wir uns wieder, ok? :)



  • Hallo,
    das Formatieren auf einem anderem Laptop (Win7) hat funktioniert.
    DANKE!!!

    Jetzt benötigt der Systemstart „nur“ noch 1,26 min.
    F: Kann ich den Systemstart noch irgendwie beschleunigen zb. durch unnötige Treiber zu deaktiviren?

    Das recal- Auswahlmenü sowie die Slide Funktion laufen nach wie vor nicht flüssig aber damit könnte ich leben...

    Die SNES Spiele laufen flüssig jedoch ist die Musik immer noch so wie bei einer Leierorgel.
    Habe deshalb den PI auf 1000Mhz übertaktet jedoch ohne merkbaren unterschied.
    F:Bekommt man den Ton flüssig zum laufen?

    Das Monitoring Menü zeigt 244,5MB RAM an (siehe Bild).
    Ich habe den PI B Version2.0 mit Revisionsnummer 000d also 512 MB RAM.
    F: Liegt das ganze Problem vielleicht an einer falschen Speicherzuteilung?

    Viele Grüße
    Struppelpeter
    0_1474914082656_Ram Temp.jpg


  • Translation Master
    Team

    Die RAM Anzeige ist schon korrekt. Der Rest des Speichers wird vom System belegt. Das Einzige, was Du noch machen kannst, um den Boovorgang etwas zu beschleunigen, ist, NOOBS beim booten zu überspringen. Schaul mal HIER im WIKI - Mini How-To! Eine weitere Möglichkeit wäre, dir einen PI3 zu besorgen.

    Zu dem Soundproblem: Das habe ich so noch nicht gehabt, aber ich könnte mir vorstellen, dass dein PI1 B die Spiele in falscher Auflösung darstellt und demnach noch mehr Arbeiten muss, was bei der geringen Speicherleistung nicht von Vorteil ist. Schau Dir mal DAS HIER an und wenn Du damit nicht weiterkommst, nutze mal due SuFu. Ich meine, wir haben das schon ausreichend Diskutiert. Wenn nicht, mach einen neuen Thread auf. Dieser hier ist ja gelöst, da es ja "nur" um dein SD Karten Problem ging. Deswegen mache ich hier nun auch zu :)



  • Vielen Dank für die Hilfe.
    Ohne Noobs braucht mein PI nur noch 50 Sekunden zum starten. Klasse!



Want to support us ?

Join us on :

164
Online

28941
Users

14684
Topics

110922
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.