a few beginner problems?



  • Hello,

    my raspberry pi 3 arrived today and I first wanted to build an emulator box with recal box.
    I downloaded recalbox beta 5 and the installation was no problem.

    But I have still some problems:

    • no emulator is working. It looks like the game is starting but the emulator station comes back at once (for every emulator and every rom; seems to be a general problem.)
      ==> Do I have to make some configuration before everything is working?

    • I have a Dualshock 3 clone (Shanwan) and I connected it with USB because the internal Bluetooth is still not working.
      ==> everything works great except that the controller is constantly vibration (very confusing :-). Can I disable this? Is the internal Bluetooth working soon or do I have to buy a bluetooth dongle? with one is compatible and the cheapest :-)

    Can someone help me? Although I am a first time recalbox user I should have no problem with complex configuration files or if needed a little programming but currently I found no logs where I can find some clue where to start...

    regards,
    heiner



  • @heiner wiki

    hi , for which systems ? you have installed the bios ? the romset are good ?



  • I tried SNES. (as far as I know there is no bios for snes, is there?) But also the preinstalled roms are not working (no other system)
    the rom sets (smc files) work on zsnes on my computer)



  • @heiner you're right no bios for snes 😉 pre-installed games don't work?
    For your controller, mine also had the same problem! I re-installed it and now it works!!



  • Internal bluetooth won't work until 4.1 release. I believe to get your shanwan controller to work you have to open the recalbox config file and change the ps3 controller type to that. Instructions are in the config file.



  • the vibration is because of sixad that is trying to set the BT master address. Gotta disable sixad for that



  • I changed the controller from "official" to "shanwan" but it does not help.
    How can I disable sixad?



  • after some live tries, playing with a USB shanwan made it all crash



  • Hello,

    my BT dongle arrive but it does not work either :-(

    I bought a CSL BT 4.0 pico(!) - not nano. But BT seems to work because it does find several BT devices.
    But my gamepad is not found. I asked in IRC and got the steps:

    plug in BT dongle and start raspberry
    after start plug gamepad per USB in and press home button
    after some time (10 sec?) it should connect.

    But although everything is heavily blinking there is no connection.
    Any ideas how to get more information or how to solve this issue?

    regards,
    heiner



  • Try doing that with "shanwan" and "official" options to see if either makes a difference. You might also want to check your dongle is compatible Compatibility-(EN)



  • @heiner what you're supposed to do is :

    1. start your pi and wait until it reaches ES
    2. plug your USB cable. The controller may rumble after approx 10s
    3. once it was rumbling, unplus it, press the home key, and wait. Don't rely on the leds, they may keep blinking. Just try to move in ES, or reconfigure your pad. If you don't have any other controller, make sure your pi was plugged to network at boot, and go to http://recalbox/ and start the virtual pad. Press start, go to controllers options, map the pad


  • Hello,

    Now I have a BT Dongle from the compatibility list (CSL Nano) but still the same problem.

    1. I start the PI until ES is fully loaded
    2. I plug in my controller with USB
    3. after some time it starts vibrating
      3a. if I now press the home button the blinking four LEDs turn to permanent two LEDs
      3b. If I plug it off first and then press the home button nothing happens.

  • Moderator
    Team

    Hello
    check is shanwan with dmesg command line : https://github.com/recalbox/recalbox-os/wiki/PS3-controllers-drivers-(EN)

    you need to edit recalbox.conf to use good driver.
    this line : controllers.ps3.driver=official

    https://github.com/recalbox/recalbox-os/wiki/recalbox.conf-(EN)



  • dmesg output:
    29.493578] usb 1-1.3: Product: PS(R) Ga`epad
    [ 29.493585] usb 1-1.3: Manufacturer: ShanWan
    [ 30.068682] cfg80211: Calling CRDA to update world regulatory domain
    [ 33.228691] cfg80211: Calling CRDA to update world regulatory domain
    [ 36.388645] cfg80211: Calling CRDA to update world regulatory domain
    [ 39.548665] cfg80211: Calling CRDA to update world regulatory domain
    [ 42.708690] cfg80211: Calling CRDA to update world regulatory domain
    [ 45.868660] cfg80211: Calling CRDA to update world regulatory domain
    [ 49.028695] cfg80211: Exceeded CRDA call max attempts. Not calling CRDA
    [ 102.889873] usb 1-1.3: USB disconnect, device number 6



  • this comes after that

    [ 573.564112] input: ShanWan PS(R) Gaepad as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.3/1-1.3:1.0/0003:054C:0268.0007/input/input5 [ 573.565461] sony 0003:054C:0268.0007: input,hiddev0,hidraw1: USB HID v1.10 Joystick [ShanWan PS(R) Gaepad] on usb-3f980000.usb-1.3/input0
    [ 573.565585] sony 0003:054C:0268.0007: can't set operational mode: step 1
    [ 573.642813] sony: probe of 0003:054C:0268.0007 failed with error -32
    [ 573.736600] usb 1-1.3: USB disconnect, device number 11



  • I found a thread where some people had similar problems and they seem to solve it with a patched version of bluez:
    https://retropie.org.uk/forum/topic/42/shanwan-ps3-controller-pi3-retropie-3-6-bluetooth-setup/126

    it seems that you need a forked version of bluez:
    https://github.com/luetzel/bluez

    more details on: https://luetzels.raspiblog.com/?p=1870

    Maybe someone from the devs can fix the problem with this information?



  • hey

    this is how things are supposed to work :

    1. plug your shanwan with the usb cable.it should rumble after 10s. That is to set the master BT address for the pad. you can check the log in /recalbos/share/system/logs/controllers.log. If there is no (new) entry, then sthg is wrong
    2. next unplug the cable and press PS. After about 10s yourpad should be paired (despite shanwans may keep blinking). Once paired there is a log in /var/log/messages for the sixbin or six??? daemon. You should also have a new entry in dmesg

    could you try 'hciconfig hci0'and show me its output ?

    the retropie link can't be used for recalbox 4.0, and I'm working on the recalbox way to implement bluez5



  • hciconfig hci0

    hci0: Type: BR/EDR Bus: USB
    BD Address: 00:1A:7D:DA:71:15 ACL MTU: 310:10 SCO MTU: 64:8
    UP RUNNING PSCAN
    RX bytes:51027 acl:939 sco:0 events:1904 errors:0
    TX bytes:24258 acl:940 sco:0 commands:367 errors:0



  • this is in controllers.log
    after first plug in
    the controller is not rumbling:

    Current Bluetooth master: 00:00:00:00:00:00 
    Setting master bd_addr to 00:1a:7d:da:71:15 
    

    if I plug out and plug in again it starts to rumble:

    dmesg output:
    https://thepb.in/p/qjhLgOpQp55cB

    after second plugin the controllers.log looks like this:
    https://thepb.in/p/lOhOWoBG0xmUB

    new dmesg output:
    https://thepb.in/p/BghPxVgOB5WIY

    and out put to /var/messages:
    https://thepb.in/p/qjhLgOpAm0WUB

    these lines seems to be suspicious:

    Sep  9 19:52:01 RECALBOX daemon.info bluetoothd[299]: Terminating 
    Sep  9 19:52:01 RECALBOX daemon.info bluetoothd[299]: Stopping SDP server 
    Sep  9 19:52:01 RECALBOX daemon.info bluetoothd[299]: Exit 
    

    bluetoothd is terminating



  • I FOUND MY PROBLEM :-)
    For one or another reason the ps3 controller support was set to 0 (!!!!)
    I set it back to 1 and everything worked. I cant believe it....


Log in to reply
 

Want to support us ?

Join us on :

197
Online

29809
Users

14883
Topics

112111
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.