Recalbox 4.0 beta 5 et RCA



  • Bonjour, j'ai un problème pour envoyer l'image sur un écran cathodique en RCA, je m'explique.
    En version 3.3 beta 7 j'avais configuré mon fichier config.txt et tout marchait bien , j'avais le son et l'image sur mon cathodique ET sur mon écran HD sans jamais rien changer en switchant entre les 2.
    Aujourd'hui en 4.0 beta 5, j'arrive à envoyer sur le cathodique mais ensuite impossible de repasser sur mon écran HD sans devoir rebidouiller mon fichier config.txt , ce qui est très peu pratique...
    Je vous laisse un screenshoot de ma version 3.30_1472411848938_image.jpeg ( qui fait le taf) et de la 4.0 0_1472411887288_image.jpeg (qui marche juste sur cathodique ), si vous pouvez me dire quoi modifier pour arriver à avoir une version qui switch toute seule entre les 2 sans me prendre la tête.
    Merci d'avance pour votre aide!


  • Moderator
    Team

    Bonjour
    Pour configurer le RCA il existe ce tuto que tu as dû utiliser dans recalbox 3.3.x
    il faut aussi l utiliser sur recalbox 4.x.x, l'as tu modifié aussi ?
    https://github.com/recalbox/recalbox-os/wiki/Connectez-votre-recalbox-à-un-CRT-avec-composite--(FR)

    as tu essayé de modifier cette ligne dans recalbox.conf
    global.videomode=CEA 4 HDMI
    mettre
    global.videomode=default



  • @acris bonjour, oui bien sûr ce wiki a été utilisé , mais il ne permet pas de switcher HDMI <----> RCA avec cette config...



  • me demande is je n'ai pas vu passer un bug côté firmware pi qui justement corrigeait cette anomalie ...



  • @subs ok c'est bon ça marche, c'est le HDMI force outplug qu'il fallait mettre à 0 apparement et quelque autre bidouille que j'ai faite.
    Bref ça marche je peu switcher ca marche.
    Par contre j'ai un soucie, j'ai dû modifier recalbox.conf en mettant n64.videomode=default pour pouvoir lancer les jeux 64 sur crt, mais j'ai une image qui est calé en bas à gauche de mon écran (mais non rogné, juste pas centré et pas fullscreen), et depuis ce changement quand j'en passe en HDMI l'image est aussi en bas à gauche de mon écran , elle occupe 1/4 de l'écran...
    Je ne comprend pas d'où viens le problème car en 3.3.X tous était parfait, que ce sois sur le CRT comme sur mon écran HD.
    Une idée? Car devoir modifier chaque fois le .conf pour jouer au jeux 64 ca va être bien chiant!
    Merci pour le coup de main en tout cas!0_1472456278095_image.jpeg



  • @tontonduson la gestion de la résiolution de la n64 a changé avezc la v4. Aurais-tu un n64.videomode=DMT 4 HDMI qq part ?



  • @subs oui bien sûr j'ai ca
    0_1472458703380_image.jpeg
    Avec cette config je suis fullscreen sur le hd mais ça marche pas sur le crt.Dès que je commente pour que ça marche sur le crt et bien je récupère la video sur un petit quart sur mon HD.
    Je viens de tester en commentant/décommandant rien n'y fait
    Edit: je viens de modifier le fichier configs/mupen64/mupen64plus.cfg et je l'ai passer en True, ça marche!Sur mon CRT ET sur mon écran HD!
    Le problème maintenant est que sur le CRT aucun problème par contre sur mon écran HD ET bien ca ram de dingue! Une solution?



  • @tontonduson parce que l'option du fullscreen ne marche que moyennement. D'où sa désactivation. Il faut garder le n64.videomode



  • @subs ok mais ce qui est bizard c'est que sur mon CRT tout est centré et ca ne rame pas...je pige pas.Sachant que si je décommente pas n64.videomode=default (et que je laisse en false) et bien je suis en fullscreen sur mon HD et ca ne rame pas (mais ça ne marche plus sur mon CRT).Putain de casse tête!



  • @tontonduson facile : sur ta tv, tu n'es pas en 640x480 pour la N64, voilà pk ! Tu es en 1080p



  • @subs oui j'ai bien compris que c'est le 1080 qui fait ramer, mais comment rester en fullscreen 640 comme quand je n'active pas le CRT?



  • @tontonduson on a eu une issue là-dessus il y a qq mois ... m'en souviens plus



  • @subs ah merde...car en gros pour passer du HDMI "quasi fullscreen" au CRT , je vais chaque fois devoir decommenter le conf + aller passer le fichier mupen64plus.cfg en true, pas très pratique...
    Si jamais tu retrouve une manip pour m'éviter ça ce serait super sympa!



  • ton CRT affiche en quelle résolution ?????



  • @subs hum comment le savoir?c'est un Sony trinitron en 80



  • @subs sur internet j'ai trouver 720/576 je sais pas si c'est ca



  • oui donc DMT 4 (640 x 480) ca se trouve il aime moyen, il faut tenter une résolution plus basse. Tente CEA 2 ou CEA 6



  • @subs mais le problème ne viens pas du CRT (il affiche comme il faut surtout en true il est parfait) mais du HD qui occupe que 1/4 quand j'active le CRT.a moins que j'ai pas compris ce que tu dis



  • @tontonduson aie confiance :D fais ce que je te dis ;) Tu n'as aucune raison de toucher au fichier de config de mupen. Juste trouver une résolution pour mupen qui passerait sur tes 2 écrans. Je résume :

    • si tu mets n64.videomode=default ca rame sur HD (normal, parce que la N64 tourne alors en 1080p)
    • si tu mets n64.videomode=DMT 4 HDMI, là c'est ton CRT qui n'affiche rien, sûrement parce que la résolution est trop haute
      Conclusion : il faut que tu saches en quelle résolution marche la N64 sur ton CRT et que tu la forces au lieu de mettre defaults. Faisons autrement : fais en sorte que ca marche poru la N64 sur CRT, fais tourner un jeu et en SSH tape tvservice -s et tu me donnes le résultat. Et par pitié arrête de faire des photos à l'envers, copie/colle le texte :D


  • @subs ok je test ca demain,merci pour ton aide en tous cas.
    Pour les photos tu les vois à l'envers?moi ca s'affiche normal...je met des photos car j'ai ps de clavier qui marche sur mon mac (je fait tous depuis le tel,il sert de clavier),du coup beaucoup plus simple pour moi de mettre une photo.mais je vais essayer de trouver un clavier pour rédiger depuis l'ordinateur ;)



Want to support us ?

Join us on :

698
Online

28859
Users

14652
Topics

110752
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.