Recalbox seems to run really slow on Raspberry Pi Zero



  • So i just switched over from using Retropie on my Raspberry Pi Zero because i wanted to see what some of the other Emulation Station based OSs had to offer kind of hoping to get better performance as well because even with tweaking i was still having fps issues even with SNES games using Retropie. What i noticed was that i was getting fps issues with Recalbox as well and with SNES emulation. I used the built in overclocking option and it didnt seem to do anything. Is there something im missing or maybe something i can change in config file?

    Any help would be much appreciated, thank you.



  • Hi,

    You should try to use an other core like pocketsnes. (I don't remember where the option is, search on start menu ;) )


  • Themer

    @cerealfordinner As nosfay said, try to change the core used by the game causing trouble. When you're on the game , press select, edit its metada, choose libretro and another core.

    But there's no miracle, pi zero is maybe not powerfull enough for the emulation of some snes games (superfx ones), just as the pi1 wasn't either


  • Moderator
    Team

    No need to change the cores, the best one are set at build for each plateform

    The pi0 can't be overclocked i think

    And there are not that many emulators available on pi, so retropie and recalbox use the same.



  • @nosfay alright i did see that option when i was tinkering so i can look into that. It was weird though because when i was using Retropie i didnt have any slowdowns with these games. I did have issues with superfx games like Star Fox which i understand so im not too worried about that, but the game i was playing yesterday and having slowdowns with was Kirby's Dream Land 3 which i feel shouldn't be happening. Maybe i need to lower the resolution the games are playing at to improve performance? Maybe the default clock settings in Recalbox of 700 MHz are slowing down the Pi Zero? I really do appreciate the help guys :)



  • The 700mhz frequency is standard raspberry pi A clock, A and zero have same CPU, but on zero it's overclocked by default if you use raspbian for example (1100mhz) .

    Recalbox version is same for A and zero ;)



  • @nosfay So by having the default setting in Recalbox of 700mhz im not at a disadvantage even though the Pi Zero should be running at 1000mhz stock? Should i just put the settings to turbo since thats what the Zero should be running at anyway?



  • Yes, you can put it at 1ghz. I think it's 700 by default because of shared OS with raspberry A.



  • I have a pi 2 and I was experiencing slow games that had played fine in older versions of recalbox. It was suggested that I disable the rewind feature. I did and now the more demanding games play smoothly. You should try that.



Want to support us ?

334
Online

24260
Users

12898
Topics

97675
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.