Reporting test of my controllers; available to help adding support for new PCB



  • Hi all First of all,  I would like to thank Retroboy for this wonderful project. He and the entire Recalbox dev team deserve high praise from all retrogaming fans. I'm writing to inform the community about some hardware I have around, used to play MAME and other cool stuff in a PC... and now being transferred to a RPi2 running Recalbox. Some of this hardware already works great under 4.0.0b3, and some simply does not work at all. If the dev team is interested in adding support for some of this stuff in Recalbox, I'm available to help and test everything. I will just need some guidance. Regards Jonas --- Here's the hardware: 1) Dual control box built around an iPac2 (2007) and an OptiPac: The iPac2  works great,  just like an USB keyboard,  while the OptiPac, connected to an optical spinner in the X-axis, remains unresponsive (as expected); 2) A pair of fightsticks,  each one built around a Zurborg.info DualStrike PCB (keyboard/PC gamepad/PS3 modes selectable on demand). With these babies, the keyboard (MAME) mode does not work at all, the PC digital gamepad mode works perfectly while the PS3 mode is still untested. More info here: http://arcadeforge.net/GamePad-Key-Encoder/Dual-Strike/Dual-Strike::17.html 3) A Thrustmaster Firestorm Digital3, a basic 8 button game pad.  Works great as long as you can live without dedicated Select+Start buttons... I just used the bottom L+R pair as Select+Start. Makes a good SNES controller imitation, except for its crappy D-pad. Detected by Recalbox as "Mega World 2-axis 8-buttom gamepad". Funny...


  • Moderator
    Team

    Hello may be @subs might be helped have you tried this link with hardware that does not work : https://github.com/recalbox/recalbox-os/wiki/keyboard-encoder-configuration-(EN)) for each hardware doesnt work : DualStrike PCB et Optipac in ssh via putty can you type : /recalbox/scripts/recalbox-support.sh upload the created archive in zippyshare.com



  • @jonas dude, if your hw is configured and works without any further configuration, you're just lucky that the emulator supports it. You may have surprises with some other emulators ... anyway, as Acris told you, if you want us to take a deeper look into your sticks, please run the script she asked you :)



  • Dears @acris, @subs I have just tested the DualStrike PCB in keyboard/MAME mode, following your instructions. The xarcade2joystick trick described in the wiki seems to work. The stick is now responsive, with all directions (up/down/left/right) working correctly. Nevertheless these movements are way too sensitive. The cursor always jumps two/three positions in the menus, listings, etc. Probably this is some hardware oddity related to the physical joystick itself, and not a software/driver issue. I have not configured the buttons yet, all configs/mappings are still the default ones, but some buttons already work, so I guess we're good. For this keyboard encoder, you can find the output file generated by the script here: https://drive.google.com/file/d/0B3zyUG3z83_nRzFETXotek91NU0/view?usp=sharing The OptiPac will be tested as soon as I take the dual-fightstick box apart to separate the OptiPac from the internal USB hub... There's a big mess inside that other control panel box. Regards Jonas



  • Well, I could not separate the IPac out of my custom control panel box. So the script had to be run with both PCBs attached, that is OptiPac + IPac. Both were detected by the script. The OptiPac seems to be just like another standard USB mouse... The script output is here: https://drive.google.com/file/d/0B3zyUG3z83_nWGdzd295bUlVZlk/view?usp=sharing Hope this info is useful to someone. Regards Jonas



  • hey @jonas ! Sorry for the late reply Usually, when "multiple input ticks" happen, it's because it's sending both keyboard + joystick events. xarcade2jstick is supposed to exclusively take the original event devices, so that shouldn't happen ... A few people reported the ipac2 (older and newer version) to work, so i don't think it has something to do with it What do you mean "the optipac was detected by the script" ? Can you run a recalbox-support.sh with both plugged (and without xarcade2jstick running) ?



  • Hi, @subs, no problem! The "multiple input ticks" seem to be due to some issue in my Sanwa stick, as these happen even in Windows :-( No keyboard attached. Not a RPi, recalbox or xarcade2jstick problem. Just don't mind it. To sum up, the DualStrike PCBs seem to work as expected using the xarcade2jstck trick.

    What do you mean “the optipac was detected by the script” ? Can you run a recalbox-support.sh with both plugged (and without xarcade2jstick running) ?

    The shellscript was indeed run with both PCBs plugged and no xarcade2jstck running. I know the OptiPAC was detected because I searched inside the output files (link in the previous post), and found the corresponding hardware id strings somewhere. My initial intention was to run the script with only the OptiPAC attached, to avoid conflicts. But for now it's impossible to unplug any of the PCBs without taking everything apart. So the shellscript had to be run with both PCBs connected to the RPi. It worked perfectly, both the IPAC and the OptiPAC hardware id strings can be found easily in the output files. And nopes, the xarcade2jstck was not running, I switched it off and rebooted before calling the shellscript.



  • @jonas so besides you multiple ticks problem, you're all good to go ?



  • @subs yes, I'm ready. Let's see what we can do with these PCBs.


Log in to reply
 

Want to support us ?

Join us on :

225
Online

28916
Users

14669
Topics

110848
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.