pb touches Devil's Crush PCEngine



  • Hello,
    Sur recalbox 7.1.0/RPI4, j'ai un problème de touche avec Devil's Crush sur PcEngine: Le flipper de gauche ne se déclenche que sur l'action du joystick ! Je ne crois pas que ce soit faisable de mapper le joystick sur une touche? 🙂 Quelqu'un a t-il déjà résolu le problème ?
    PS: j'ai le bon bios PcEngine (MD5 OK) et j'ai testé avec plusieurs roms de Devil's Crush, le résultat est toujours le même


  • Staff
    Global moderator
    Team

    Bonjour @Philou33
    as tu tenté de changer d emulateur si disponible pour ta plateforme ?
    bouton select sur le jeu
    editer les données du jeu
    modifier emulateur



  • @acris : oui, j'avais testé les trois. le jeu se lance avec les deux premiers émulateurs (mais le problème de touche se produit) et ne se lance pas avec le troisième émulateur (fbneo)



  • Hello,
    Je ne suis pas sur d'avoir compris la question mais le jeu est comme ça. C'est le pad qui gère le flip gauche et le bouton II le droit. Une grande majorité de flippers sur console sont comme ça de mémoire.



  • @yogi_om : oui, ok, mais justement ma question c'est de savoir s'il y a moyen de faire un remap un peu plus propre afin d'avoir les deux flips sur de vraies touches.



  • @Philou33 said in pb touches Devil's Crush PCEngine:

    ! I don't think it's feasible to map the joystick to a key? Has anyone already solved the problem?

    Yes you can change the default keys. For example I have assigned L1 and R1 to flippers.
    (Button L= D-Pad Left and Button R= I)

    To do it, follow the next:

    • Press Hotkey+B (options for retroarch are shown).
    • Go to "Controls", now you can reassign the keys.
    • back and choose the option to save for this game.
    • Press again Hotkey+B (back to the game)

    Tip: The remaps files are saved in "share\system.config\retroarch\config\remaps" the place to save the rempas for pc-engine was changed in newer version of Recabox from folder "Mednafen SuperGrafx" to "Beetle SuperGrafx"



  • @RetroVadus , it's OK ! Thanks a lot.
    I didn't imagine that it could be possible to map D-Pad on a button! Great!

    Here is may config for this game, now:

    input_player1_joypad_index = 0
    input_player1_select_btn = "nul"
    input_player1_left_axis = "7"
    input_player2_joypad_index = 1
    input_player2_select_btn = "nul"
    input_player2_left_axis = "7"



  • Je complète suite à la lecture d'un post sur Mario Kart N64: apparemment il faut aussi mettre "input_autodetect_enable=true" sinon ça ne semble pas fonctionner (ne me demandez pas pourquoi, je ne comprends rien à cette option):
    Voici le positionnement de mes boutons sur ma bornes:

    Select
    X L1 R1
    B A Y

    Voici la config finale commentée (et qui fonctionne 😉 )

    input_autodetect_enable=true
    #Joueur 1
    input_player1_joypad_index = 0
    #pour bouger les flips: Flipper gauche et bouton A
    #Select sur joystick (controle le flip gauche)
    input_player1_select_btn = "nul"
    input_player1_left_axis = 7
    
    #Echange des boutons Start et B
    input_player1_start_btn = 5
    input_player1_b_btn = 6
    
    #Joueur 2, joue sur les mêmes boutons
    input_player2_joypad_index = 0
    


Want to support us ?

179
Online

82.1k
Users

22.6k
Topics

163.4k
Posts