Recalbox 7.0

Screen size on CRT TV



  • Hi everyone
    I connected my raspberry pi 3b to a sony trinitron CRT TV via composite cable.
    I followed this guide here:
    https://github.com/recalbox/recalbox-os/wiki/Connect-your-recalbox-to-a-CRT-with-composite-(EN)

    Fortunately, everything works perfectly. The only problem is that the image (both of the recalbox menu, and of Kodi and of the games, whatever they are) is cut and comes out of the screen.
    I would like to know how to adapt the screen properly.
    My TV's resolution is 720x480 60Hz interlaced, and its format is 4:3

    if it can be useful, here is my config.txt:

    #uncomment if you get no picture on HDMI for a default "safe" mode
    #hdmi_safe=1

    #uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=6

    #Sound output. Set to 0 or comment for autodetect, 1 for DVI, 2 to force HDMI.
    #hdmi_drive=1

    #Using /etc/modules is deprecated and no longer supported on 4.4 kernel
    #So manually enable audio
    dtparam=audio=on

    config_hdmi_boost=0

    #force hdmi while the tv can take time before sending the signal on the hdmi output
    #hdmi_force_hotplug=1

    #uncomment for composite PAL
    sdtv_mode=0
    sdtv_aspect=1
    hdmi_ignore_hotplug=1
    audio_pwm_mode=0

    #uncomment for lirc-rpi
    #dtoverlay=lirc-rpi

    #if you plug your tv at the same time as your rpi and that the rpi switches from the hdmi or give a low resolution because tv had no enough time to initialize it
    boot_delay=3

    #uncomment if you don't want the rainbow at startup
    disable_splash=1

    #default CEC name
    cec_osd_name=recalbox

    #Overclock
    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=448

    avoid_safe_mode=1

    kernel=zImage

    #Raise the first security limit up to 70° instead of 60°
    temp_soft_limit=70
    overscan_scale=0
    disable_overscan=1

    in the recalbox.conf I simply edited
    system.es.videomode=default
    global.videomode=default

    Thanks in advance for your support.



  • I have tried several times to adapt the screen through the manual configuration of overscan, but I still cannot get a satisfactory result. How can I correctly fill the TV screen? Ah, and one more thing:
    The recalbox-next theme is a little blurry on a CRT TV, and text are not see very well. Where can I find a more suitable theme for a CRT TV?
    Thanks for the support.

    Forgive me if I make mistakes, I don't speak English very well!


  • Local Moderator

    @nexusone13 I saw that you are a CRT HERO, can you help him? I tried to help this user, but I don’t have a CRT TV to test, and I don’t have as much knowledge on that subject.


  • CRT Hero

    Hi @Zing
    I don't know why I got this CRT Hero badge cause I have never helped anyone with subject relative to CRT. I don't have a CRT monitor either, so I'll be helpless on this thread, sorry 😞


  • Local Moderator

    @nexusone13 Got it, sorry for the inconvenience.

    @barbudreadmon do you also have a CRT HERO badge, can you help, or are you in the same situation as nexusone13?


  • CRT Hero

    @Zing @rahnpo did yo try this

    global.videomode=DMT 16



  • @nexusone13 @Zing First of all, thank you very much for your support and your availability !!

    @nexusone13 I will try to follow your advice as soon as possible, although honestly, I don't think it can solve my problem:
    DMT is a video mode dedicated only to monitors, and I own a TV. Also, DMT 16 is a video mode with a too large resolution for my CRT TV.
    I'll try it anyway, it won't hurt to try 🙂


  • CRT Hero

    @Zing said in Screen size on CRT TV:

    are you in the same situation as nexusone13?

    I am, no idea what this badge is refering to



  • @barbudreadmon thanks anyway, it don't matter.

    @nexusone13 i tried to use
    global.videomode=DMT 16
    But when I start a game i have a black screen with background audio 😞

    I really appreciate the help of all of you, and I hope someone in the forum knows the solution to my problem.

    @ironic I saw that you are a CRT Maniac. Please can you help me?


  • Developer
    Team
    Global moderator
    Translator

    @rahnpo have you added the 'default' in recalbox.conf? Also activated/deactivated overscan in ES Menu? The hdmi video modes won't have any effect over composite.



  • @paradadf yes I did. In the recalbox.conf i edited "default" to global.videomode= and system.es.videomode=

    Also i have deactivated the overscan, but despite everything working properly, the edges of the image come out of the screen. In the retroach menu of some psx games, I have seen that the screen size and resolution of the games, are set to 4:3 and 720x480. That is the esactly resolution of my TV, but the image is still not adapted to the screen. I tried setting the retroach screen size on custom, and I reduced the resolution from 720x480, to 640x480.
    Now the image is more adapted to the screen, but on the sides of the screen there are two small black wavy bars that deform the image.
    I am looking for an ideal resolution for games, which is as close as possible to the actual resolution of the original console.
    For the size of the screen in the emulationstation and kodi menu, however, I don't really know what to do, the image is too big and come out from the edges.


  • Developer
    Team
    Global moderator
    Translator

    @rahnpo sadly I don't have a CRT to test, but I'm aware of some resolution management improvements being currently worked on that will be available on the next v7. If nobody else can help you and/or you don't find the answer by yourself, there is still hope coming soon.



  • @paradadf thank you, I will wait for the arrival of the new version



  • @rahnpo I got it here

    Set the default for all lines of "video mode" in these two files that I show in the image.

    alt text

    alt text

    alt text

    I did it using your configuration.

    config.txt


Log in to reply
 

Want to support us ?

159
Online

79.1k
Users

20.4k
Topics

149.2k
Posts