Can't get retroachievements working on recalbox, but work on RetroArch



  • Hello all,
    I am trying to get the retro achievements working for Mega Man for the NES.

    The ROM I am trying to use (with hashes: MD5 = 4d4ffdfe7979b5f06dec2cf3563440ad, CRC32 = 5ded683e) works fine on RetroArch on my laptop, all achievements show and work. However, the very same ROM on my Recalbox claims that there are no achievements for it.

    Achievements work perfectly for other games on the Recalbox, I can see and unlock them. And as for Mega Man itself, it otherwise runs fine.

    Have you experience a similar issue, or have any clues about what could be wrong?

    Thanks!


  • Staff
    Developer
    Team
    Global moderator
    Translator

    @HerrKuhmann try changing the core.



  • @paradadf Thank you for your answer.

    For some reason, I cannot update the core from the RetroArch interface in Recalbox, when I go to Online Updater > Core Updater, it does nothing (in my laptop, that shows the list of cores and allows me to update). My Recalbox is Dragon Blaze 6.1.1, do you think the installation is somehow messed?

    With regards to the cores, I am running the game on FCEUmm 1.8.1 in Recalbox, and FCEUmm 1.8.8 in my laptop; other than the lack of achievements in this particular game, I see no differences of behavior.

    One more question, do you think that a game-specific configuration could be messing with the achievements? Every time I open a NES game I get the "configuration override" message, I guess I must have done it by mistake in my first runs. Is there any way to remove all configuration overrides just to be sure?

    Thanks


  • Staff
    Developer
    Team
    Global moderator
    Translator

    @HerrKuhmann hi! I didn't say "update", I said "change" 😉
    The retroarch updater isn't compatible with recalbox, so don't use that.

    You can deactivate the configuration override from retroarch's menu (don't ask me where - I can't check right now). Anyway, it might just be that our current fceumm version (although it show the same version), is outdated and either doesn't have proper retroachievements support or something wasn't right at that time. I'd suggest you to better try on the upcoming v7... All cores are being updated and general retroachievement support will be better.

    You can always try using a different core (Press Start on top of the game on EmulationStation, edit medatada and change the libretro core from fceumm to something else) and see if achievements work there.



  • @paradadf Ah, my bad. Yes, I tried QuickNES for sure, and I think I tried Nestopia too but I don't recall. Anyway, same thing.

    I will take a deeper look to disable override (I think I tried but I might have missed something). Anyway, knowing that v7 is around the corner is good enough for me.

    Thank you very much, I will close the question.


  • Staff
    Global moderator
    Team

    @HerrKuhmann
    are you ok in recalbox.conf ?

    ## Enable retroarchievements (0,1)
    ## Set your www.retroachievements.org username/password
    ## Escape your special chars (# ; $) with a backslash : $ => \$
    global.retroachievements=1
    global.retroachievements.hardcore=0
    global.retroachievements.username=Acris
    global.retroachievements.password=toto
    


  • @acris Everything looks fine in the conf, actually the achievements work fine for other games, and this game shows achievements in my laptop so I don't know what could be wrong.



Want to support us ?

227
Online

81.5k
Users

22.3k
Topics

161.6k
Posts