Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Custom ratio ne sont pas pris en compte par retroarch



  • Bonjour,

    Depuis Recalbox 6, je viens de m'apercevoir que mes custom ratio que j'ai défini il y a bien longtemps et qui ont toujours fonctionné avec leurs overlay respectifs par système, ne fonctionnaient plus. J'ai suivi la doc pour paramétrer tout ça mais ça ne passe pas. Mes overlay sont bien affichés et quand je vais dans les options de retroarch directement depuis un jeu, dans les settings/video: mes custom aspect ratio X, Y, Width et Height sont bien affichés (les mêmes que j'ai défini dans mon fichier) donc le fichier est bien pris en compte.

    Par contre l'option "Aspect ratio" est toujours à "Core provided" et non pas à custom, si je vais la modifier depuis les settings/video de retroarch, je suis obligé de la modifier à custom de faire "back" et de revenir dans le menu comme si je voulais la remodifier pour que l'affichage change et que le ratio soit bien pris en compte. Malheureusement à chaque fois que je quitte un jeu, et que j'en relance un, l'option aspect ratio a été remise à "core provided" et ce peut importe le système que j'utilise.

    Du coup j'ai essayé de modifié depuis le menu d'emulation station, dans advanced settings, pour chaque système j'ai mis le ratio à "Custom" depuis là bas aussi, mais rien n'y fait.

    A quoi cela est du ? Et que faut-il faire pour ne pas que retroarch mette systèmatiquement l'aspect ratio à "core provided" en en tenant pas compte du fait que les miens sont custom (pourtant il prend bien en compte les valeurs étant donné qu'ils les affichent)

    P.S. Pourtant j'ai bien la valeur: aspect_ratio_index = 22 dans mon fichier (le core provided étant censé être le 21), retroarch écraserait-il cette valeur à chaque fois ? Y-a-t-il une option à désactiver pour l’empêcher de faire ça ?

    Merci pour votre aide 🙂


  • Global moderator
    Team

    Bonjour @eightkiller

    Que faire si j'utilise des OVERLAYS ?
    si vous utilisez ceux de screenscraper, aller vérifier si les packs ont été mis à jour pour recalbox 6.0
    Si vous avez créer vos overlays, retroarch a ajouté un nouveau aspect ratio qui décale certains overlays :
    tester 22 ou 23 sur cette ligne : `aspect_ratio_index = 21

    Source : https://forum.recalbox.com/topic/17011/a-lire-processus-de-mise-à-jour/2



  • Merci pour la réponse @acris :), mais dans quel fichier ?

    Ca ne change rien si je met 23 dans mon fichier de conf perso (vu qu'il est déjà à 22).
    Et le fichier /recalbox/share/system/config/retroarch/retroarchcustom.cfg n'est normalement pas chargé car spécifié nulle part dans mon recalbox.conf.
    C'est le seul fichier ou j'ai trouvé ces lignes au tout début:

    #aspect_ratio_index = "21"
    aspect_ratio_index =
    cache_directory = /recalbox/share/extractions/
    cheat_database_path = /recalbox/share_init/cheats/cht/
    cheat_settings_path = /recalbox/share/cheats/saves/

    Normalement le # signifie soit un commentaire, soit dans certains cas un include. Mais même en modifiant et en mettant
    #aspect_ratio_index = "22" ou #aspect_ratio_index = "23"
    ou bien aspect_radio_index = 22 ou aspect_ratio_index = 23, juste en dessous, ça ne change rien, l'option est toujours à "Core provided" par défaut. Je ne vois donc pas où ni dans quel fichier retroarch va mettre cette info par défaut qui override mes modifications qui normalement sont chargées après et ce devrait être elles qui override la conf de base de retroarch ??!

    Merci d'avance.


  • Global moderator
    Team

    @eightkiller
    tu es en 6.1.1 ?

    si non, une mise à jour corrigé le problème de ratio voir le changelog.

    si oui, une surcharge de retroarch devrait résoudre les problèmes si tu es en minium 6.1 : https://forum.recalbox.com/topic/18803/tuto-les-surcharges-mais-avec-vous/

    si tu n'es pas à jour nous pourrons pas t'apporter notre aide.



  • Lol, non je suis toujours en 6.0, je comptais faire la mise à jour mais plus tard, car ça m'oblige à reconfigurer des choses à chaque fois et je n'avais pas trop le temps là :s. Mais les surcharges ont l'air adaptées, ça évite de reparamétrer le recalbox.conf général à chaque fresh install dans ce cas. Je vais tester et je te dis ça 🙂

    Merci.



  • C'est bon j'ai réussi en 6.1.1, il faut faire une surcharge du .retroarch.cfg et y mettre la valeur aspect_ratio_index = 23
    Si jamais ça peut aider quelqu'un :), en tout cas ça ne marche pas sans surcharge (même en mettant la valeur 23 dans le fichier de config original)

    Merci pour l'aide !


  • Developer
    Global moderator
    Creator
    Team



Want to support us ?

126
Online

78.5k
Users

20.1k
Topics

147.6k
Posts