Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Custom Scripts not working anymore


  • Translation Master

    Hi πŸ™‚

    Since a long time I use some customs scripts in /etc/init.d for the startup & shutdown procedure. It worked with no problems.
    Recently I had to setup my recalbox from scratch (due to an upgrade error from 6.1 to 6.1.1) and somehow my scripts are not called anymore.
    If I log in via ssh and call the scripts manually, they work, but during startup they don't.

    I use the following structure for startup:

    start() {
    // Call a script which is located in /recalbox/scripts
    }

    case "$1" in
    start)
    start
    ;;
    esac

    Does somebody know a reason why this is not working anymore? Maybe I really miss a small thing somewhere..

    Thanks πŸ™‚


  • Translation Master

    Somebody of the team has an idea? Thank you πŸ™‚


  • Developer
    Global moderator
    Team

    Hi @lackyluuk,

    Could you please post the exact and complete script? I could have a look at it and try to reproduce.
    Could you also post the output of ls -l /etc/init.d/?

    Thanks in advance.


  • Translation Master

    @Michael-Baudino Yes sure. I will post it this weekend when I am home. Thanks in advance πŸ™‚


  • Developer
    Global moderator
    Team

    Unrelated, but I love the NintendoRS linked in your signature: awesome work 😍
    Ooc, are you still using it?


  • Translation Master

    @Michael-Baudino
    Thanks πŸ™‚
    Yes, I am still using it. But more to configure new themes or maintain the game lists. Recently i just finished Zelda - A link to the past πŸ™‚

    Unfortunately I have to write from my smartphone since it tells me that my account is banned. Reason: insulting. Most probably I used the wrong password to often. But on the smartphone I am still logged in πŸ˜„

    Here is the content of the script which I am starting in /etc/init.d (S32StartFanAndVolumeControl.py)

    #!/usr/bin/python
    
    import subprocess
    
    try:
        subprocess.Popen(["python","/recalbox/scripts/fanControl.py"])
        subprocess.Popen(["python","/recalbox/scripts/volumeControl.py"])
    
    except KeyboardInterrupt:
        print "Quit"
    

    Maybe this code is very bad, but it works when I run this script manually. And in the past (before 6.1.1) it also worked during startup.
    I also tried the structure with the start() case but also no success.

    ls -l /etc/init.d shows that the rights are the same as for the other scripts (-rwxr-xr-x l root root)

    Thank you for your help. Really appreciate πŸ™‚


  • Developer
    Global moderator
    Team

    Thanks a lot, I'll try to reproduce πŸ‘

    Regarding your "insulting" ban, I have no idea what happen (unless you actually insulted someone, indeed πŸ˜…), but maybe @OyyoDams can help?


  • Developer
    Global moderator
    Team

    @lackyluuk your account works so for sure it's not banned. Please double check your password.


  • Translation Master

    @oyyodams yes, now it works. I tried using my nickname, but then it failed and told me I am banned. I used the email instead and you're right πŸ™‚

    @Michael-Baudino do you already had time to doublecheck the script issue? thanks πŸ™‚


Log in to reply
 

Want to support us ?

262
Online

78.2k
Users

19.9k
Topics

146.8k
Posts