Behavior of Arkanoid (USA) and different NES cores



  • Hi. I have spent a few hours with this game and I'm very confused about how the emulators handle it.

    I want to play using the DPAD because that is how I used to play it in my childhood (on a knock off Famicom compatible system) and I would like the chance to use a cheat code for extra lives so I can finally see the more advanced stages of the game, but I can't find a combination of core/settings that will enable me to do that and I'm very confused.

    Here is what I have so far with the latest updates installed this morning (RecalBox 6.1.1) on a Raspberry Pi 3. I also tried updating cheat codes and databases from Retroarch Online Updater menu.

    Core Controls Cheats
    Quickness ✔❌
    FCEUNext ✔❌
    FCEUmm ❌ ✔
    Nestopia ❌ ✔

    In the two first cores I can move the paddle but cheat codes don't work. In the last two I can't move the paddle but cheat codes work.

    I read that in the US Arkanoid was bundled with a special controller but I figured the emulators would work around this and allow the use of the standard controller (which the first two seem to do).

    I have tried every single setting I can think of changing the control to auto/gamepad/gamepad with analog. etc.

    If it makes any difference, I'm using an 8bitdo NES30 pro and tried both the dpad and left/right sticks with the same results.

    Any help on how to achieve what I'm trying to do would be appreciated.

    Update: I also tried plugin in a keyboard and mouse to the Pi. The keyboard works in all other NES games I tried but not in Arkanoid. The mouse doesn't do anything but I haven't try running the setup for the mouse to see if it makes any difference.


  • CRT Hero

    @diegus83 said in Behavior of Arkanoid (USA) and different NES cores:

    FCEUmm ❌ ✔
    ...
    I have tried every single setting I can think of changing the control to auto/gamepad/gamepad with analog. etc.

    Not sure it'll help, but FCEUmm seems to have an "Arkanoid" device type available for second player, maybe the special controller was something you were supposed to plug into the second port of your NES, and the emulator reproduce this.



  • Thanks for the reply. I just had time to try this today.

    Effectively there is an "Arkanoid" option under Controllers for Player 2 but I after connecting two controllers and starting a two player game, I still can't move the paddle with either controller, I tried both user turns.

    That's a shame since it seemed a very promising lead.


  • Staff
    Developer
    Team
    Global moderator
    Translator

    @diegus83 are you using no-intro roms? Otherwise I can only imagine there is some “hidden” option within retroarch for the special controls like suggested before.



  • Honestly I don't know the origin of these roms, I got them out of a premade image I tested.
    Based on your suggestion I found a Japanese arkanoid nes rom and the controls work fine on that one!
    The cheat codes included for the US version don't work as probably the memory mapping is all different but that is progress!
    So now I will try to get a proper version of the US rom to try or hunt down some cheat codes for the japanese one.
    As the people how know keep saying, check your rom set! I didn't thought it was so important for 8 bit consoles but clearly it is.
    Thanks for your help!



  • Sorry for the double post but the forum won't let me edit my previous message.

    I've procured a No-Intro rom set for NES. There where two versions available (headered and unheadered).
    The unheadered rom won't launch with any core.
    The headered rom launches fine but I get the same results as before.

    Is there anyway I can verify I got the proper rom using the checksum or a hash? Like the dat files used for mame rom sets?


  • Staff
    Developer
    Team
    Global moderator
    Translator



  • Ok, I'm going to leave the solution here for anyone who may need it in the future:

    https://github.com/libretro/libretro-fceumm/issues/308#issuecomment-560408467

    if using the US rom (NES), set User 2 to NONE instead of auto. if using the Japan rom (Famicom), disable User 5 instead.

    Further explanation:

    on NES, player 2 port acts as expansion port, including arkanoid paddle in this case (using mouse)
    on Famicom (when loading Japanese ROMS), expansion port is on a dedicated port which is mapped to User 5 on fceumm.
    

    this should resolve this issue and any other confusion with nes/famicom expansions



Want to support us ?

334
Online

80.4k
Users

21.5k
Topics

157.4k
Posts