Cant get the Amstrad CPC virtual keyboard to appear

  • Hi all,
    Booted up an Amstrad CPC game for the first time on Recalbox 6.0 on my Pi 3B, went to use the virtual keyboard by pressing Y on my joypad, and nothing happened.
    This was always the button with Caprice32 on Recalbox 4.1, so Im not sure whats happened in 6.0.

    I checked on
    and it says "The Caprice32 core has a virtual keyboard GUI that can be accessed through User 1's RetroPad Y input", but this definitely isnt happening, and unfortunately is required for a lot of games, where you need to select the joystick option before you can start the game.

    Any ideas or suggestions?

    I tried the other core, but it didn't seem to have a virtual keyboard either, and I can find very little about it via google...

    Thanks in advance

  • Developer
    Global moderator

    @rustymg they change the way the virtual keyboard is opened but haven’t documented it yet, apparently.
    It was something with SELECT to toggle joypad mode (I believe). Try smashing all buttons until you find it out and let us know :D.

  • @paradadf Hi, thank you for your prompt reply.

    This subject was, ahem, mentioned on another well known Pi forum.

    They said you have to enable AMSTRAD JOYSTICK within RetroArch, ie Retroarch Quickmenu / Controls / User [1-4] Device Type: Amstrad Joystick

    .....but, that setting on Recalbox was already on this, so I think it might be emulator related.

    Another suggestion was with nano /opt/retropie/configs/amstradcpc/retroarch.cfg and add line input_libretro_device_p1 = "513" to it, directly below; input_remapping_directory = "/opt/retropie/configs/amstradcpc/"

    Another simpler one was to press "select" and "down" but this didnt work.

    To be honest, I tried every key combo I could think of, but no luck 😞

  • Developer
    Global moderator

    @rustymg there is no need to change any setting. They virtual keyboard will pop up with the right button(s) is(are) pressed. I’ll try and let you know.

    UPDATE: To show the virtual keyboard press SELECT + START. Pressing SELECT alone let you move the cursor either with the D-Pad or the left analog Stick. Weird choise for controllers with no L3 or PS button to set the hotkey there though.

  • The virtual keyboard is a bit tempramental and the mouse pointer seems to only move every 2nd time the keyboard is selected, but yes, select and start brings it up - thank you very much 🙂

    And typically, I think that must have been the only key combo I didn't try !!

    Thanks again for the prompt reply.

  • Banned

    @rustymg I think select alone make the main device switch between mouse and joystick, maybe only when virtual keyboard is up

Want to support us ?