Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Odroid xu4 en 2019


  • Staff
    Moderator
    Team

    AdvanceMame n'etait pas disponible sur Odroid XU4 jusque là. Dans la 6.1, il n'est toujours pas disponible, le fait qu'il apparaisse disponible est un bug que nous avons corrigé.

    Pour Daphné, il va nous falloir un peu plus de précision car c'est un émulateur un peu complexe qui demande une structure précise pour pouvoir fonctionner. Et encore, tous les jeux ne fonctionneront pas forcement.

    Pour TriggerHappy... je n'ai trouvé aucune référence sous Odroid? Tu es certain de la compatibilité? Car s'il utilise les GPIO RPi, et même si l'Odroid a un connecteur "compatible", il est très loin d'être certain que ça fonctionne...



  • @bkg2k,

    AdvanceMame est indiqué comme compatible avec l'Odroid XU4 (compatibility board : https://github.com/recalbox/recalbox-os/wiki/Board-Compatibility-(EN)). C'est ça qui m'a fait replonger dans le setup Odroid, car avant (je ne sais pas quand exactement) il était indiqué non compatibile.

    TriggerHappy fonctionne. Comme je l'ai indiqué, au démarrage de Recalbox il se lance (en ssh je peux voir le daemon qui tourne) mais ça se passe comme si les touches n'étaient pas capturées. Si je fais un restart (/etc/init.d/S10triggerhappy restart) là tout fonctionne parfaitement ! Plutôt embêtant si je dois à chaque fois me connecter et lancer une commande. Ou alors un script qui le ferait, mais ce n'est pas très propre.

    Si le GPIO consiste bien en une connection sur les pin du board, alors je confirme que je n'utilise pas le GPIO du RPI (ni du Odroid). Mes sticks/boutons sont branchés sur un iPac-2, et l'iPac-2 est branché en USB soit sur le RPI, soit sur l'Odroid. Donc c'est la même configuration, le board (RPI ou XU4) reçoit un signal comme si une touche était pressée.

    Pour Daphne, je vais relancer et voir les logs. Il me semble qu'il y a une erreur qui sort (même si je ne sais pas comment la fixer). Merci :)


  • Staff
    Moderator
    Team

    Alors pour TriggerHappy, s'il se lance avec un restart, c'est possiblement qu'il est lancé trop tôt dans la sequence d'init.
    Pour tester, il faudrait renommer le S10triggerhappy en S99triggerhappy afin qu'il se lance après tout le monde, une fois que tout est monté/lancé correctement.



  • @bkg2k,

    Oui, déjà fait. J'ai aussi changé le lancement pour se lancer plusieurs minutes après le démarrage (avec un sleep dans S10triggerhappy) mais sans succès.
    Mon idée était que le driver n'était pas up&running au moment du lancement du daemon, mais mes essais n'ont pas été fructueux.



  • Voici ce que j'ai dans le log ES à l'exécution de Daphne (Space Ace) :

    <code>fffff</code>
    [
    { "code":1, "width":1920, "height":1080 }
    ]
    [
    { "code":1, "width":1920, "height":1080 }
    ]
    SDL_VIDEO_EGL_DRIVER=/usr/lib/libGLESv2.so SDL_VIDEO_GL_DRIVER=/usr/lib/libGLESv2.so /usr/bin/hypseus ace vldp -framefile /recalbox/share/roms/daphne/ace.daphne/ace.txt -fullscreen -useoverlaysb 2 -datadir /usr/share/daphne -homedir /recalbox/share/roms/daphne -nocrc -noissues -nolog -noserversend -latency 950 -x 640 -y 480 -blank_searches -min_seek_delay 1000 -seek_frames_per_ms 20 -bank 0 00000000 -bank 1 00000001
    running command: /usr/bin/hypseus ace vldp -framefile /recalbox/share/roms/daphne/ace.daphne/ace.txt -fullscreen -useoverlaysb 2 -datadir /usr/share/daphne -homedir /recalbox/share/roms/daphne -nocrc -noissues -nolog -noserversend -latency 950 -x 640 -y 480 -blank_searches -min_seek_delay 1000 -seek_frames_per_ms 20 -bank 0 00000000 -bank 1 00000001
    

    Rien d'autre d'indiqué dans les logs (ES stdout/stderr), et si j'exécute en ligne de commande j'ai une segmentation fault.


Log in to reply
 

Want to support us ?

192
Online

59630
Users

18507
Topics

139218
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.