Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Odroid xu4 en 2019



  • Je suis passé à l'odroid xu4 en pensant avoir une belle émulation Dreamcast
    Je suis déçu, mais je pense que le pb est l'émulateur
    Peu de jeux tournent vraiment bien, bcp de bugs et c pas fluide notamment les jeux 3d de caisse (a part crazy taxi), même en 720p
    Je ne sais pas si il y a du tuning a faire ?



  • J'ai un rpi3b+ qui tourne sans problème sur Recalbox 4.1. J'ai monté ma borne d'arcade avec un iPac-2 et j'ai 2 lightguns (aimtrak), et je joue quasi uniquement sur Mame (advancemame pour être précis, car c'est le seul sur 4.1 qui était compatible avec les lightguns). A noter aussi que le contrôle du volume de ma borne est assuré par 2 boutons dédiés qui sont interceptés par TriggeryHappy (outil qui permet de configurer un script à exécuter lorsqu'on presse une touche).

    Il y a quelques temps j'ai acheté un Odroid XU4 (refroidissement actif) pour pouvoir profiter des jeux un peu plus avancés (3D principalement) et j'y ai installé Recalbox 6.1.
    Sur les branchements USB j'ai : un hub USB (pas assez de ports sur l'Odroid) + mes 2 lightguns + une antenne wifi (pas de wifi sur oDroid) + mon iPac-2 + un dongle audio (pas de sortie son sur Odroid).

    Voici ce que j'ai constaté :

    • TriggerHappy est lancé au démarrage mais n'a aucun effet sur le volume sonore lorsque je presse les touches configurées. Par contre si je redémarre le programme (daemon), ça fonctionne. Rien vu dans les logs et mes tentatives diverses n'ont pas résolu le problème.
    • Advancemame ne fonctionne pas (pas moyen de lancer un jeu, c'est écran noir puis retour au menu et dans les logs il est indiqué un problème de format vidéo).
    • Daphne a le même problème qu'Advancemame (enfin ... peut-être pas le même problème, mais le même effet).

    Aucune idée si ça sera résolu dans la 6.1.1, en tout cas sur GitLab je n'ai rien vu qui me rassurait dans la liste des fix.

    Même si dans la plupart des cas (e.g. pour ceux qui jouent sur N64) le passage à l'Odroid est bien, je ne vois pas comment l'utiliser pour l'intant.


  • Screenscraper
    Developer
    Global moderator
    Team

    AdvanceMame n'etait pas disponible sur Odroid XU4 jusque là. Dans la 6.1, il n'est toujours pas disponible, le fait qu'il apparaisse disponible est un bug que nous avons corrigé.

    Pour Daphné, il va nous falloir un peu plus de précision car c'est un émulateur un peu complexe qui demande une structure précise pour pouvoir fonctionner. Et encore, tous les jeux ne fonctionneront pas forcement.

    Pour TriggerHappy... je n'ai trouvé aucune référence sous Odroid? Tu es certain de la compatibilité? Car s'il utilise les GPIO RPi, et même si l'Odroid a un connecteur "compatible", il est très loin d'être certain que ça fonctionne...



  • @bkg2k,

    AdvanceMame est indiqué comme compatible avec l'Odroid XU4 (compatibility board : https://github.com/recalbox/recalbox-os/wiki/Board-Compatibility-(EN)). C'est ça qui m'a fait replonger dans le setup Odroid, car avant (je ne sais pas quand exactement) il était indiqué non compatibile.

    TriggerHappy fonctionne. Comme je l'ai indiqué, au démarrage de Recalbox il se lance (en ssh je peux voir le daemon qui tourne) mais ça se passe comme si les touches n'étaient pas capturées. Si je fais un restart (/etc/init.d/S10triggerhappy restart) là tout fonctionne parfaitement ! Plutôt embêtant si je dois à chaque fois me connecter et lancer une commande. Ou alors un script qui le ferait, mais ce n'est pas très propre.

    Si le GPIO consiste bien en une connection sur les pin du board, alors je confirme que je n'utilise pas le GPIO du RPI (ni du Odroid). Mes sticks/boutons sont branchés sur un iPac-2, et l'iPac-2 est branché en USB soit sur le RPI, soit sur l'Odroid. Donc c'est la même configuration, le board (RPI ou XU4) reçoit un signal comme si une touche était pressée.

    Pour Daphne, je vais relancer et voir les logs. Il me semble qu'il y a une erreur qui sort (même si je ne sais pas comment la fixer). Merci 🙂


  • Screenscraper
    Developer
    Global moderator
    Team

    Alors pour TriggerHappy, s'il se lance avec un restart, c'est possiblement qu'il est lancé trop tôt dans la sequence d'init.
    Pour tester, il faudrait renommer le S10triggerhappy en S99triggerhappy afin qu'il se lance après tout le monde, une fois que tout est monté/lancé correctement.



  • @bkg2k,

    Oui, déjà fait. J'ai aussi changé le lancement pour se lancer plusieurs minutes après le démarrage (avec un sleep dans S10triggerhappy) mais sans succès.
    Mon idée était que le driver n'était pas up&running au moment du lancement du daemon, mais mes essais n'ont pas été fructueux.



  • Voici ce que j'ai dans le log ES à l'exécution de Daphne (Space Ace) :

    <code>fffff</code>
    [
    { "code":1, "width":1920, "height":1080 }
    ]
    [
    { "code":1, "width":1920, "height":1080 }
    ]
    SDL_VIDEO_EGL_DRIVER=/usr/lib/libGLESv2.so SDL_VIDEO_GL_DRIVER=/usr/lib/libGLESv2.so /usr/bin/hypseus ace vldp -framefile /recalbox/share/roms/daphne/ace.daphne/ace.txt -fullscreen -useoverlaysb 2 -datadir /usr/share/daphne -homedir /recalbox/share/roms/daphne -nocrc -noissues -nolog -noserversend -latency 950 -x 640 -y 480 -blank_searches -min_seek_delay 1000 -seek_frames_per_ms 20 -bank 0 00000000 -bank 1 00000001
    running command: /usr/bin/hypseus ace vldp -framefile /recalbox/share/roms/daphne/ace.daphne/ace.txt -fullscreen -useoverlaysb 2 -datadir /usr/share/daphne -homedir /recalbox/share/roms/daphne -nocrc -noissues -nolog -noserversend -latency 950 -x 640 -y 480 -blank_searches -min_seek_delay 1000 -seek_frames_per_ms 20 -bank 0 00000000 -bank 1 00000001
    

    Rien d'autre d'indiqué dans les logs (ES stdout/stderr), et si j'exécute en ligne de commande j'ai une segmentation fault.



  • Up!
    Est-ce qu'il y a une chance d'avoir les problèmes résolus sur Odroid ? Une prochaine release ?



  • @garden-dwarf j'ai l'impression que recalbox est surtout développé sur raspberry, et qu'odroid est supporté a minima


  • Local Moderator
    Tester

    Non, Non, l'equipe des Dev travaillent aussi énormément sur XU4.
    Exemple dans la future version 6.2 il y aura

    • Fix Odroid XU4 fan issue
    • Fix Odroid XU4 sound issue
    • Fix: EMMC boot on XU4
    • Odroid XU4 uboot bumped to odroidxu4-v2017.05

  • Developer
    Global moderator
    Team

    @olivierdroid92 merci, voilà une réponse intelligente aux "impressions" que nous nous tournons les pouces... Ce qu'il ne faut pas lire parfois!



  • Salut, sincèrement je peux comprendre le sentiment de @Garden-Dwarf même si la manière de le dire est un peu maladroite...

    Honnêtement sur XU4, entre la version 6.0 et cette 6.1.1, il y a une impression de régression avec des bugs comme le sifflement du ventilateur ou les glitchs de l'interface qui nuisent clairement à l'utilisation de la board. Alors oui, en s'intéressant un minimum, en cherchant, en posant des questions ici et mettant un peu les mains dans le cambouis, on trouve des solutions !

    Mais je ne pense pas que ce soit à la portée de tous les utilisateurs... Je pense même que le premier réflexe est basique et se résume à "ça marchait mieux avant, je remets la version précédente !".

    Et là, ça se complique encore un peu... La version précédente n'est plus officiellement disponible au téléchargement.

    Il se passe un peu de temps entre 2 versions, il n'y a pas rapidement un fix pour corriger ces problèmes et c'est compréhensible. Vous avez tous une vie à côté de Recalbox et votre travail est purement bénévole, je pense qu'on vous remercie tous pour ça ! 🙂

    Mais lorsque des bugs vraiment gênants remontent auprès de la communauté et nuisent ainsi à la board, je ne sais pas si vous ne devriez pas arrêter le déploiement de la build en question et proposer la version stable précédente...

    Dans le même esprit, le bug de glitch pour les vidéos au boot du XU4 est connu et existe depuis pas mal de versions maintenant, pourquoi ne pas mettre simplement une image à la place des vidéos en attendant de fixer le problème ?

    Attention, je vous livre ici juste mon sentiment, je respecte énormément le travail de toute la Team et vous en remercie chaleureusement une fois de plus ! 😉


  • Local Moderator
    Tester

    @jraffel
    Pour aider sur le bruit du ventilateur.
    Voici une modification instantanée à réaliser.
    Je viens de le faire chez moi.
    Lire : https://forum.recalbox.com/topic/19440/scratching-fan-noise-with-6-1-1-dragonblaze-on-odroid-xu4/7

    Pour les vidéos d'introduction il est facile de supprimer Splash02 et tous les problèmes sont résolus



  • @olivierdroid92 merci mais @OyyoDams m'avait déjà aidé à résoudre le souci sur un autre post ! 😉

    Ensuite, je ne parlais pas de mon cas en particulier, évidemment pour le moment je supprime les vidéos (malheureusement).

    En fait, je parlais plus globalement en pensant aux autres utilisateurs.



  • Pas de souci, je peux attendre. J'ai un rpi3 qui tourne très bien sur 4.1.

    Par contre mon odroid xu4 reste à l'arrêt car j'ai plusieurs problèmes qui m'empêchent de l'utiliser:

    • Freeze occasionnels dans ES
    • Triggerhappy qui ne fonctionne pas correctement au démarrage
    • Advancemame qui ne lance pas les jeux
    • Daphne qui ne fait pas tourner certains jeux marqués compatibles (space ace, dragon's lair...)

    Je sais bien que c'est du bénévolat et qu'on a la chance d'avoir des personnes compétentes qui prennent sur leur temps libre pour la communauté, encore merci, et j'essaye juste de savoir si il y a une chance que mes problèmes soient repris quelque part afin d'essayer de trouver une solution.



  • Bonjour à tous,

    Je suis l'heureux possesseur depuis peu d'un Raspberry 3b+ et d'un Odroid XU4.
    Aucun problème pour la mise en place de Recalbox sur le 1er, par contre je galère pas mal avec le second 🙂

    J'ai actuellement un petit soucis, contrairement à mon Raspberry 3b+ connecté sur mon WIFI, je n'arrive à me connecter en Putty sur mon odroid XU4, que ce soit en par câble réseau ou par Wifi (via une clé usb), il me met connexion refusée. Pourtant je me connecte tout pareil, en récupérant l'adresse IP via le menu de la Recalbox puis je me connecte en Putty via le port 22. Du coup corriger le problème d'écran de mon boitier OGST et du bruit du ventilateur devient compliqué.

    En attendant les modifications sur la 6.2, pourriez-vous m'indiquer où je pourrais trouver l'image de la 6.0 svp ?

    Merci et bonne journée !


  • Global moderator
    Team

    @soulou said in Odroid xu4 en 2019:

    En attendant les modifications sur la 6.2, pourriez-vous m'indiquer où je pourrais trouver l'image de la 6.0 svp ?

    nul part, nous ne conservons pas les anciennes versions, c'est à l'utilisateur de le faire.
    tu utilises le meme share que sur les anciennens versions
    si oui, faut surement refaire une fresh install
    https://www.youtube.com/watch?v=skeULeTu7p8&list=PL2oNQ0AT7fx2ExiSNrfHUzga5GnogI4sh&index=23



  • Je confirme que le ssh avec PuttY fonctionne bien de mon côté en Recalbox 6.1.1



  • @acris Ok je regarde ça merci



  • @acris J'ai retéléchargé l'image, reflasher la carte, j'ai démarré la carte hors boitier. Bien attendu le démarrage et là j'avais accès en putty. J'ai réglé le problème du ventilateur en changeant la valeur 35 par 40. Reste à voir ce qui est possible avec l'écran lcd du boitier OGST. Merci


Log in to reply
 

Want to support us ?

178
Online

78.2k
Users

19.9k
Topics

146.8k
Posts