Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Recalbox 6.0 RC2 is released


  • Staff
    Moderator
    Team

    Hi friends! Recalbox 6.0 RC2 is released!

    Here is what has been fixed since the RC1:

    • Fix default GBA games metadata
    • Fix old core names in recalbox.conf (automatically renamed)
    • Add Ximo controller to pre-configured pads/joyticks
    • Fix missing desmume_libretro.so
    • Fix reicast on XU4/X86
    • Fix virtual gamepad
    • Fix device handling to quit demo mode
    • Fix Kodi not starting with some gamepad
    • Fix retroarch core options not saved
    • Fix AROS bios with CD32
    • Fix Oricutron conflicts between 2nd player joystick and keyboard
    • Fix Dragonrise on Amiga (partially, you still need to HK+B and reset the emulator)
    • Fix descending sorts in gamelists
    • Improve randomness in demo mode

    These issues are NOT FIXED yet:

    • AdvanceMame configuration not saved (need some code rework and appropriate tests)
    • The internal scraper is not reliable (need some heavy code rework)

    And just for information, the incredible "Changelog" of the previous 6.0 RC1:

    • Major system upgrade. See https://github.com/buildroot/buildroot/blob/2018.02.3/CHANGES#L1-L1427 for the full log
    • KODI bumped to 17.6
    • Raspberry Pi3b+ and CM3 support
    • Joypads management updated, mostly impacting joypads advertising as a complete keyboard. You have to reconfigure your pad if it is acting strangely
    • Preconfigured gamepads file rewritten
    • arcade GPIO driver upgraded: now support I2C and GPIO recopnfiguring from the command line
    • x86 now requires a CPU that can handle at least SSE and SS2
    • x86: add support for newer AMD GPU
    • fix PS3/PS4 pads not working
    • fix kodi configgen
    • bump rpi kernel + firmware
    • gpio arcadedriver works again
    • fix bug on bluetooth discover
    • Add Capcom RB video intro
    • Bump kodi.plugin.video.youtube to 6.3.1
    • Add support for Mayflash GameCube adapter
    • ES: better cyrillic display
    • Add ipega 9055 udev rule
    • New upgrade procedure to prepare for the future
    • ES: fix scraped folders display
    • ES: improve image loading
    • ES: now automatically reboots once the upgrade is ready
    • Atari 8 Bits: Added Atari 800 and Atari 5200 support - Thanks to dubbows!
    • MSX: Fixed Bluemsx core
    • Add 7z file support for many libretro cores
    • Docker build unified
    • "overlays" folder and roms subfolders automatically created
    • Fix bug on bluetooth discover
    • ES: fix pads buttons detection and configuration
    • Fix bluetooth detection on Odroid XU4
    • Update version of Theodore core (now supports TO8, TO8D, TO9, TO9+ and MO5)
    • Add homebrew game Mission: Liftoff (Theodore)
    • Fix BT recovery on XU4
    • advmame: add overlay possibility
    • MAME: Added mame2003-plus libretro core. A MAME078 version with added games support plus many fixes and improvements.
    • PokeMini: Add Pokémon Mini support
    • FreeIntv: Add Mattel Intellivision support
    • FreeChaF: Add Fairchild Channel F support
    • pc98: Add PC-98xx series support
    • Add Atari Jaguar on x86(_64) platforms
    • SNES9X: Add Satellaview and SuFami Turbo as own systems
    • Neo Geo CD: Added support with fbalpha emulator (TruRip ccd/sub/img recommended)
    • Bump FBA libretro to latest version => Romset 0.2.97.44
    • Bump AtariST emulator to december 2018 version
    • Add Oric/Atmos emulator (Oricutron, standalone)
    • Add MGT Sam Coupé emulator (Simcoupe, standalone)
    • c2/xu4: enable generic quirks for usb encoders like Xin-Mo
    • Bump DosBox to revision 4178 (December 2018)
    • Beetle PC-FX: Add NEC PC-FX support (x86, x86_64 and xu4)
    • MAME bios folders: Update hiscore/cheats for all MAME versions (courtesy of olivierdroid92)
    • Bump 4DO to support threaded DSP emulation & lightgun
    • Activate 4DO package on Rpi3
    • Bump Amiberry to 2.24 (SDL2). Compatible Odroid XU4.
    • Add Amiga CD32 system
    • Add AROS bios as default Amiga bios (2019 version)
    • Add configuration for static ip addresses on wifi interfaces
    • Bump ScummVM/ResidualVM (January 2019)
    • Bump almost all libretro cores
    • Package names updated (catsfc -> snes9x2005, pocketsnes -> snes9x2002, snes9x_next -> snes9x2010, pce -> mednafen_pce_fast, vb -> mednafen_vb, imame -> mame2000, mame2003 as core name instead of mame078, fbalpha instead of fba)
    • Improved log formatting
    • Add Demo Screensaver

    Have fun!


  • Staff
    Moderator
    Team

    Bugs confirmed on RC2:

    • Amiga 600 WHDR are not working (fixed for the final release)
    • Mame2003plus - DPAD is not responsive


  • @oyyodams I have installed Recalbox 6.0 RC2 on Raspberry Pi 3B+ and kodi is not launching, any hints?


  • Staff
    Moderator
    Team

    @gustavolima I've just tested on a fresh install and I can confirm you Kodi works on this version.



  • I installed on my Raspberry Pi 3b+ RecalBox 6.0RC1, then upgraded to 6.0RC2, since then Kodi has stopped working. When I start Kodi everything is still normal, but when the Kodi main page comes, the mouse pointer is in the corner on the top left and everything is frozen. I also have the problem that when I start the Raspberry Pi 3b+, not equal to the network is there, must first enable and disable Wi-Fi until then until sometime the WLAN works. Router is FritzBox 7490.


  • Staff
    Moderator
    Team

    Hello @SeatFreak
    Have you reconfigure gamepad ?



  • Hello acris

    No, I did not have that. Do I have to do this after every update?
    Thanks for the tip, I tried it right away.
    Kodi works now again, after reconfigure the Gamepad.

    many thanks.



  • @seatfreak said in Recalbox 6.0 RC2 is released:

    I also have the problem that when I start the Raspberry Pi 3b+, not equal to the network is there, must first enable and disable Wi-Fi until then until sometime the WLAN works. Router is FritzBox 7490.

    Regarding wifi, set wifi region to DE in recalbox.conf (or FR, or AT; just something european, instead of US).

    Also had same issue with my FritzBox. I can‘t understand why this is set to US by default. A developer told me it‘s to be complient in US, because they use less channels/frequecies. But many users have these problems and don‘t know what to do. I would set European setting as default, as it‘s European software. If US citizens use it, they can change if necessary. Just my point of view...



  • Yesterday I followed the tip to reconfigure the controller then Kodi went again,
    but after a recalbox restart and game list update in the options,
    after Kodi was frozen again.



  • @OyyoDams Hi, since version 6.0 I got some warnings about invalid CRC in es_log.txt. No big deal, but would be interesting where these come from. Examples:

    [2019/04/03 00:31:48.413] (WARN!) : Invalid CRC32 FD7B1BE33ath
    [2019/04/03 00:31:48.414] (WARN!) : Invalid CRC32 FE43FE586ath
    [2019/04/03 00:31:48.414] (WARN!) : Invalid CRC32 02FAD2B66ath
    [2019/04/03 00:31:48.415] (WARN!) : Invalid CRC32 FA8DF0BA3ath
    [2019/04/03 00:31:48.415] (WARN!) : Invalid CRC32 FF9ED9819ath

    Thanks for all the work you guys do, version 6.0 RC2 is working very well here on Pi3 B+!


  • Staff
    Moderator
    Team

    @lhari84 check the corresponding gamelist.xml file.
    What did you use to generate those CRC? An external scraper? The internal ES tool?



  • @bkg2k Hi, I used external scraping tool (Skraper). Afterwards I run internal solution in netplay-section.



  • I want to report another minor issue:
    I wanted to compress pcengine and sega cd roms (bin/cue) and used a tool named chdman to create chd-files.
    Now pcengine is working fine with those chd-files, but sega cd only runs into a black screen for about 10 seconds and quits to ES then. (Of course i tried the old bin/cue rom before compression and it worked too)

    I used tool version from this manual. Maybe I have to use another version? Or is it a bug in sega cd's chd support?

    https://www.reddit.com/r/RetroPie/comments/72kh6q/stepbystep_guide_how_to_convert_sega_cd_or_pc/

    (I know it's a manual for retropie, but I guess emulator is the same and for pcengine it appearantly works in recalbox)



  • Three more findings:

    recalbox.conf
    I have already read about from other user during beta phase and don't know if it should be fixed in meanwhile:
    When enabling (uncommenting) power/reset switches on Pi 3B+' GPIO, in my case line with "PIN356ONOFFRESET", the same entry appears many times (all uncommented) in recalbox.conf. Seems that all other (still commented) entries are replaced by any reason:

    ------------ A - System Options -----------
    Uncomment the system.power.switch you use
    system.power.switch=PIN356ONOFFRESET # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    system.power.switch=PIN356ONOFFRESET # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    system.power.switch=PIN356ONOFFRESET # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    system.power.switch=PIN356ONOFFRESET # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    system.power.switch=PIN356ONOFFRESET # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    system.power.switch=PIN356ONOFFRESET # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    system.power.switch=PIN356ONOFFRESET # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    system.power.switch=PIN356ONOFFRESET # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    system.power.switch=PIN356ONOFFRESET # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)

    es_log.txt

    Here appears an error saying config file missing. + systems are listed double-named like "3do3do".

    2019/04/04 00:20:15.340] (ERROR) : /recalbox/share/system/.emulationstation/es_systems.cfg file does not exist!
    [2019/04/04 00:20:15.340] (INFO ) : Loading system config files /recalbox/share_init/system/.emulationstation/es_systems.cfg...
    [2019/04/04 00:20:15.349] (WARN!) : Key: 3do3do
    [2019/04/04 00:20:15.350] (WARN!) : Key: amiga1200amiga
    [2019/04/04 00:20:15.350] (WARN!) : Key: amiga600amiga
    [2019/04/04 00:20:15.350] (WARN!) : Key: amigacd32amiga
    ....and so on....



  • @bkg2k said in Recalbox 6.0 RC2 is released:

    @lhari84 check the corresponding gamelist.xml file.
    What did you use to generate those CRC? An external scraper? The internal ES tool?

    Sorry for this one, should have opened my eyes before.
    Indeed there was text "ath" in the end of the hash. Must have come form Skraper (Screenscraper) I guess...

    Maybe you can have a short look on the other issues I found above.

    Thanks for your support!


  • Staff
    Moderator
    Team

    @lhari84 don't worry about such "errors", that's normal, and we'll remove thos logs in the next release.



  • @bkg2k ok regarding error messages :)

    But do you have an idea why sega cd isn't working with chd files made from bin/cue roms that work perfectly, though?
    Readme says .chd is supported and pcengine cd chd files converted the same way from bin/cue work fine!
    I don't know if chd support is new in 6.0 or if it was implemented before. I just can say I don't manage to get it working without a visible reason...


  • Staff
    Team
    Moderator
    Translator

    @lhari84 check if changing the core allows you to launch segacd in chd format. It might be that the default core doesn’t support chd, but the other does.



  • @paradadf
    I've tried already tried switching to genesis plusgx yesterday, no success.
    But it's a good hint, appearantly it only works with genesis plusgx core and that's the point. It seems this core needs other bios files (or at least renamed ones), than picodrive core:
    https://github.com/RetroPie/RetroPie-Setup/wiki/Sega-CD
    I guess I have to approach from this side.
    I'll try when I'm at home and report when I get it working.



  • @lhari84

    Yep, only Genesis Plus GX support .chd extensions.
    For both Emulators you need following name convention:

    bios_CD_E.bin for Europe Region
    bios_CD_U.binfor USA Region
    bios_CD_J.binfor Japan Region

    Just rename your old Bios filenames to work on both Cores.
    (example: eu_mcd2_9306.bin -> bios_CD_E.bin)



Want to support us ?

240
Online

55688
Users

18204
Topics

137045
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.