February 2019 Beta Version

  • Staff
    Global moderator

    Picture NES Familly

    Updated - 2019/02/24

    New February 2019 Beta version! For Pi3B+ and ALL platforms!


    From the latest stable, this is the 3rd beta version. And the last until the next stable release!

    We know you're all impatients, and the team has been working hard to provide you with this almost-final beta version.
    The changelog is pretty long, and from now on, the repository includes a more user-friendly list of changes, available here: Beta RELEASE-NOTES.md
    or here, if you want to follow work-in-progress developments : WIP RELEASE-NOTES.md

    Thanks to all people that made bug reports in the previous beta thread. Almost everything has been fixed since the last beta.

    Beware: some emulators have been updated and requires new bios (i.e: Amiga - Read Here)


    Here we go! As usual, download the image and use Etcher to flash it on your favorite SD Card.
    2019-02-23: Images have been updated to include important fixes

    Please read this post CAREFULLY, especially the part that says: NO UPDATE!




    Testing & Reporting

    What to test?

    ALL! Almost everything has been updated: Linux kernels, drivers, tools, all emulators and libretro cores, Retroarch, EmulationStation, ...

    What to report, and where?

    Any bug, bad behavior or suspect behavior should be reported here, or on our Discord server when it requires further discussion.
    When posting a bug report, please be as much accurate as you can.
    If possible, tell us:

    • The hardware your recalbox is running on
    • Anything specific in your configuration (exotic pad? HDD? USB? Network, ...)
    • Default or user/custom theme?
    • Optionnaly, if you have a big game collection, how many systems/games.

    When a particular emulator is not working:

    • Rom/game extentions
    • BIOS
    • Pad(s)

    The last beta has been released on many systems, and every single system has its own particularities!
    Without details, we won't be able to help you!

    Known bugs

    Here is the list of confirmed bugs.

    • Sound volume in EmulationStation may be louder than in-game depending of the platform you run Recalbox on.
    • Cheats are not working with mame2010 (path issues)
    • Retroarch screen ratio seem still unsync' with ES/Configgen
    • Kodi is not starting with some pads.
    • Reicast do not launch games with spaces in filename
    • Some pads are still not working in Amiberry (forbidden chars in configfile path)
    • Virtual Gamepad is not working at all (or require to be remapped!)
    • Netplay doesn't event start (often) due to string garbage in configgen command line
    • Some A600 WHD are running too fast

    This list will be updated as soon as a new bug is discovered and confirmed or a bug is fixed.


    There is a popup telling me there is an update! Wow you're fast!
    NO! NO! NO! No update at all until the final release! update = crash

    My game doesn't launch 😞 I get a black screen and then it goes back to the gamelist...
    Remap your pad/joystick/whatever! Even if it's working in EmulationStation menus, your pad may not be in the known-pad-list. If it's still not working, check the required bios and/or the game you try to run.
    When your game is working after remapping, please read the post here!

    My game is buggy or there are glitches/artifacts...
    We are not making emulators 🙂 Please report the issue to the appropriate emulator/core mainteners.

    Where can I find games or bios?
    Not here. Nor on our discord. Thanks.

    Testing & Reporting (for french people 😉 )

    Lorsque vous rapportez un ou des bug(s), soyez le plus précis possible!
    Essayez d'indiquer:

    • Le hardware sur lequel tourne votre recalbox
    • Tout ce qui est spĂ©cifique Ă  votre configuration (HDD, Reseau, USB, pad exotiques, ...)
    • ThĂšme par dĂ©faut ou thĂšme custom/utilisateur?
    • Optionnellement, si vous avez une grosse collection, le nombre de systĂšmes et de jeux.

    Si un Ă©mulateur en particulier ne fonctionne pas:

    • L'extension du jeu ou de la rom
    • Le(s) BIOS utilisĂ©(s)
    • Le(s) Pad(s) utilisĂ©(s)

    Merci de poster vos archives de support en utilisant le manager https://recalbox/help

    La derniĂšre bĂȘta est sortie sur tous les systĂšmes, et chaque systĂšme a ses propres particularitĂ©s!
    Sans indications, il nous est peu ou pas possible de vous aider.


    To All Amiga Fellows

    Since the WIKI is not yet updated, here is a quick intro to the new Amiga emulator!

    Amiberry has been upgraded to v2.24 on Raspberry 2, 3B(+) and Odroid XU4.
    This is a big bump, and the new version supports lots of new features!


    In Recalbox, Amiga machines have been split up in 3 virtual sub-systems:

    • Amiga 600:All OCS/ECS machines from A1000 up to the latest A600
    • Amiga 1200: All AGA machines, starting from the 1200
    • Amiga CD32: The only true console from the Amiga series
      The CDTV is not yet supported, although the Recalbox theme and CDTV configurations are ready. It will be added later as a new sub-system, as soon as Amiberry fully supports it.

    Supported "roms"

    Here is a list of supported file format per sub-system:

    • Amiga600 & Amiga1200:
      ADF disks (*.adf), the most popular disk format (cannot embedd disk protections). May be zipped or 7-zipped.
      IPF disks (*.ipf), mostly used by no-intro dumps (can embedd disk protections). May be zipped.
      WHD (folders, *.lha/lzh/lzx, *.zip), the well known format for hard-drive games. WHD folders are reconized using the inner *.slave file, however it is highly recommended to keep them packed in lha or zip format. Unpacked WHD are not faster and even worst they may make EmulationStation slow as hell 🙂
      HDD FS, Hard drive on filesystem. Must be folders ending with ".hd" extensions. Rarely used. For true amiga fellows that backuped their Amiga HD. May be zipped, but not recommended.
      HDF (*.hdf), Hard drive images in a single file. May be zipped (R/O!)
      RP9 (*.rp9), Amiga Forever all-in-one packages

    • Amiga CD32:
      ISO (*.bin, *.iso, w/ or w/o *.cue), CD dumps. May be zipped
      Other CD image formats may be supported but haven't been tested by the recalbox team.

    When running zipped/7-zipped files, our configurator try to identify the rom type by seeking for specific extensions inside the archive. ADF/IPF/BIN/ISO are fast to identify. WHD are fast, but LHA should be prefered. HDDFS may be longer to check and may lead to some misinterpretations. If you are using HDDFS, let them as regular files & folders and make the root folder name ending with .hd for fast identification.

    Overriding configurations

    As you can see, this new Amiberry supports all amiga "rom" formats. To make things easier for everyone, we have made a huge work to auto-magically configure the emulator regarding what you want to start.
    Recalbox build a default machine configuration per sub-system, however, in some situations you may want to override the auto-generated settings.

    Recalbox generates config files in /tmp/amiga/conf. The most important is the uaeconfig.uae file, where you will find all keys defining the machine, disk drives, hard drives, etc.
    I cannot describe all keys here. If you're curious I recommend you to take a look at the appropriate Amiberry and UAE documentations.

    You have two ways to override settings:

    By system:

    Create a file named /recalbox/share/system/configs/amiberry/<subsystem>.uae (/recalbox/share/system/configs/amiberry/amiga1200.uae to override Amiga1200)
    Set the key you want to override.
    For example, you can make a config file with:
    to disable LED display in the bottom right corner.

    By game

    Create a file named exactly like your "rom" (or folder) but that ends with .uae.
    For exemple, in your rom folder, if you have a file named Aladdin (AGA).ipf, you may create an Aladdin (AGA).uae and override keys in this file.

    Recalbox builds the configuration in the following order:

    • Build the default config regarding the rom type and the sub-system.
    • Load /recalbox/share/configs/<subsystem>.uae if the file exists, and add/overwrite the config keys.
    • Load <game>.uae if the file exists, and add/overwrite the config keys.

    In game

    As in other emulators:
    HoyKey + START quit the emulator
    HoyKey + B run the Amiberry interface


    The new Recalbox comes with an open-source kickstart replacement, the AROS bios (2019 version).
    Our auto-magically configurator use this bios when no other BIOS is available in share/bios folder. Several games have been booted & tested successfully using the AROS bios.
    But keep in mind that this is a replacement. It is highly recommended to get the required bios. In particular if you want to run WHD games, because the Amiberry's WHDLoader may change bios settings and seek for the best available kickstart.

    Here is the list of new required kickstart:


    • kick33180.A500.rom (Kickstart v1.2 rev 33.180 (1986)(Commodore)(A500-A1000-A2000).rom)
    • kick34005.A500.rom (Kickstart v1.3 rev 34.5 (1987)(Commodore)(A500-A1000-A2000-CDTV).rom)
    • kick37175.A500.rom (Kickstart v2.04 rev 37.175 (1991)(Commodore)(A500+).rom)
    • kick39106.A1200.rom (Kickstart v3.0 rev 39.106 (1992)(Commodore)(A1200)[!].rom)
    • kick40063.A600.rom (Kickstart v3.1 rev 40.63 (1993)(Commodore)(A500-A600-A2000)[!].rom)
    • kick40068.A1200.rom (Kickstart v3.1 rev 40.68 (1993)(Commodore)(A1200).rom)
    • kick40068.A4000.rom (Kickstart v3.1 rev 40.68 (1993)(Commodore)(A4000).rom)


    • kick40060.CD32.rom (Kickstart v3.1 rev 40.60 (1993)(Commodore)(CD32).rom)
    • kick40060.CD32.ext.rom (CD32 Extended-ROM rev 40.60 (1993)(Commodore)(CD32).rom)

    Hope it helps 🙂

    WIFI 5G

    @michael-baudino said in February 2019 Beta Version:

    I have two solutions to this issue:

    • the workaround: connect to your not-5G network 😏 (it sounds silly, but it works: most routers offer both 2.4GHz and 5GHz)
    • the fix: I changed wifi.region in recalbox.conf from US to FR (I'm in France) and 5G WiFi started working perfectly ✹

    I hope it'll work for you as well as it did for me đŸ€—

  • Thanks a lot !

  • Yesssssss!!!!! Appuyer sur F5 pendant des semaines dans l'attente de l'annonce de la nouvelle beta, ça commençait Ă  faire mal aux doigts 🙂
    Plus sĂ©rieusement, merci mille fois, vous faites un boulot ÉNORME!!!!!!

  • Global moderator
    Global moderator

    Thanks a lot for this Feb release !!!
    Will try soon!!

  • Bonjour,

    Si j'utilise Etcher, vais-je perdre les roms installées avec la beta précédente ?



  • @marcus_972 Oui, parce que Etcher va Ă©craser ta ”SD avec l'image de la nouvelle version. Fais un backup de tes dossier avant.

  • Are there any known bugs we should be ignoring?

  • Staff
    Global moderator

    Known bugs section added in the first post. Will be updated everytime a bug is confirmed.

  • Global moderator
    Global moderator

    Mici mici mici mici pour votre Ă©norme travail 🙂
    Keep it up ! đŸ”

  • Gros gros boulot... FĂ©licitation Ă  toute l'Ă©quipe Recalbox.

    1 problÚme identifié avec PSP sur PI3+ sur la version Février 2019, retour automatique à l'écran de lancement pour tous mes iso. Le fichier /recalbox/share/system/logs/es_launch_stderr.log indique l'erreur suivante : /usr/bin/PPSSPPSDL: error while loading shared libraries: libsnappy.so.1: cannot open shared object file: No such file or directory. Une idée pour la correction !? J'ai cherché, rien trouvé avec cette commande find / -name "libsnappy.so*"

  • Can we update from the Christmas beta or should we perform a clean installation?

  • Merci, je vais tester ça sur mon 3B+ 🙂

  • Global moderator
    Global moderator

    @pmroyo don't update, reinstall properly using etcher

  • Staff
    Global moderator

    @marcus_972 To avoid losing all your games next time, you can configure Recalbox to use an external drive (usually a USB drive) to store them (and your configuration). Next system update will only update the OS (you may have to configure it again after update to use the external USB drive, though). See @Fab2Ris tutorial #5 on Youtube: https://www.youtube.com/watch?v=65deA8c-stM

  • Staff
    Global moderator

    Known bug list updated.
    Concerning PPSSPP, since the missing library is a critical bug, beta images will be updated in a few days.

  • @nordicpower Tu avais le mĂȘme soucis de pb de Psp sur la version prĂ©cĂ©dente de recalbox ?

  • Many thanks for this build, it installs on my ASUS VivoMini VC65-C1 (i5-8400T, Intel HD Graphics 630) whereas the previous beta did not.

    It seems that recalbox-configgen is not configuring my F710 joypad in dreamcast/reicast (works fine so far in other emulators bundled in the build) I have tried re mapping the controller with no change.

    my controllerP1.cfg

    btn_trigger_left = 0
    axis_dpad1_y = 1
    btn_trigger_right = 0
    axis_dpad1_x = 0
    mapping_name = Logitech Gamepad F710
    btn_escape = 0
    btn_b = 0
    btn_a = 0
    btn_x = 0
    btn_start = 0
    btn_y = 0
    axis_y = 0
    axis_x = 0

    my emu.cfg

    backend = auto
    disable = 0
    Debug.SerialConsoleEnabled = 0
    Dreamcast.Broadcast = 4
    Dreamcast.Cable = 3
    Dreamcast.RTC = -2113930091
    Dreamcast.Region = 3
    Dynarec.Enabled = 1
    Dynarec.idleskip = 1
    Dynarec.unstable-opt = 0
    aica.LimitFPS = 1
    aica.NoBatch = 0
    aica.NoSound = 0
    bios.UseReios = 0
    pvr.MaxThreads = 3
    pvr.Subdivide = 0
    pvr.SynchronousRendering = 0
    pvr.rend = 0
    rend.UseMipmaps = 1
    rend.WideScreen = 0
    ta.skip = 0
    enable_x11_keyboard = 1
    evdev_device_id_1 = 5
    evdev_device_id_2 = 6
    evdev_device_id_3 = -1
    evdev_device_id_4 = -1
    evdev_mapping_1 = /recalbox/share/system/configs/reicast/controllerP1.cfg
    evdev_mapping_2 = /recalbox/share/system/configs/reicast/controllerP2.cfg
    nox11 = 0
    ElfFile = 
    ta.HashCheckFile = 
    ta.HashLogFile = 
    OpenGlChecks = 0
    fullscreen = 0
    height = 480
    width = 640

  • Another issue (same hardware as previous post), this time with libcec not creating /dev/tty* for my usb cec adaptor. Possible udev issue (missing rule)?
    I have had this adaptor working on the last stable on another box.
    Thanks again.

    # dmesg | grep -i cec
    [    1.943138] usb 1-4: Product: CEC Adapter
    [    3.267137] input: Pulse-Eight CEC Adapter as /devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.2/0003:2548:1002.0001/input/input14
    [    3.267239] hid-generic 0003:2548:1002.0001: input,hidraw0: USB HID v1.10 Mouse [Pulse-Eight CEC Adapter] on usb-0000:00:14.0-4/input2
    # cec-client
    No device type given. Using 'recording device'
    CEC Parser created - libCEC version 4.0.2
    no serial port given. trying autodetect:
     path:     /sys/devices/pci0000:00/0000:00:14.0/usb1/1-4
     com port: /sys/devices/pci0000:00/0000:00:14.0/usb1/1-4
    opening a connection to the CEC adapter...
    DEBUG:   [              11]     Broadcast (F): osd name set to 'Broadcast'
    ERROR:   [            3514]     error opening serial port '/sys/devices/pci0000:00/0000:00:14.0/usb1/1-4': Is a directory
    ERROR:   [            3514]     could not open a connection (try 1)
    ERROR:   [            6349]     error opening serial port '/sys/devices/pci0000:00/0000:00:14.0/usb1/1-4': Is a directory
    ERROR:   [            6349]     could not open a connection (try 2)
    ERROR:   [            8239]     error opening serial port '/sys/devices/pci0000:00/0000:00:14.0/usb1/1-4': Is a directory
    ERROR:   [            8239]     could not open a connection (try 3)
    ERROR:   [            9499]     error opening serial port '/sys/devices/pci0000:00/0000:00:14.0/usb1/1-4': Is a directory
    ERROR:   [            9499]     could not open a connection (try 4)
    unable to open the device on port /sys/devices/pci0000:00/0000:00:14.0/usb1/1-4
    NOTICE:  [           10504]     connection opened
    ERROR:   [           10504]     could not start CEC communications

  • Je suis en test avec la nouvelle version beta "February 2019 Beta Version". Bravo la team, que de boulot dans cette nouvelle beta.

    • Comment peut-on dĂ©sactiver l'indication de compteur de Frames qui dĂ©file en bas Ă  gauche de chaque lancement de jeu quelques soit les consoles ?
    • Pour les bios, il y en a des nouveaux Ă  rajouter. Par contre dans le "Recalbox Manager", il me semble ne plus voir d'ancien BIOS qui apparaissaient avant. Est-ce normal ? Si oui, ceux qui n'apparaissent plus, il faut les supprimer ?

  • Staff
    Global moderator

    @gnubit Thanks for your feedback, we'll take a look as soon as possible on both issues.

    @simba51 AFAIK, only old Amiga BIOS are no longer used (kick13.rom, kick20.rom & kick30.rom)

Want to support us ?