Menu and Kodi is not full screen on old netbook



  • hi... i had an old asus netbook:
    https://www.asus.com/Laptops/Eee_PC_1001PXD/

    with broken screen and heat problem... i fixed it and decided to make it retro box and connect it to TV.
    alt text
    i installed Lubuntu 18.04 on it's main HDD and recalbox into and SD card.
    everything works fine i can get fullscreen Lubuntu and boot from SD card for recalbox.
    it can run games perfectly till Ps1 (45 FPS on PS1 no sound).
    i connected the laptop via the VGA output to the TV.

    every thing works great the only problem is the main menu and kodi is not full screen.
    like the picture the main menu is on bottom left.
    alt text

    and kodi starts on upper left.
    alt text

    but when i start a game it's OK and goes full screen.
    alt text

    please help me fix this problem.
    Thanks.



  • plz help me... still need the solution.



  • @ash1390 Hi
    I'm new with recalbox but it looks like you just need to change the resolution of Emulation station and kodi in the recalbox.conf file with a specific one.
    Or change the global.videomode line but i'm not sure, can anyone confirm?



  • @ash1390

    It may be that xorg is not autodetecting the correct resolution of your 2nd display. You can use xrandr to duplicate the image or set a specific resolution on the vga port.

    Common display names are:
    LVDS - Laptop Screen
    HDMI - High-Definition Multimedia Interface
    DVI - Digital Visual Interface
    DP - DisplayPort
    VGA - Video Graphics Array
    TV - Composite Video
    S-video - S-Video

    Get root access: https://github.com/recalbox/recalbox-os/wiki/Root-access-on-terminal-(EN)

    run xrandr from terminal to see what your displays are: (my example laptop)

    ~ $ xrandr

    VGA-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 340mm x 270mm
    1280x1024 75.02+ 60.02 
    
    1024x768 75.03 70.07 60.00 
    
    800x600 75.00 72.19 60.32 56.25 
    
    640x480 75.00 72.81 59.94 
    
    LVDS-0 connected primary 1440x900+0+0 (normal left inverted right x axis y axis) 367mm x 230mm
    1440x900 59.94+
    HDMI-0 disconnected (normal left inverted right x axis y axis)
    

    Once you know what your display names are you can use xrandr to set your display.
    See the example displays I used with my laptop with a monitor connected via VGA, your display name may be different.

    xrandr --output LVDS-0 --auto --output VGA-0 --auto --same-as LVDS-0 (this will duplicate the same resolution on the VGA port)

    To set a specific resolution on the vga port (eg: 720 resolution)
    xrandr --output VGA-0 --mode 1280x720

    A more complete command that will duplicate the display and set set VGA to 720:
    xrandr --output VGA-0 --mode 1280x720 --same-as LVDS-0

    You could also switch off the laptops display if you want:
    xrandr --output LVDS-0 --off

    Or have the laptop screen off and VGA screen on:
    xrandr --output LVDS-0 --off --output VGA-0 --mode 1280x720

    Once you happy with it you can make it permanent by adding it ~/.xinitrc
    https://github.com/recalbox/recalbox-os/wiki/Change-display-resolution-on-x86---x86_64)

    My apologies for waffling on, hope it may help :)

    Sources:
    https://wiki.archlinux.org/index.php/Xrandr
    https://wiki.archlinux.org/index.php/multihead



  • Apologies the correct wiki link is Change display resolution on x86 x86_64



  • thanks alot for helping.


  • Moderator
    Team
    Moderator
    Translator

    @ash1390 what about changing/adding the parameter in recalbox.conf:

    kodi.videomode=default



  • @ash1390 said in Menu and Kodi is not full screen on old netbook:

    thanks alot for helping.

    So what worked for you in the end ?



  • @gnubit hi gnubit a mi me sale asi , y se me ve como a el
    #!/bin/sh

    matchbox-window-manager -use_titlebar no -use_desktop_mode no -use_lowlight no &

    set the keyboard

    systemsetting="python /usr/lib/python2.7/site-packages/configgen/settings/recalboxSettings.pyc"
    settings_lang="$systemsetting -command load -key system.language"

    not always true (en_US for us), but it's really better than always english

    map_name=$(echo $settings_lang | cut -c 1-2)
    setxkbmap "${map_name}"

    disable dpms to prevent screen to turns blank

    xset -dpms
    xset s off

    to disable a video output (multi-screen setup) and prevent ES to be stretcht on all screens,

    uncomment the line below, and replace output_name by the output that you want disable on ES startup (ex: HDMI-0)

    xrandr --output output_name --off

    auto hide cursor each 5 sec of inactivity

    hhpc -i 5 &

    export HOME=/recalbox/share/system
    export LC_ALL="${settings_lang}.UTF-8"

    without windowed, time must be sleeped to wait that matchbox ended to initialize :-(

    exec emulationstation --windowed



  • @ash1390 hola pudiste solucionarlo



  • @seba-carp

    Hello sebra-carp , sorry but I don`t speak spanish, but looking at your post @ZING referred you here.

    Have you tried ?
    xrandr -s 1280x720



  • @gnubit la unica solucion que encontre fue esta . Pero cada ves que entramos hay que ir a kodi y salir...y queda dicha resolucion..mi maxima resolucion es 1680x1050
    0_1534379325119_20180815_211615.jpg

    0_1534379339261_20180815_211510.jpg


Log in to reply
 

Want to support us ?

Join us on :

244
Online

28897
Users

14664
Topics

110817
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.