Atari ST / Plantage Recalbox



  • Bonjour à tous,

    J'ai un soucis avec les jeux Atari ST sur ma Recalbox.
    Les jeux ne se lancent pas.
    Selon le Rom, j'arrive soit jusqu'à l'interface Atari (écran vert / floppy disks) soit j'ai un écran bleu (ou dans de rares cas, le message de présentation de celui qui propose le jeu).
    A partir de là : que je clique (avec une souris) ou bien que je ne fasse rien, ça plante --> l'écran reste le même, et la Recalbox ne répond plus.
    Je dois la rebooter.
    Une idée sur la raison ??
    Merci à tous !!



  • Petit ajout après plusieurs tests : la console freeze quand j'appuie soit :

    • Sur la touche Y de la manette (manette SNES)
    • Sur le clic gauche de la souris

    Les autres touches ne font pas planter la box mais ne font rien, non plus.
    En résumé : j'arrive à l'écran de présentation de ceux qui ont "cracké" le jeu...Et impossible d'aller plus loin car aucune touche ne le permet.

    Merci d'avance !!!



  • Idem même problème pour moi.
    J'avais pensé à un soucis de RAM disponible avec mon thème mais non.



  • @Substring , @OyyoDams aucune idée du côté des "experts" ?? :)
    Merci !


  • Moderator
    Team

    @Micman
    Je crois que le core va subir un downgrade.



  • @acris Merci de ta réponse !
    Donc aucune autre solution d'ici là ?



  • Les jeux ATARI ST fonctionnent très bien, j'ai fait un set d'environ 300 roms, et tout passe parfaitement. J'utilise un clavier + souris sans fils + Manette 8bitdo SF30Pro sans fil également.
    Sur l'écran de présentation des Crackeurs, il faut soit appuyer sur la barre d'espace, soit sur la touche Entrée du clavier, et parfois dans de rares cas, sur la touche de fonction "F1".
    Mes roms proviennent toutes du set " 2005-11-09 TOSEC " et sont les roms des jeux uniques (pas les compilations avec plusieurs jeux, que j'ai testées aussi et qui fonctionnent très bien aussi d'ailleurs).



  • Je viens d'essayer et ça ne fonctionne pas forcément pour toutes les roms.
    Par contre j'ai encore l'émulateur qui plante avec obligation de reboot.
    Aucun problème avec tous les autres émulateurs.



  • Bonjour,

    J'arrive après la bataille, mais je confirme l'information ci-dessus : le clavier est indispensable au fonctionnement de l'émulation Atari ST.
    Si vous avez des difficultés y compris en utilisant un clavier, merci de le préciser.



  • J'utilise bien un clavier et j'ai toujours des plantages avec l'émulateur. Peut-être les roms. Je n'ai plus essayé depuis.



  • @jomofcw : merci pour la réponse :)
    Mais oui : clavier ou pas---> plantage



  • Moi aussi, cet émulateur à visiblement des soucis, heureusement l'Amiga lui fonctionne!!!



  • Bonjour, j'avais créer un sujet expliquant que certains jeux faisait figer le système recalbox et que c'était donc impossible de quitter par la hotkey.
    Mais je vous conseil pas de forcer a éteindre au risque de perdre des données, il faut passer par le manager pour éteindre.
    En espérant une possible mise a jour du core émulateur s'il vous plait.



  • Bonjour la team,

    Cela fait 1 an que je n'avais pas remis les mains dans ma recalbox que j'utilisais principalement pour emuler mon bon vieux Atari ST, et tout fonctionnait a peu près bien sur un grans nombre de jeux.
    Je me suis décidé a reset ma config avec la derniere version de recalbox, upload du bon tos, branchement Clavier/souris USB, utilsation des memes ROMs qu'avant et la ... le drame :-)
    Meme symptomes que au dessus, des que je click gauche sur la souris sous le bureau Atari, ca freeze .... certains jeux en autoboot passent mais certaines touches et boutons Y Snes font aussi freeze l'émulateur.
    A l'aide , ouin ... :-) Je vais pas lancer des jeux Amiga quand meme ...

    Si je peux aider a ma facon, faite moi signe ... Atari, on est tous des dieux.



  • Il y a une issue à ce sujet sur le github d'hatari

    https://github.com/libretro/hatari/issues/18#issuecomment-435673287



  • Ca n'a pas l'air d'etre le meme soucis, en tout cas j'ai essayé le workaround mais ca ne marche pas chez moi ....:-( Je vais reinstaller une version + ancienne on verra bien ...



  • Pouvez-vous me donner la procédure pour lancer un dump ou mode debugging quand j'ai le pb avec cette émulateur ? J'aimerais aider :-)



  • Semblerait qu'il y ait un fix, comment le tester avec la distrib Recalbox ?

    https://github.com/libretro/hatari/pull/30


  • Themer

    @unclefab pas possible a moins de recompiler recalbox :)



  • @voljega Il est peut-être possible de l'installer sur retropie et de l'importer sur recalbox ? (je dit surement une grosse connerie la ;) )


Log in to reply
 

Want to support us ?

Join us on :

236
Online

31182
Users

15132
Topics

113838
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.