Odroid C2 PSX stuttering / choppy and Sega CD iso issue



  • Hello there,

    I have two issues. The first one is a stuttering issue with PSX Games.

    PSX Games are choppy and are stuttering - making playing PSX Games impossible.

    The second issue is a Sega CD iso issue - loading a iso File will result in a black screen and then returning to the Game selection Menu.

    I already tried a different TV and those Games and isos run on a different retro system (like RetroPi) without issues. Also PSP Emulation works great, so I guess I can rule out an hardware issue.

    Can somebody help me or point me into the right direction?

    Thanks in advance for your help :)

    Edit: I am using recalbox 18.03.30


  • Moderator
    Team
    Moderator
    Translator

    @regalia what hardware do you use? Do you have a good power supply?

    Segacd need bios files.



  • Thank you for your assistance.

    I am using an Odroid C2 Hardware with a good power supply.

    I also can rule out an issue with the ISOs as well - I created them myself and they are working on a different retroOS (like RetroPi) without any issues (both PSX and Sega CD ISOs).

    I also have the matching BIOS files for the Sega CD and the PSX . They are placed in the correct directory and I also checked the MD5 hash.



  • I checked the logs and found this - I don't know if it's helpful, tho - the last lines after I tried to start a Sega CD ISO:

    lvl2: python /usr/lib/python2.7/site-packages/configgen/emulatorlauncher.pyc -p1index 0 -p1guid 030000004c050000c405000011010000 -p1name "Sony Computer Entertainment Wireless Controller" -p1nbaxes 6 -p1devicepath /dev/input/event2 -system segacd -rom /recalbox/share/roms/segacd/TimeGal.iso -emulator default -core default -ratio auto
    lvl2: Creating surface...
    lvl2: Created window successfully.
    lvl2: Added known joystick Sony Computer Entertainment Wireless Controller (instance ID: 0, device index: 0)
    lvl0: VolumeControl::init() - Failed to find mixer elements!
    lvl2: SDL AUDIO Initialized

    Is anybody here who runs an Odroid C2 without those issues with PSX and Sega CD Games?



  • @regalia
    Hello Regalia!
    I too am using an Odroid C2, vers. 18.03.16, and tried all before version. I'll update to 18.03.30 to see if that's the problem, but know that currently psx is a real hell because of the framerate, but sega cd works really fine.
    Currently with C2, the emulators with problems are:
    -PSX
    -N64
    -Sega 32X

    Appart from that, all works fine. N64 was a mess when released but now works better, almost perfect for some games..
    Be sure to check your bios for the Mega CD, as i have had no problem with it. I remember that when i first tried using ISO, i always had black screens, try using .cue & .bin for the games, and let me know.
    If you can, try 32x games and tell me if that work, as PSX are sure not to work correctly, so i may be sure about 32x too...
    Check these other messages for more about it:
    https://forum.recalbox.com/topic/12293/problème-avec-l-odroid-c2-emu-psx
    https://forum.recalbox.com/topic/10518/odroid-c2-4-1-ps1-and-32x-running-slow

    Just to know and try, what iso game were you trying on the sega CD? So i can try it on my recalbox and tell you if it does work or not...

    Edit: Update done, Sega Mega CD still works fine, tried a few games no problem.
    Really try cue and bin, should solve the problem. Also if you can, give the psp a try, it work 100% fine, a real pleasure...
    I really hope that someday PSX works fine and Dreamcast is added...



  • @shadowfrenchy

    Hey there - thank you for your reply :)

    I made another backup from my Sega CD games using the .cue / .bin format. Unfortunately it still doesn't work.

    I tried two games: Time Gal and Sonic CD - both do not work. Only difference now: the screen stays black. I have to end the emulator to return to the Menu (with Hotkey+Start).

    These games work with a different retroOS (RetroPi) so I do not know what I am doing wrong here.

    The BIOS is OK too - the MD5 matches and it shows up as valid on the Manager Website.

    I agree - the PSP emulation works very good.

    I do not know how to test 32x games because there is no 32x folder for the games.

    Thanks again :)



  • @regalia
    Hi!
    Just tried both Time gal and Sonic CD, these two work fine for me (never tried time gal before, i discovered it thanks to you!)
    For the sega cd i use the default emulator and core, no prob...
    I'm contacting you via private discussion, let's talk about that via emails so i can give you something to test...
    As for the 32x, check your "Roms" folder, you should have one named "sega32x" right above your "segacd" folder...
    With some luck, i'll fix your mega cd problem and you'll maybe fix my 32x problem, so all that will be left will be psx (and maybe dreamcast, one can hope)...
    For psx, the problem should be solved by adding other cores and testing which one run best, maybe mednafen (and adding parallel64 for n64). Hoping to see these ones added and finally fixed on the next recalbox release for our Odroid c2



  • @shadowfrenchy

    Hey there,

    thank you for contacting me :)

    I do not have a folder named "sega32x" - maybe 32x support got removed in the latest recalbox release for the C2?

    Is there a way to obtain an older version of recalbox? The website only shows the newest release.

    Maybe an older version will work with Sega CD better so I would try that first. Can anybody give me a link for the 18.03.16 Odroid C2 version?

    It still puzzles me because the images I made do work with a different system, so I do not think the images are the issue.



  • @shadowfrenchy

    I did some more testing. I still have a few Raspberrys here so I ran some tests with a Raspberry Pi 3 - everything works with the recalbox version for Raspberry. So it is not an Image or BIOS issue but definitely an Odroid C2 version issue.

    I can also confirm, that the latest Odroid C2 version has no 32x folder.

    So I guess I have to wait until or if the next Odroid C2 version gets a fix for those issues.

    Its unfortunate that the Odroid C2 does not get the same support as the Raspberry (in general). It is even more powerful then the Raspberry Pi 3 B+ making it a great small retrosystem :)



  • @regalia
    Hi!
    As i was saying, i upgraded to the lattest version and it still works perfectly. I'm using an external hdd to store all my roms, but it's perfect... Do you have an USB key? Gimme your email, so i can give you something to test right now, and fix your problem...

    Edit: I'm creating an image for an USB pen drive specially for you to test, be sure to format a USB pen drive in fat32, and I'll give you a link for you to download and install on the pen drive once I got your email...the image should be ready in an hour or so...



  • @shadowfrenchy

    Hey there,

    my guess is that the newest release has an issue with those systems.

    Is there a link to an older version of recalbox for the Odroid C2?



  • @shadowfrenchy

    Sounds great. Do I just flash it on to my SD Card and boot from it?



  • @regalia
    Hi! As i told you i upgraded to the same version as you, so it's definitively not an issue with the newest release (maybe except for the fact that the 32x folder for the roms disappeared). As for a link for and older version, don't do that as otherwhise what i'm doing for you won't work, we need to have the exact same version...
    As for what to do, no, you won't have to flash your SD card for these tests since we'll be using an usb stick, that way all your actual files and settings will be safe and untouched on the sd card, it's way better for simply testing! As i said, we'll be using a USB stick (be sure it's 4go or above):
    01- If you have one with files currently in use, do a back-up on your pc, then format it in fat32 and name it "TEST".
    02- Then simply get the file i'll give you once you have gave me your email (i WON'T give a link in a public forum, of course), then simply use winrar to uncompress the folder in the file on your USB stick.
    03- Start your odroid c2 and once in the menu, put in the usb port of the c2 the usb stick. Go to the menu (by pushing start button), go to system setting, and then storage device list. Select your USB stick, and the Odroid c2 will reboot.
    04- At the startup, configure again your controller (as it won't remember what was on the SD card), and give the sega cd a try, i put some files for you in there to try.

    Contact me when it's done and let me know how it worked for you!
    But first gimme your email, so i can send you the link for the file that i'm uploading on MEGA...



  • @shadowfrenchy

    I already sent you my E-Mail like an hour ago :D



  • @regalia
    Oups! Sorry, didn't see it, as I'm currently on my phone... I'm finishing the file in about 10mn then I'm uploading it on MEGA. If it's your first time using MEGA, in the meantime you can create your account to grab it once the upload is complete (I don't have a fiber connection so it may take some time, I'll send you the link via email the moment the upload is complete)



  • @regalia
    Upload has started, you'll receive the link in you email in about one hour...



  • @shadowfrenchy

    Thank you. Please give me some time, I will take a look at it as soon as possible.

    I will give you feedback then :)



  • @regalia
    Link send to your email, check it! In case you need help for using the USB stick, look at this post:
    https://github.com/recalbox/recalbox-os/wiki/Use-an-external-usb-storage-device-on-recalbox-(EN)
    And let me know the results!



  • @shadowfrenchy

    Thanks for your link and guess what: Sega CD also does not work with your image. So I am totally at a loss now. Do you have any idea what could be the reason?



  • @regalia
    Hi! Are you sure it booted on the USB stick? Did you see only 2 games in the Sega CD folder? Did you have access to the 32x game and emulator I put in there for test? And what about the other ones? Be sure it started via the usb stick... On the menu, try selecting the USB stick by its name, and if that don't work try "any external storage"... For with the file I gave you as the starting device, we have the exact same configuration, recalbox version, ISO and Rom...
    Did you see any difference with your current version on the menu, just to be sure you started via the USB, as mine is horizontal not vertical, with the Xbox buttons showing on the bottom left of the screen...

    Edit: Last possible scenario, if it's not a booting selection problem and you ARE starting via the usb, maybe there is a problem with your SD card installation of recalbox, try downloading again the file and install all over again...



Want to support us ?

Join us on :

329
Online

26890
Users

13859
Topics

105410
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.