Recalbox 7.0

Problème avec l'Odroid C2 / emu PSX



  • Salut à tous,

    Je suis nouveau, j'espère poster dans la bonne section.

    Voilà j'ai installé cette semaine Recalbox (17.12.02) sur un Odroid C2, tout marche bien sauf l'émulateur PSX (et aussi N64). Le son lag à fond et certains jeux ne sont pas très jouables.

    • j'ai vérifié le md5 du bios, c ok
    • je joue au clavier pour le moment, pas de manette
    • j'ai essayé d'overclocker le C2 (CPU/RAM), c'est un peu mieux mais pas top
    • l'alim: 5.2V @ 3A, je pense que c'est ok
    • carte SD: 8Go class 10 Sandisk (rouge et gris)

    Vidéo ici: https://www.youtube.com/watch?v=6j2JE7_SOmg

    Du coup je ne vois pas trop d'ou vient le souci...

    Je vais tester avec un RPi3 (avec la mm alim) pour voir la différence, mais si quelqu'un a une idée je suis preneur!

    Merci



  • Je viens de faire un "top" en ssh, voici le résultat:
    Ce qui est étonnant c'est le CPU n'a pas l'air chargé.

    Mem: 388220K used, 1370460K free, 3452K shrd, 16788K buff, 119024K cached
    CPU: 23% usr 0% sys 0% nic 74% idle 0% io 0% irq 1% sirq
    Load average: 0.96 0.74 0.40 3/125 1063
    PID PPID USER STAT VSZ %VSZ %CPU COMMAND
    1058 1027 root R 264m 15% 25% /usr/bin/retroarch -L /usr/lib/libretro/pcsx_rearmed_libretro.so --config /recalbox/share/system/configs/retroarch/retroarchcustom.cfg /recalbox/share/roms/psx/Final Fantasy
    86 2 root SW 0 0% 0% [kworker/u8:2]
    936 2 root SW 0 0% 0% [kworker/u8:1]
    85 2 root SW 0 0% 0% [kworker/0:2]
    783 1 root S 73212 4% 0% /usr/sbin/ntpd -g
    1024 879 root R 2496 0% 0% top
    119 1 root S 2368 0% 0% /sbin/klogd -n
    862 834 root S 854m 50% 0% /usr/bin/node server.js
    834 1 root S 841m 49% 0% node virtualgamepads.js
    675 1 root S 461m 27% 0% {emulationstatio} /usr/bin emulationstation
    803 1 root S 30204 2% 0% smbd -D --configfile=/etc/samba/smb.conf
    1027 1026 root S 28968 2% 0% python /usr/lib/python2.7/site-packages/configgen/emulatorlauncher.pyc -system psx -rom /recalbox/share/roms/psx/Final Fantasy VII (France) (Disc 1).cue -emulator default -c
    805 803 root S 28116 2% 0% {smbd-notifyd} smbd -D --configfile=/etc/samba/smb.conf
    806 803 root S 28108 2% 0% {cleanupd} smbd -D --configfile=/etc/samba/smb.conf
    808 1 root S 18864 1% 0% nmbd -D --configfile=/etc/samba/smb.conf
    1026 675 root S 18436 1% 0% sh -c python /usr/lib/python2.7/site-packages/configgen/emulatorlauncher.pyc -system psx -rom /recalbox/share/roms/psx/Final\ Fantasy\ VII\ (France)\ (Disc\ 1).cue -emu
    1028 1026 root S 17256 1% 0% head -300
    366 1 root S 5928 0% 0% /usr/sbin/wpa_supplicant -u
    265 1 root S 5264 0% 0% /usr/sbin/connmand -n
    454 1 root S 4944 0% 0% /usr/sbin/lircd -n --driver=default --device=/dev/lirc0 --output=/var/run/lirc/lircd --pidfile=/var/run/lirc/lircd-lirc0.pid /recalbox/share/system/.config/lirc/lircd.conf
    173 1 root S 4156 0% 0% /sbin/udevd -d
    879 878 root S 3708 0% 0% -sh
    789 1 avahi S 3328 0% 0% avahi-daemon: running [RECALBOX.local]
    237 1 dbus S 2796 0% 0% dbus-daemon --system
    878 794 root S 2712 0% 0% /usr/sbin/dropbear -R
    116 1 root S 2368 0% 0% /sbin/syslogd -n
    859 1 root S 2368 0% 0% /sbin/getty 38400 tty2
    794 1 root S 2348 0% 0% /usr/sbin/dropbear -R
    1 0 root S 1756 0% 0% init [3]
    6 2 root SW 0 0% 0% [kworker/u8:0]
    80 2 root SW 0 0% 0% [ge2d_monitor]
    83 2 root SW 0 0% 0% [kthread_di]
    79 2 root SW 0 0% 0% [mmcqd/0]
    33 2 root SW 0 0% 0% [khubd]
    36 2 root SW 0 0% 0% [kworker/0:1]
    768 2 root SW 0 0% 0% [RTW_CMD_THREAD]
    73 2 root SW 0 0% 0% [kworker/3:1]
    72 2 root SW 0 0% 0% [irq/249-sd_emmc]
    7 2 root SW 0 0% 0% [rcu_preempt]
    71 2 root SW 0 0% 0% [kthread_hdcp]
    14 2 root SW< 0 0% 0% [kworker/1:0H]
    67 2 root SW 0 0% 0% [kworker/1:1]
    69 2 root SW 0 0% 0% [kworker/2:1]
    3 2 root SW 0 0% 0% [ksoftirqd/0]
    208 2 root SW 0 0% 0% [w1_bus_master1]
    74 2 root SW 0 0% 0% [irq/99-sd_emmc_]
    75 2 root SW 0 0% 0% [irq/101-sd_emmc]
    12 2 root SW 0 0% 0% [ksoftirqd/1]
    16 2 root SW 0 0% 0% [ksoftirqd/2]
    20 2 root SW 0 0% 0% [ksoftirqd/3]
    934 2 root SW 0 0% 0% [kworker/0:0]
    2 0 root SW 0 0% 0% [kthreadd]
    5 2 root SW< 0 0% 0% [kworker/0:0H]
    8 2 root SW 0 0% 0% [rcu_sched]
    9 2 root SW 0 0% 0% [rcu_bh]
    10 2 root SW 0 0% 0% [migration/0]
    11 2 root SW 0 0% 0% [migration/1]
    13 2 root SW 0 0% 0% [kworker/1:0]
    15 2 root SW 0 0% 0% [migration/2]
    17 2 root SW 0 0% 0% [kworker/2:0]
    18 2 root SW< 0 0% 0% [kworker/2:0H]



  • Du coup je crois pas que ça soit un pb de matériel, mais d'émulateur.
    J'utilise Libretro et pour le core, PCSX_REARMED

    Mais le truc si je mets défaut aux deux, ça ne change rien.



  • Je crois qu'il n'y a qu'un seul core, psxrearmed.
    Ff7 fonctionne parfaitement sur pi2 chez moi.
    Tu es sûr de la qualité de la Rom ?
    As tu modifié des paramètres dans retroarch ?


  • Banned

    a priori je penserai pour un problème de compilation de cet ému sur Odroid C2 ...



  • @noktambule said in Problème avec l'Odroid C2 / emu PSX:

    Tu es sûr de la qualité de la Rom ?

    Merci pour ta réponse
    Non, pas sur de la ROM, et j'ai modifié des paramètres dans PCSX_ReArmed (avec F1) mais pas grande amélioration

    @noktambule : possible, c'est ce que je voudrais savoir.

    A priori mon alim est bonne mais je suis en cours de tests

    Edit: Pour la ROM, tous les jeux PSX ont ce lag de son, donc je pense pas



  • @voljega faudrait voir avec la team ainsi que des utilisateurs de c2 si lors de leurs tests ils ont eu le même problème...



  • Oui, si la team pouvait tester une ROM avec le C2 pour voir si le problème ne vient pas de chez moi !

    J'ai testé une autre carte SD, 32 Gb samsung (or et rouge) et pareil, même lags de son.
    Je peux aussi envoyer une archive debug si vous voulez.

    A+ et merci pour le taf en tout cas.



  • le odroid c2 a une architecture particulière aarch64 et non arm classique.
    ce dernier ne supporte pas les optimisation NEON sous buildroot, ce qui a forcément un impacte sur l'émulation psx/n64



  • L'émulation N64 fonctionne parfaitement ! (du moins pour le son, car le clavier ne répond pas pour le moment)
    J'attend des manettes qui devraient arriver d'ici peu.



  • j'ai aussi cette erreur dans le log:
    sh: /usr/bin/setterm: No such file or directory



  • @yogg oui l'émulation n64 fonctionne, mais pas aussi bien qu'elle le devrait si on avait un soc arm classique de même puissance.
    de pus l'émulateur pcsx-rearmed est fortement optimisé arm/neon. le fait de ne pas utiliser les optimisation neon a donc un fort impact sur les performances.



  • @rockaddicted
    En ce cas, seriez vous d'accord pour que l'on modifie cette page : https://github.com/recalbox/recalbox-os/wiki/Board-Compatibility-(EN)
    Pour y indiquer que l'émulation psx et N64 sont imparfaites, afin que les futurs acquéreurs de c2 soient au courant du problème ?



  • @noktambule il faudrait refaire des tests avant pour confirmer



  • @rockaddicted
    Pas de problème!



  • Ok alors je vais patienter, espérons un correctif pour la prochaine màj !

    Merci



  • @yogg
    Je ne suis pas sur que tu puisses attendre une amélioration après une mise à jour, a moins que cette mise à jour n'apporte un nouvel emulateur pour psx.



  • Ah... dommage 😞
    Du coup l'intérêt du C2 pour Recalbox est très discutable!

    J'ai vu que Lakka était compatible avec le C2, j'essaie et vous dit si c'est mieux.



  • @yogg
    Si lakka utilise aussi pcsx rearmed, ce sera le même problème. Je ne sais pas ce qu'il en est, le mieux effectivement est de tester !



  • @noktambule
    Ouais c'est pareil. Et pour N64 j'arrive pas à lancer un jeu, le bios n'est pas présent et c'est plus difficile à configurer que Recalbox.
    Je laisse tomber, tant pis.


Log in to reply
 

Want to support us ?

109
Online

79.1k
Users

20.3k
Topics

149.0k
Posts