Unable to stop Emulationstation in 4.1



  • I'm loving the changes in 4.1 but I've had to make my own gameslist for Dreamcast and PSP with the data I want... but I can't upload it as I can't get it [emulationstation] to stop!

    There is no stop button in the 'online manager' - only Start ES and Restart ES

    When SSH and sending /etc/init.d/S31emulationstation stop, the return is:

    "Command '/etc/init.d/S31emulationstation stop' failed with return code 127 and error message /etc/init.d/S31emulationstation: line 24: start-stop-daemon: command not found"

    Has something changed??


  • CRT Fan

    Hi !
    you can try killall emulationstation maybe?
    or kill $(pidof emulationstation)
    but not sure the last command work on recalbox.



  • @idarius said in Unable to stop Emulationstation in 4.1:

    killall emulationstation

    Thanks, killall emulationstation works. Then I have to go back into the manager to restart ES.

    Bit of a pain and I'm sure there's an easier way to do it all whilst SSH-d


  • CRT Fan

    i just tested this two commands :
    /etc/init.d/S31emulationstation stop
    /etc/init.d/S31emulationstation start

    it worked as intended, i'm on a fresh 4.1

    are you connected with root (i think so but never hurt to ask :) )



  • @idarius
    Yes I am, I can't see any reason why the commands won't work :/
    Everything else does bar those two... I know it would make no difference but I thought maybe it was a R/W error so I took rw permissions of the SD card and tried again to no avail...

    Real head-scratcher this one...



  • @matra How have you got your 4.1 ? as an update or a fresh .img ?



  • @substring as an update,

    I have a fresh img to try (but trying that on the Zero for the first time later today)



  • Same error message for fresh install on Pi Zero W...



  • @matra Can't test on Pi0 now, but on my Pi3 :

    # which start-stop-daemon
    /sbin/start-stop-daemon
    

    weird ...



  • @substring
    Found the issue, it's to do with the terminal within WinSCP - which works lovely on 4.0.2 but doesn't want to stop/start.

    Opening in Putty and it works fine...



  • @matra WinSCP to pass some commands ... shame :D


Log in to reply
 

Want to support us ?

Join us on :

237
Online

28783
Users

14635
Topics

110648
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.