4.1 bluetooth pairing persistency issue?



  • First: yay for v 4.1 ! Thanks for all the hard work.

    I updated to 4.1, and tried to pair my 8bitdo devices anew.

    • I can pair from the GUI but even once paired I cannot configure them (does not show up in the list, and when I press a button on the ' press the button of the pad to configure' then nothing happens
    • I tried to pair manually, as explained here: https://github.com/recalbox/recalbox-os/wiki/Connect-bluetooth-controller-manually-(EN)
      • method #1 did not work, my devices are not detected
      • method #2 works (after solving a 'Failed to start discovery' issue, I updated the wiki)

    But again, my pads are paired, but they don't show up in the configure controller GUI.

    What shall I do? Restarting did not help, my devices are just not in the list of devices I can configure.

    Help would be greatly appreciated !



  • Me too with 8bitdo nes30 pro controller.

    Recalbox see bluetooth devices but can't connect....


  • Moderator
    Team
    Moderator
    Translator

    Try resetting the controller itself. I believe you need to press the button next to the power button for about 3 sec. Try pressing the power button 8 seconds otherwise. Forget paired devices and try again.



  • I used the 'forget paired devices' command, then tries again.

    • The pad is seen and I can pair it (pairing successful)
    • But I cannot configure it (not detected on the 'configure device' screen)

    If I switch pad off and on again, pairing does not work automatically (I need to repeat the pairing step).

    It's as if it pairs but the pairing is not persisted. Which file is updated upon successful pairing? Maybe the file is not writable for some reason?



  • @valvolt you don't wantto know how bluez stores its known devices, some data is not user-readable.

    If pairing works but you can't map it, it either means you didn't start it the right way, or that's because the udev rule to forfe joystick on the pad did not work. I'd need a support archive from http://recalbox/help if you're on windows, http://recalbox.local/help for linux/mac



  • After restart recalbox it's can't detect pad...



  • I reset it, change port usb Bluetooth dongle (dongle CLS), and nothing again..

    I test too with android tablet and windows computer it's works only this device now



  • @ppx32 said in 4.1 bluetooth pairing persistency issue?:

    I test too with android tablet and windows

    can't expect Recalbox to behave the same way ... Companies that have thousands of developpers working full time on their OS, and Recalbox, 2.5 devs working on their free time on it ...

    I asked you your support archive, still waiting for it



  • @substring I guess I did start the controller the right way (keep right shoulder button pressed while pressing START), it worked perfectly with the previous version(s) of recalbox.
    I created a support archive, will send it to you via private message since it contains my retroachievement login and password :(



  • Oh second post for return previous recalbox for resolve problem bluetooth pad... :(



  • Hi,
    I´ve also got a problem, connecting my PS3 Dualshock3 SIXAXIS-Controller to Recalbox running on a raspberry pi zero w.
    Each time i boot recalbox, i can`t pair it with the controller.
    After i reset the controller, using the button on the backside, the pairing works.
    If i connect the controller via usb-cable, wait a few seconds and disconnect the controller, it works also.

    Just after a reboot the pairing won`t work.



  • Okay, I made some progress.

    After messing-up quite a bit with diverse commands, I finally managed to pair and configure one of my 8bitdo (mostly through the GUI). But for some reason, as explained in my first post, I can pair my second 8bitdo but I cannot configure it - it is not detected on the 'configure a controller' screen?

    Extra detail, possibly useful:

    My /recalbox/share/system/udev/rules.d/99-8bitdo.rules was completely clogged-up with the same entry over and over. I created the file anew, now I just have my 2 gamepad mac addresses in there.

    I'm wondering whether it's due to line 508 in /recalbox/scripts/recalbox-config.sh ?

    But in anycase, what I did not find is how pads are being detected at the configure controller screen. I don't think I did anything special, so I may have been lucky with my first controller. @substring if you have details about this script I may be able to troubleshoot it?


  • Moderator
    Moderator
    Team

    @valvolt Hi,

    Which 8bitdo pad do you have exactly ?



  • @valvolt So let me explainthat mess with 8bitdo pads ...

    https://gitlab.com/recalbox/recalbox/blob/master/board/recalbox/fsoverlay/recalbox/scripts/recalbox-config.sh#L508 is made to handle those darn pads because they are not detected as gamepads but keyboards. The UDEV rule is here to force the pad as a "real gamepad" regarding the OS.

    But I admit it's made dirtily : we don't check the .rules file to decide if we should add the pad or not. quite easy to fix, never really took time to solve that.

    In your case, you should empty the file and leave a single rule. Or just totally remove the file, reset your 8bitdo pad, forget known bt devices in ES, reboot, and pair again.

    Regarding ES : it just lists devices that have the "joystick" attribute, hence the udev rule.



  • Some more progress...

    1- Huzzah for rolling updates ! I updated the box before following the steps you proposed, @Substring.

    2- I did the following: delete 99-8bitdo,rules, update box, forget controllers, reboot.

    When pairing first device ( @OyyoDams : SFC30), I could pair and configure via the GUI. I can go through the ES menus with the pad and start games, but the pad is not recognized by the emulator (at least the SNES one says something along the lines of 'SFC30 gamepad not configured'. For the record, the emulator also says that my X-Arcade is not configured but I can use it properly so maybe this is a false lead.

    When trying to pair my second device (SNES30), I saw it in the pair list but when selecting it, it said 'unable to pair'. However, after a reboot the pad was instantly paired when switched on. I could use it to go through the menus, I could configure it via the GUI, but as for the other one, it is not recognized (at least by the SNES emulator, maybe I should test other emulators and see if it's the same there [EDIT] Same thing for other emulators (GameBoy, Genesis) [/EDIT]).

    Bottomline: the pads are paired and configured, can be used for menu navigation but not for playing games.

    Hope this helps, looking forward to any further tips. My .rules files now has 3 times the SFC pad and 2 times the SNES pad...



  • @valvolt Are you starting them with the right combo ? If they are started as a keyboard, they won't work in most emulators



  • I start them with R+Start, exactly as I did on the previous version(s) of Recalbox, and as described here: https://github.com/recalbox/recalbox-os/wiki/8bitdo-on-recalbox-(EN).

    Just to make sure, I tried to use keyboard mode (mode 2) but unsurprisingly this failed as well. I also checked that using the stick in USB mode works perfectly.

    How can I check what retroarch sees? Where does it (and other emulators) read info about configured pads? What is weird is that several emulators fail, could there be a mishap upon the saving of the pad configuration (e.g. at the end of the configuration step) ?

    For info, I just configure up, down, left, right, A B X Y L1 R1 Start Select and Hotkey (on Select), leaving all the rest empty. This worked well in Recalbox 4.0.

    Alternatively, does anyone reading this successfully use a 8bitdo on 4.1 or am I the only one so far?


  • Moderator
    Moderator
    Team

    @oyyodams said in 4.1 bluetooth pairing persistency issue?:

    @valvolt Hi,

    Which 8bitdo pad do you have exactly ?



  • @valvolt I have the FC30 arcade stick, worked flawlessly.



  • @oyyodams quoting my post above ;) I have one SNES30 (the one looking like a US pad with purple buttons) and one SFC30 (the one looking like a JP / EU pad with colored buttons). These are 'classic' pads (regular SNES pads, not the Pro version with the sticks). Same problem with both pads. They both worked well before v 4.1 when started with R+Start.

    @Substring ok, so maybe that's a specific issue ?



Want to support us ?

Join us on :

158
Online

28852
Users

14651
Topics

110727
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.