Recalbox 4.1 partage rom synology ds216j



  • Bonjour,

    je commence par mettre les 2 liens du forum que j'ai lus et essayer en plus du wiki :
    https://forum.recalbox.com/topic/6548/unstable-recalbox-4-1-nas
    https://forum.recalbox.com/topic/7727/soucis-liaison-nas/21

    Je suis sur recalbox 4.1. je souhaiterai mettre mes jeux sur mon NAS car tous ne logera pas sur ma carte sd.

    J'ai lu et suivi le wiki mais le montage du nas ne fonctionne pas. Du coup j'ai cherché et tenté de suivre les post au-dessus, mais pour mon cas cela ne fonctionne pas.

    J'ai paramétrer mon NAS avec un utilisateur recalbox et mdp Azerty1 avec comme droit "lecture-ecriture" sur un dossier partagé se trouvant a la racine de mon nas avec a l'interieur un dossier roms (meme architecture que dans le share),bios et saves. J'ai activé le smb.

    Sur mon pc (win7) en tapant la barre executer : \(adresse NAS)\recalbox j'accede bien à mon dossier partagé et les identifiants sont bon.

    Dans la console de recalbox j'ai fais un ping de mon NAS et il est bien vu par le RPI.

    Donc apparemment la config de mon nas devrait etre bonne. Or en suivant le wiki j'arrive bien a changer le sharedevice en NETWORK. je rentre les commande (dans le recalbox-boot.conf): sharenetwork_smb1=ROMS@192.168.1.228:recalbox/roms:username=recalbox,password=Azerty1
    sharenetwork_smb1=BIOS@192.168.1.228:recalbox/bios:username=recalbox,password=Azerty1
    sharenetwork_smb1=SAVES@192.168.1.228:recalbox/saves:username=recalbox,password=Azerty1

    Je sauvegarde en gardant le meme nom de fichier mais cela ne fonctionne pas.
    Recalbox demarre je vois la manette de demarrage + la musique mais ensuite cela revient sur un ecran noir avec le build de la versoin inscrite.

    J'ai tenté plusieurs chose avec mes connaissances et ma comprehension mais malheuresement je ne suis pas aussi debrouillard que les 2 auteurs des liens ci-dessus.

    Merci d'avance cordialement


  • Moderator
    Team

    Bonjour @quikill
    il est TRES IMPORTANT d'être en cable rj45
    le wifi n'est pas supporté pour les NAS,
    es tu en cable réseau ?



  • @acris Oui absolument en rj45. je n'ai mis aucun parfeu sur le nas (oublié de le mentionner)


  • Moderator
    Team

    je sais pas si c'est corrigé avec cette nouvelle méthode mais faut que le réseau démarre apres emulationstation
    sinon il ne le trouve pas.

    peut être que @Substring pourra te répondre.



  • @acris Si le reseau demarre apres emulstation cela fait un ecran noir avec le N° de build affiché? Par contre une fois cette fenetre affichait je ne peux plus rien faire a part debrancher le RPI.



  • De mémoire les mots de passe deconnent



  • Hello ,

    Tu as utilisé le tuto ci dessous ?

    https://github.com/recalbox/recalbox-os/wiki/Charger-ses-rom-depuis-un-partage-réseau-Samba-(par-exemple-un-NAS)-(FR)

    Il faut vraiment suives à la lettre la procédure , c'est ce que j'ai fait ( avec un nas Syno 712+ ) , et j'ai du m'y reprendre a 5 fois car j'avais toujours raté un truc ( mot de passe mal tapé, user sans les droits .. etc etc ).

    Cette histoire d'écran noir est bizarre... par contre ne t'étonnes pas si cela met du temps à démarrer , j'ai plus de 10 000 jeux, et quasi 250 Go de roms, et le PI3 met facilement 5 minutes à se lancer ( surement scan au démarrage ).

    A+



  • @Substring J'ai utilisé le compte guest sans mdp et j'ai crée un compte recalbox avec Azerty1 en mdp.

    @franck-cousquer Alors oui j'ai suivis le tuto. Par contre j'ai pris a partir de =>4.1. Pas avant. Je pense avoir utilisé les bonne synthax.
    Concernant le temps de demarrage j'ai laisser tourner le rpi un certain temps pour voir et un ecran noir sans rien m'est apparu. Je n'ai pas mis de roms j'ai simplement copié le dossier roms presents dans share de la rpi lors d'une nouvelle installation.

    Sur le tuto le délais permettant au reseau de demarrer avant emulstation n'est pas indiqué. Cela est fait d'origine?



  • Je penche pour un probléme de droit sur le NAS , car en 4.1 , la procédure est beaucoup plus simple qu'avec la 4.0 .

    Voila pour mon nas comment les choses se présentent .

    alt text

    Met quelques roms en place pour tester .

    Je ne connais pas ton niveau de connaissance pour le partage fichiers NAS , donc excuse ma question, mais as tu mis dans les propriétes du repertoire "roms" , l'utilisateur recalbox , en lecture/ecriture ?



  • @franck-cousquer
    Bonjour,
    J'ai crée et partagé un dossier "roms". J'ai crée un utilisateur "recalbox" mdp "xxx" avec droit de lecture/écriture sur le dossier.
    Sur Windows je tape \"adresseipNAS"\roms et j'ai une fenêtre d'identification qui apparaît. De la je rentre recalbox et xxx. J'ai acces au dossier roms. Je peux ouvrir les fichiers Txt et ajouter des roms.



  • Bonjour,

    Pardonnez le temps de réponse (pas eu le temps). Vous pouvez mettre en solved le sujet. J'ai reussi a faire fonctionner parfaitement. En suivant vos conseil et en étant plus assidu sur les syntaxes. J'ai utilisé le compte guest en ne mettent pas de MDP.

    Merci a vous.



  • bonsoir, je rencontre quelque difficulté pour l'adresse du nas a renseigner dans nano /boot/recalbox-boot.conf
    le nas est une freebox mini avec hdd en usb.
    dans un navigateur si je tape "file://192.168.0.254/freeboxnas/recalbox/roms/" j'arrive ou il faut
    dans un explorateur "\192.168.0.254\freeboxnas\recalbox\roms" pareil fonctionne.
    par contre quand je met
    sharenetwork_smb1=ROMS@192.168.0.254:freeboxnas/recalbox/roms:username=freebox,password=*****
    sharenetwork_smb2=SAVES@192.168.0.254:freeboxnas/recalbox/saves:username=freebox,password=*****
    avec \ / username,etc sa ne marche pas.
    quelle étape je rate.merci d'avance.
    rpi connecté par cable.



  • quelle bille, je suis en 4.0.2 tu m’étonne que sa marche pas.


  • Moderator
    Team

    @ebayalors bonjour
    merci de créer ton propre sujet si tu as des soucis et de fournir les informations dans le post it nommé LIRE AVANT DE POSTER.



Want to support us ?

Join us on :

146
Online

28790
Users

14637
Topics

110655
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.