Make Kodi go away?



  • Hello all. I am enjoying Recalbox a great deal for game emulation. However, I have no use whatsoever for Kodi/XMBC, as I use a different solution already for streaming. Is there a way I can, for lack of a better way to put it... make Kodi go away? Forever? I don't want to switch from EmulationStation to Kodi. Ever. And it keeps happening accidentally, which is extremely frustrating. Usually when I hit the Xbox button on the Xbox 360 wireless controller I use. I have edited relevant files in the recalbox.conf file as follows:

    ------------ A - Kodi ----------- # ## Show or hide kodi in emulationstation enable_kodi=0 ## Start kodi at launch ;kodi_at_start=0 ## set x button shortcut (enabled by default) kodi_by_xbutton=0

    But they appear to make no difference. Pressing the Xbox button still kicks me over from EmulationStation to Kodi. I am sure Kodi is great at what it does, if you need it. But I don't. How can I ensure I never have to look at it while I am trying to play games again? Thanks in advance for your help!



  • If you look in that file, there is a section on enabling the xbox module. You should enable that, then redo your controller mappings. Worked for me


  • Staff
    Developer
    Global moderator
    Team

    Hi, try to edit your recalbox.conf file with nano on a ssh session. Or try an other editor on windows like notepad ++.



  • Would renaming or deleting kodilauncher.sh also work or would it cause Recalbox to crash?


  • Staff
    Developer
    Global moderator
    Team

    But you'll still have the shortcut on Y and in the menu @nickdj 🙂



  • Elkstreme, If you're talking about the enable_xbox_drv section of the file, I've removed the ; and changed the variable to 1.

    ------------ D - XBOX Controllers ------------ # ## Xbox controllers are already supported, but xboxdrv can solve some compatibility issues ## Disable this if you use ps3 controllers enable_xbox_drv=1 ## set the amount of controllers to use with xboxdrv ;xboxdrv_nb_controls=2

    Retroboy, Trying to avoid having to do things through ssh if possible because as I mentioned in my other thread the ins and outs of it are a mystery to me. I have installed Notepad++ and will try it that way, but why should it make a difference what editor I use to change the variables? Why will Recalbox pay attention to changes made with one editor and not another? The changes to the conf file are definitely saved when I have edited it with Notepad or WordPad, they just don't appear to actually have any effect.



  • Short answer: Because Windows Notepad failed to handle Linux text file properly, blame Micro$oft. Long answer: Read it here http://kb.ucla.edu/articles/opening-a-unix-text-file-on-windows



  • @sunfighterfranchise If you want activate xboxdrv in your recalbox you also need to uncomment this line ;xboxdrv_nb_controls=2 by suppressing ; and specify your controller number at the end.



  • Neko, Well, I have been using WordPad to make edits to the conf file all along, since I immediately noticed that NotePad can't parse the line breaks and makes the whole thing one big wad of text. Rockaddicted, Thanks for this tip. Can you elaborate by what you mean about my controller number? Currently I just have the one wireless 360 controller I am using, so do I just put a 1?



  • Try 'EditPad Lite 7'.  I had the same issues when creating a theme but this works flawlessly.  🙂



  • Yes indeed, if you are using only one xbox controller, so edit you recalbox.conf like this :

        # ———— D – XBOX Controllers ———— #
    
        ## Xbox controllers are already supported, but xboxdrv can solve some compatibility issues
    
        ## Disable this if you use ps3 controllers
    
        enable_xbox_drv=1
    
        ## set the amount of controllers to use with xboxdrv
    
        xboxdrv_nb_controls=1
    

    And to edit the file, as said before don't use the wordpad or notepad included in Windows. But download and use Notepad ++ or EditPad Lite 7. Once the xboxdrv driver activated, the led of your controller should be fixed on the player 1 position and stop to blinking.



  • Update: Made all of the changes mentioned above with Notepadd++, saved the edited conf file again, reconfigured the input on my wireless 360 controller. The LED around the Xbox button on the controller continues to blink constantly instead of fixing in the player 1 position. The Xbox button no longer starts Kodi, but pressing the X (blue) button on the system menu results in a prompt asking if I want to start Kodi. The answer is always going to be NO. Isn't there any way I can get Kodi out of my life forever? Also noticing strange sound issues in some SNES games (notably Looney Tunes B-Ball, one of my favorites); tried switching which SNES emulator is used in the conf file from pocketsnes to Snes9x (I have played this game in Snes9x before with no such problems) but it makes no difference... I am suspicious this line in the conf file is not doing anything either.



  • If you've edited the config file and the LEDs are still blinking, either it's wrong or corrupt. This is exactly what happened to be, so I now do it all from the shell to be safe.



  • What is this portion of the config file supposed to look like? If it's corrupt, how do I fix it? If I delete it, will recalbox autogenerate a new default one?



  • Can't say for sure, I just reinstalled myself and edited from the shell afterwards. From a putty SSH session: nano /recalbox/share/system/recalbox.conf This is mine: # ------------ D - XBOX Controllers ------------ # ## Xbox controllers are already supported, but xboxdrv can solve some compatibility issues ## Disable this if you use ps3 controllers enable_xbox_drv=1 ## set the amount of controllers to use with xboxdrv xboxdrv_nb_controls=2


Log in to reply
 

Want to support us ?

309
Online

82.0k
Users

22.5k
Topics

163.1k
Posts