N64 Pi3B 4.0.2 black screen



  • Hello I can't seem to find to get the N64 games to play on my RPi3 Recalbox 4.0.2. I'm a first time user of recalbox and followed de steps in de DYI. I'm using the PS3 controller from Sony.

    The Nintendo 64 section and games load in to the recalbox but if I chose one to play de screen get black and a moment later my tv states that it can’t play the video format.

    After a few visits to the wiki and forum I've tried a bunch of stuff but didn't work and now I'm clueless.

    Now I've done a clean install, put 3 N64 games on the recalbox and put in the PS3 controller and Tv screen in the config below:

    # System Variable
    # You can configure your recalbox from here
    # To set a variable, remove the first ; on the line
    
    
    
    # ------------ A - System Options ----------- #
    #    Uncomment the system.power.switch you use
    ;system.power.switch=ATX_RASPI_R2_6      # http://lowpowerlab.com/atxraspi/#installation
    ;system.power.switch=MAUSBERRY           # http://mausberry-circuits.myshopify.com/pages/setup
    ;system.power.switch=REMOTEPIBOARD_2003  # http://www.msldigital.com/pages/support-for-remotepi-board-2013
    ;system.power.switch=REMOTEPIBOARD_2005  # http://www.msldigital.com/pages/support-for-remotepi-board-plus-2015
    ;system.power.switch=PIN56ONOFF          # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    ;system.power.switch=PIN56PUSH           # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    ;system.power.switch=PIN356ONOFFRESET    # https://github.com/recalbox/recalbox-os/wiki/Add-a-start-stop-button-to-your-recalbox-(EN)
    
    ## Recalbox Manager (http manager)
    system.manager.enabled=1
    
    ## Recalbox API (REST)
    system.api.enabled=0
    
    ## EmulationStation menu style 
    ## default -> default all options menu
    ## none -> no menu except the game search menu
    ## bartop -> less menu, only needed for bartops
    system.es.menu=default
    
    ## Emulator special keys
    ## default -> default all special keys
    ## nomenu -> cannot popup the emulator menu
    ## none -> no special keys in emulators
    system.emulators.specialkeys=default
    
    ## Show or hide kodi in emulationstation (0,1)
    kodi.enabled=1
    ## Start kodi at launch (0,1)
    kodi.atstartup=0
    ## set x button shortcut (0,1)
    kodi.xbutton=1
    
    ## Kodi can wait for a network component before starting
    ## waithost is the ip or hostname that must answer to a ping to validate the availability
    ## waittime is the maximum time waited when kodi boots
    ## if waitmode is required, kodi will not start if the component is not available
    ## if waitmode is wish, kodi will start if the component is not available
    ## if waitmode is not set or has another value, kodi will start immediately
    ;kodi.network.waitmode=required
    ;kodi.network.waittime=10
    ;kodi.network.waithost=192.168.0.50
    
    # ------------ B - Network ------------ #
    ## Set system hostname
    system.hostname=RECALBOX
    ## Activate wifi (0,1)
    wifi.enabled=0
    ## Wifi SSID (string)
    wifi.ssid=telenet-3AE1D
    ## Wifi KEY (string)
    ## Escape your special chars (# ; $) with a backslash : $ => \$
    wifi.key=PhUx61F3302
    ## Samba share
    system.samba.enabled=1
    ### Virtual Gamepads
    system.virtual-gamepads.enabled=1
    ### SSH
    system.ssh.enabled=1
    
    # ------------ C - Audio ------------ #
    ## Set the audio device (auto, hdmi, jack)
    audio.device=auto
    ## Set system volume (0..100)
    audio.volume=90
    ## Enable or disable system sounds in ES (0,1)
    audio.bgmusic=1
    
    
    
    # -------------- D - Controllers ----------------- #
    # Enable support for standard bluetooth controllers
    controllers.bluetooth.enabled=1
    
    
    ## Please enable only one of these
    # -------------- D1 - PS3 Controllers ------------ #
    ##Enable PS3 controllers support
    controllers.ps3.enabled=1
    ## Choose an driver between official, shanwan and gasia if you have dualshock clones (official,shanwan,gasia)
    controllers.ps3.driver=official
    
    
    # ------------ D2 - XBOX Controllers ------------ #
    ## Xbox controllers are already supported, but xboxdrv can solve some compatibility issues 
    ## Enable xboxdrv driver, disable this if you enabled ps3 controllers (0,1)
    controllers.xboxdrv.enabled=0
    ## Set the amount of controllers to use with xboxdrv (0..4)
    controllers.xboxdrv.nbcontrols=2
    
    
    # ------------ D3 - GPIO Controllers ------------ #
    ## GPIO Controllers
    ## enable controllers on GPIO with mk_arcarde_joystick_rpi (0,1)
    controllers.gpio.enabled=0
    ## mk_gpio arguments, map=1 for one controller, map=1,2 for 2 (map=1,map=1,2)
    controllers.gpio.args=map=1,2
    
    
    ## DB9 Controllers
    ## Enable DB9 drivers for atari, megadrive, amiga controllers (0,1)
    controllers.db9.enabled=0
    ## db9 arguments
    controllers.db9.args=map=1
    
    ## Gamecon controllers
    ## Enable gamecon controllers, for nes, snes psx (0,1) 
    controllers.gamecon.enabled=0
    ## gamecon_args
    controllers.gamecon.args=map=1
    
    ## XGaming's XArcade Tankstik and other compatible devices
    controllers.xarcade.enabled=1
    
    
    
    # ------------ F - Language and keyboard ------------ #
    ## Set the language of the system (fr_FR,en_US,en_GB,de_DE,pt_BR,es_ES,it_IT,eu_ES,tr_TR,zh_CN)
    system.language=en_US
    ## set the keyboard layout (fr,en,de,us,es)
    ;system.kblayout=fr
    ## Set you local time
    ## Select your timezone from : ls /usr/share/zoneinfo/ (string)
    ;system.timezone=Europe/Paris
    
    
    
    # ------------ G - UPDATES ------------ #
    ## Automatically check for updates at start (0,1)
    updates.enabled=1
    # Update type : default to stable
    # set to unstable at your own risk to get the development version.
    updates.type=stable
    
    # ------------ H - HERE IT IS - GLOBAL EMULATOR CONFIGURATION ------------ #
    ## The global value will be used for all emulators, except if the value
    ## is redefined in the emulator
    
    ## Set game resolution for emulators
    ## select your mode from the command : tvservice -m [MODE]
    ## CEA 5 HDMI : 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced 
    ## CEA 4 HDMI : 1280x720 @ 60Hz 16:9, clock:74MHz progressive
    ## use 'default' for using the default resolution
    ## (string)
    global.videomode=CEA 16 HDMI
    
    ## Shader set 
    ## Automatically select shaders for all systems
    ## (none, retro, scanlines)
    global.shaderset=none
    
    ## Once enabled, your screen will be cropped, and you will have a pixel perfect image (0,1)
    global.integerscale=0
    
    ## Set gpslp shader for all emulators (prefer shadersets above). Absolute path (string)
    global.shaders=
    
    ## Set ratio for all emulators (auto,4/3,16/9,16/10,custom)
    global.ratio=auto
    
    ## Set smooth for all emulators (0,1)
    global.smooth=1
    
    ## Set rewind for all emulators (0,1)
    global.rewind=1
    
    ## Set autosave/load savestate for all emulators (0,1)
    global.autosave=0
    
    ## Enable retroarchievements (0,1)
    ## Set your www.retroachievements.org username/password
    ## Escape your special chars (# ; $) with a backslash : $ => \$
    global.retroachievements=0
    global.retroachievements.username=
    global.retroachievements.password=
    
    ## Set retroarch input driver (auto, udev, sdl2)
    ## If you don't have issues with your controllers, let auto
    global.inputdriver=auto
    
    ## If you do not want recalboxOS to generate the configuration for all emulators (string)
    ;global.configfile=/path/to/my/configfile.cfg
    
    # ------------ I - EMULATORS CHOICES ----------- #
    ## You can override the global configuration here
    ## Here is the snes example
    ;snes.videomode=CEA 4 HDMI
    snes.core=snes9x_next
    ;snes.shaders=/recalbox/share/shaders/shaders_glsl/mysnesshader.gplsp
    ;snes.ratio=16/9
    ;snes.smooth=0
    ;snes.rewind=1
    ;snes.autosave=0
    ;snes.emulator=libretro
    ;snes.integerscale=0
    ## If you do not want recalboxOS to generate the configuration for the emulator : 
    ;snes.configfile=/path/to/my/configfile.cfg
    
    ## Default cores for RPi3
    snes.core=snes9x_next
    gba.core=mgba
    mame.core=mame078
    nes.core=fceunext
    
    ## NeoGeo emulator 
    ## You can use pifba or a libretro core (fba2x,libretro)
    neogeo.emulator=libretro
    ## If you set libretro as neogeo.emulator, the line below sets the retroarch core (fba,imame4all)
    neogeo.core=fba
    
    ## N64 emulator is configured to display a screen with a 640x480 resolution (native n64 resolution)
    ## So you must use one of these video modes (DMT 4 HDMI,CEA 1 HDMI).
    ## If your screen is not compatible with one of these video modes, please check the recalbox's wiki.
    n64.videomode=DMT 4 HDMI
    ## If you are using a CRT screen, please change the setting above with this one : 
    # n64.videomode=default
    
    ## Configurations generated by Recalbox
    

    th0_1492463327049_WP_20170417_12_19_52_Pro.jpg 0_1492463601518_N64 games.png

    Hopefully someone can give some directions or information how to handle this. Thank you very much for any given information!



  • @Maarten003 in recalbox.conf try n64.videomode=CEA 1 HDMI instead of n64.videomode=DMT 4 HDMI


  • Moderator
    Team

    @Maarten003 I guess your TV is lying regarding its supported video formats ;) So try what @pepe sugested, then try any other mode.



  • @Pepe @Substring Okay, the CEA 1 didn't work but indeed an other: the CEA 4 works. I thought to have read that i needed to take the small ones. Apparently not, thank you verry much! My collegues at work will be happy to, I was really bummed out, that I couldn't relive my childhood :').

    Now I can see the games are running slow but thought to have read someting about that on the wikki and will search for it.

    Thought about getting a new tv for a second there, because my mate just did plug and play ! :D

    Again thank you very much!


  • Moderator
    Team

    @Maarten003 we set DMT 4 to reduce CPU calculation and make N64 more fluid ... increasing the resolution makes it slower ... nothing more nothing less



  • Hi, guys.

    I have the same problem and the changes n64.videomode=DMT 4 HDMI to n64.videomode=CEA 1 HDMI doesn't worked for me.

    I have tried to do the n64 work in my rasp2 since three weeks ago, and I don't have success. I searched in the forum and tried all supposed solutions, but still don't work.

    I saw in the forum who the problem may be due to the byte format of the roms, the screen resolution, and the configuration of the joysticks.

    So, I kept trying.

    • My roms of n64 is Byteswapped;
    • I tried changes the n64.videomode to all option who have resolution 640x480 from my TV (i tried also in a monitor);
    • I tried with two differents controllers (ps2 format);
    • Controllers model:
      0_1501066775537_Screen Shot 2017-07-26 at 07.58.38.png

    But still, the n64 returns to emulation station after the black screen.

    Please, help me, guys.
    I can try with a clean installation.


  • Moderator
    Team
    Moderator
    Translator

    @rubem-moura

    Have you setup the Joysticks on UI correctly (The "L" Buttons also)?



  • Hi @abunille
    Thanks for your reply.

    I used the menu to configure the joysticks (Controller Settings-> Configure a Controller).
    In this menu, he asks me to choose the L1 R1 L2 R2 buttons, and i set according to ps2 controller model (the controller of the pictures above).

    I don't know if this procedure is correct to n64.


  • Moderator
    Team
    Moderator
    Translator

    @rubem-moura

    Ok, the joystick configuration seems ok.
    As i can read below, you have already change the videomodes.
    https://github.com/recalbox/recalbox-os/wiki/N64-%3A-return-to-ES-%28EN%29

    With other systems the games are starting and the joysticks works in recalbox?
    Have you checked a game without plug in a joystick (only with keyboard)?

    The only problems i know are

    • wrong videomode
    • joystick not configured ("L") or is not supported
    • bad roms


  • Hi @abunille ,

    Yes, i tried to do like explained in this tutorial (https://github.com/recalbox/recalbox-os/wiki/N64-%3A-return-to-ES-(EN)), but still don't works.

    With other systems the games are starting and the joysticks works in recalbox?

    • With all others systems (NeoGeo, MegaDrive, SNES, PS1...), i can play with this two joysticks, without any problem.

    Have you checked a game without plug in a joystick (only with keyboard)?

    • Yes, i tried do this after see in other topic, but still don't works

    :'(

    I will put here my configuration file and recalbox.log.


  • Moderator
    Team
    Moderator
    Translator

    @rubem-moura

    strange.
    The rom extensions are .n64 .N64 .z64 .Z64 .v64 .V64, right? Not .zip

    For your configuration and log, please have a look here:
    https://github.com/recalbox/recalbox-os/wiki/Recalbox-support-%28EN%29



  • @abunille

    Yes, my roms aren't .zip.
    And i checked with toll64 application, who my roms are byteswapped.


  • Moderator
    Team

    Did you check if your screen is compatible with the default N64 video mod ?



  • Hi @rockaddicted ,

    When i run the comand tvservice -m DMT and CEA, the output contains the resolution 640x480 like an option. I tried use them but still don't works.

    Here my log file with same information when i try run n64:

    0_1501154052468_Screen Shot 2017-07-27 at 08.12.54.png


  • Moderator
    Team

    ok so, upload support archive, I'll check your setup (look @abunille post).
    Then log on ssh, /etc/init.d/S31emulationstation stop then /etc/init.d/S31emulationstation start. Now keep this ssh window open, start a N64 game and check in this ssh window if an error is displayed.



  • @abunille ,

    i can't get the recalbox-support.sh file now (i'm working), but i will put this file here later.



  • Ok @rockaddicted ,

    I will do this later (i'm working) and will put the result here.
    Thanks!



  • Hi guys!

    Ok @abunille and @rockaddicted , i do a clear installation to undo the old any changes.

    After this, i configured again the joystick (Clone), and put an video here to you check if is correct. Youtube Video

    I put the n64 roms into the corresponding folder. All roms in format .n64 and byteswapped (checked with tool64 application).

    So, i tried start n64, without any modifications in recalbox.conf file and still don't works.

    :|

    Ok, i open the recalbox.conf file, and i compare with other recalbox.conf file from the GitHub. In my file, was missing an text, who defines some configuration to n64:

    0_1501196145971_n64 missing.PNG

    So, i copy and paste this stretch to my file, and tried start n64, but still don't works.

    I tried apply the modification about the video mode (link), changing n64.videomode=DMT 4 HDMI to n64.videomode=CEA 1 HDMI , but still don't works.

    This is my output from tvservice command: 0_1501197056735_tvserivce.PNG

    After this, i do the processes to get the recalbox support file, described in this link. And here is my support file: GoogleDrive File

    So, i get the log via ssh with the commands /etc/init.d/S31emulationstation stop and /etc/init.d/S31emulationstation start, and here is the output after i tried start a n64 game: 0_1501196926433_log error.PNG

    Ok guys!! Please help me!



  • Just remembering: Now, the recalbox version is 4.0.1, and my rasp is pi2.


  • Moderator
    Team
    Moderator
    Translator

    @rubem-moura

    we must wait for @rockaddicted to read the support file, he is more a pro than me ;)

    But what i see in your log is (i hope i am right):

    • Machine model: Raspberry Pi Model B Plus Rev 1.2 (seems to be a pi1)
    • Load BCM2835 DMA engine driver (also a sign for pi1, pi2 has BCM2836)
    • hw perfevents: enabled with armv6_1176 PMU driver (also, pi2 has Cortex-A7)

    And this means it is a pi1 and not pi2.
    And how i know a pi1 is not supported with n64.

    But how i write above, better to wait for @rockaddicted


Log in to reply
 

Want to support us ?

291
Online

24243
Users

12894
Topics

97629
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.