Thunder Force 4 (Megadrive) freezes ?



  • Hello all,

    First of all, thanks for the tremendous work you've been all doing, it's amazing to be able the play the game of my youth that easily !
    Now, I have an issue while playing Thunderforce 4 on Megadrive.
    From time to time (though it's seems to appear on identified moments), the game simply freezes, and no other possibility than resetting or loading a save.

    Here is my technical configuration :
    Raspberry Pi model: RPi 3
    Recalbox version (build) : 4.0.2
    Hardware (Micro SD, Power Supply, etc.): microSDHC SanDisk Ultra 64 Go Classe 10
    Controller(s): Recognized as Xbox 360 (working perfectly on any other game/emulator).

    Here are the game details :
    Which Game: Thunder force 4 (tried several rom versions)
    Emulator used: Picodrive (tried Genesisplugx but the game is so slow, I can't play)
    Is the problem reproducible (how): This happens every time at the first level ("Strite")during boss fight.
    Almost everytime when it shots some orange beams (like autoguided orange drops), the game freezes.
    Just in case, here is a screenshot of the boss I'm talking about :
    alt text

    Please note that I didn't face this issue with any other game (whichever emulator or rom used).
    I tried to change a couple of settings like deactivate the Rewind feature and so on, but doesn't change anything.

    If you had any advice I'd take it.

    Thank you all

    Phil

    PS : note that the game also freezes at other moments, other levels (while picking up lives in this same level or in level "Daser" for instance)


  • Moderator
    Team
    Moderator
    Translator

    @motenai79 i want to congratulate you because you belong to the vey exclusive group of people that gives all relevant information when creating a topic!!! Belive it or not, it makes me very happy every time that happens!

    Back to your question... I can't test the game but it might just be that either the pi isn't powerful enough for that game or the emulators can't handle it properly (at this point). For recalbox 4.1 unstable the cores have been bump to the latest commits of the libretro repo, and that might help sometimes. But only you can test it and see if the situation improves. Be aware that it still is an unstable version, so bugs and similars are to be expected. Check the blog to know how to update in case you want to test, and back up everything before doing that!



  • @paradadf

    Hello,

    Thanks for your quick response.
    As for the relevant information, I'm used to working in IT environnement hence, providing all necessary information for an efficient troubleshooting is kind of mandatory in this business !!! But I really appreciate your comment on this, thanks !

    Regarding my issue, I'm a bit surprised that the RPi3 could be not powerful enough for that (although I estimated its limits when trying to play 3D arcade games like soul Calibur of Street fighter EX, veeeeeeeeeeeeeeeery slow, unplayable). But for Megadrive I'd rather think, as you mentioned, that the emulator is not perfectly fit for this game.

    You're right, I may try and format a new Micro SD card and install the 4.1 recalbox unstable version and give it a try.
    I spent dozens of hours sorting and testing the hundreds of games I have here, I don't want to ruin all this because of that. So I'd prefer testing with a whole fresh new install.

    Quick question : If I install the 4.1 unstable version of recalbox, I suppose I would have to reinstall the same Megadrive Bios or is it also going to be updated ?
    While writing it, I'm thinking that the Bios is the manufacturer's original code, hence, not subject to any evolution whatsoever (given that the console is discontinued), therefore the improvement lies in the way recalbox handles this Bios, not the bios itself. Am I right ?

    If the issue is solved with this unstable version, then I'll wait for the official 4.1 release.
    It's no big dead anyway, my life doesn't depend on it ;)

    I'll give it a test and post an update in a few days (you never know, it might be useful for someone else facing the same issue).


  • Moderator
    Team
    Moderator
    Translator

    There is no bios needed for megadrive, check:
    https://github.com/recalbox/recalbox-os/wiki/Add-system-bios-(EN)

    I know for instance that Pier Solar (on the megadrive) doesn't run on picodrive (at least not well yet) and it works perfevtly fine on genesisplusx. That happens with gba games quite frequently as well. Sometimes there are game specific tweaks that an emulator needs to implement, so updating isn't a guarantee that it happened.



  • @paradadf

    Hello,

    You're right, my bad, I had the Sega CD bios in mind, my bad.

    As promised, I ran some tests.
    I installed version 4.1 unstable on a fresh new MicroSD card.

    To be more precise : version 4.1.0-master-rpi3-2017-03-05-09-29-03-116003320

    I tested 3 different roms (European, Japanese and US versions), on both GenesisplusGX and Picodrive emulators.
    For each test, I ran the first level from beginning to end (up to the boss explosion).
    The results for the US and Japanese versions are identical.

    On Picodrive, the game behaviour is the same as on the 4.0.2 version :

    • US/J : Thunder Force IV (U).bin + Thunderforce IV (J) [P1] [!] : Works fine, no freeze, although a framerate drop is noticeable when numerous sprites are on the screen (which happens quite often because it's a shmup after all, beams and lasers also count as sprites)
    • E : Thunderforce IV (E) (C) [!] : Game freezes on the mentioned identified moments

    On GenesispluGX :

    • US/J : Thunder Force IV (U).bin + Thunderforce IV (J) [P1] [!] : Works fine, no freeze, although a framerate drop is noticeable when numerous sprites are on the screen
    • E : Thunderforce IV (E) (C) [!] : No freeze, works fine, although the screen resolution is forced to full screen (I guess that can be configured somewhere, although I didn't look for it).

    To make it short :
    Things seems to improve on the European version on the forthcoming version of Recalbox.
    Now the game can be played on GenesisplusGX (which is impossible on version 4.0.2 : way to slow and the sound is distorded), although the screen resolution needs to be reset.
    No improvement noticed on the Picodrive emulator, the game freezes on the same conditions as on the 4.0.2.

    As for my issue on 4.0.2, I'll switch to the US version of the game (Thunder Force IV (U).bin, that's the version that proposes infinite lives at start up ;) ).
    Even if it has a framerate drop from time to time, at least I can play !

    I wanted to be more accurate by giving the actual framerate while playing but even though the option was enabled, the information disappears while playing.
    Instead the screen displays a line of squares at the bottom (like missing font caracters).

    The glimpse of the 4.1 version of Recalbox I saw seems very promising, the list of improvements at the first start is very impressive.
    The new Retroarch version (very XMB-like) is a really good idea.
    Although I noticed some weird changes on the menus (like the "update game list" option that's not under the Games menu anymore), I guess the developers have their reasons on these changes.
    Anyway, it's no big deal, we'll get used to it.

    Again, the work done by all of you guys is very impressive.
    I have a quick question, is it possible for someone to give feedbacks on this unstable version ?
    Do you accept people to be like "beta-testers" ? I would gladly test some features if you need extra hands.

    Have a good day.


  • Moderator
    Team
    Moderator
    Translator

    @motenai79 the xmb ui of retroarch has been corrected, we will keep the rgui because it condumes less resources.

    About reporting bugs for 4.1...
    https://forum.recalbox.com/topic/6453/4-1-unstable-bug-reports

    The was is also a topic about testers on the forum. Write there so the devs consider you. But actually, anyone testing the latest unstable and reporting bugs is for me a tester and is helping the community.



  • @paradadf Unfortunately Thunder Force IV Japanese version is still crashing in the 4.1 stable version. :_( At least it works in GenesisplusGX



  • @kelv @paradadf

    I can confirm the issue. Tried to play this wonderful game yesterday and the emulator got stuck after 7 min gameplay.

    Using the default Megadrive(Genesis) core.



Want to support us ?

Join us on :

432
Online

28218
Users

14439
Topics

109242
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.