[4.1-Unstable] Bug reports



  • Hey guyz,

    This 4.1 is a major leap forward, and is not yet bugless. Please use this thread to report bugs you found.

    Known bugs so far :

    • retroarch squares : there is a workaround : just remove ~/configs/retroarch/retroarchcustom.cfg Recalbox will regenerate it with the proper values. People using custom configfiles should add the value manually. Might be solved with a retroarch bump, no idea Solved since build 11167165
    • can't update with a FAT32 USB key from 4.0.1 to 4.1 : yeah, that's a major problem, we're investigating on that Solved
    • dreamcast : i've had no problems with it so far, here are the bios hashes i was using :
    e10c53c2f8b90bab96ead2d368858623  dc_boot.bin
    0a93f7940c455905bea6e392dfde92a4  dc_flash.bin
    
    • manager (and even anything related to the upgrade of the recalbox.conf) : the upgrade process of that file says no update is necessary, which is totally wrong. Should fix that very soon Solved since build 11167165
    • no scrape visible : i had the same issue yesterday, couldn't find the origin of the problem, thanks for the workaround @lackyluuk : edit reccalbox.conf and add emulationstation.forcebasicgamelistview=0
    • C64 : is listed but no emulator behind. Needs a bump to a SDL2 version rather than this SDL1 version. For people who REALLY want to play: you'd need to kill the vice process, through SSH, then all other launches should work ok until you reboot. I still haven't figured out how to configure controllers for that emulator yet, help would be appreciated
    • PSX + xbox 360 pads : infinite rumble in with games like Bushido Blade or Enhander. Would need confirmation on non x360 pads
    • DO NOT USE THE REINFORCED SECURITY FEATURE !!!
    • upon updating, the update type switches back to stable sometimes

    Thank you for reporting all this, keep hunting bugs :)



  • @Substring Tried Dreamcast, and see the start screen with the dreamcast logo. But then only a white screen. But I can hear the music running



  • @Substring when I save or load a state, I only see square at the bottom of the screen. Can't read the text

    Great work by the way! Keep it up :)



  • @Substring can't reach recalbox manager. Tried to set it both to 1 or 2 in recalbox.conf but get an error message when trying to connect to the IP address of my raspberry


  • Translator
    Translation Master

    • Cannot reach recalbox manager anymore. It is activated through ES menu.
    • No scrapes visible. There is obviously already a solution: Add the following line to recalbox.conf: emulationstation.forcebasicgamelistview=0


  • As mentioned in other thread (just to keep things together):
    When I launch the C64 emulator, it always exits back to EmulationStation.



  • @treacle I fixed the issue adding a new line this line system.manager.version=2 in the recalbox.conf



  • Nes games are not working... Castlevania 3 for example, grey screen



  • Some psx games Bushido Blade, Enhander the pad vibration/rumble is not stopping



  • On Screen messages during the game are showing squares instead of letters, it seems that the character set is not latin. Another fellow from the forum reports is fixed if you install it from the scratch instead of updating.



  • So much enthusiasm for bug reports <3

    So, a quick round-up :

    • retroarch squares : there is a workaround : just remove ~/configs/retroarch/retroarchcustom.cfg Recalbox will regenerate it with the proper values. People using custom configfiles should add the value manually. Might be solved with a retroarch bump, no idea
    • can't update with a USB key : yeah, that's a major problem, we're investigating on that
    • dreamcast : i've had no problems with it so far, here are the bios hashes i was using :
    e10c53c2f8b90bab96ead2d368858623  dc_boot.bin
    0a93f7940c455905bea6e392dfde92a4  dc_flash.bin
    
    • manager (and even anything related to the upgrade of the recalbox.conf) : the upgrade process of that file says no update is necessary, which is totally wrong. Should fix that very soon
    • no scrape visible : i had the same issue yesterday, couldn't find the origin of the problem, thanks for the workaround @lackyluuk
    • C64 : need to bump to a SDL2 version rather than this SDL1 version. For people who REALLY want to play: you'd need to kill the vice process, through SSH, then all other launches should work ok. I still haven't figured out how to configure controllers for that emulator yet, help would be appreciated

    Thank you for reporting all this, keep hunting bugs :)



  • @Substring THX the square issue is gone :) with the workaround provided



  • I'll update the 1st post with known issues


  • Translator
    Translation Master

    @Substring the credits for the solution of the absence of the scrapes goes to @acris :)
    I just added it here to the english thread



  • PCSX_REARMED can not play Zanac x Zanac --> Zanac Neo, freeze at memory card check.
    It is the PCXS_REARMED version problem, old version ( recalbxo 4.0 use it ) can play it.



  • @Substring Just realized, that I still had my USB BlueTooth dongle plugged in. Removed it and rebooted to try the internal BlueTooth. Now I can't connect my PS3 controller via BlueTooth. Works with the cable though. Oh, and I pressed the little button at the bottom to reset the controller.

    Is there anything I need to set in the conf?



  • @treacle you need to reset your pad as bluez5 manages pairing according to the BT dongle MAC address. So you can't switch from one dongle to another without repairing.

    plus your PS3 pad knows its master mac address, so it wouldn't connect to the internal bt



  • At the start, when the new start screen is displayed the sound is VERY HIGH, I would say 100%. Once the menu appears, it is adjusted to what we have adjusted.

    Also it would be well that the volume of the background music of the menu can be regulated independently to the one of the games, since the music of the menu is higher than the one of the games.

    thanks!!!!
    sorry for my english



  • @ferminote

    [url=http://subefotos.com/ver/?95ab49bc1f1591a670fc660332c0b449o.png][img]http://thumbs.subefotos.com/95ab49bc1f1591a670fc660332c0b449o.jpg[/img][/url]



  • @ferminote your english is fine :) The fact is that the sound volume is at default at this moment and has not yet been set to what users defined it in ES


Log in to reply
 

Want to support us ?

Join us on :

282
Online

31042
Users

15113
Topics

113725
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.