Urgent/Hurry !!! Emulationstation not launching after brutal power off (removing cord manually)



  • Hy,

    I got this problem a long time ago but I don't remember what was the solution to this, and I can't find post about it. I'm in a hurry, people are supposed to come and play at home 😢

    I powered off the recalbox by removing cord manually , and now i can't boot anymore in emulationstation (i'm stuck in the black screen with the recalbox logo at the bottom).

    I remember past in the days i had to remove a file or something like this but i can't find which one

    THanks in advance for your help !!!



  • I'am trying to sumon @Substring or @rockaddicted



  • Thanks,

    I have in order : Rainbow screen, recovery mode pressing shift screen, black screen with recalbox logo, emulationstation loading screen for a few seconds, then black screen again and it gets stuck here forever.



  • My bad :'(, I did a full reinstall of recalbox 4.0 , it worked, then i copied my saved files as i always do and the problem shows up again omg, I dont know what's happening



  • Maybe a corrupted file? Try to removed your files and add them incrementally...



  • Damn, i'll copy the content of files not the file itself, seriously the first day i plan a session with friends, I used recalbox/retropie since 3 years, i modified lots of things, not now 😢



  • What's your "saved files"? Thousand of files, some config files, all of your /share folder?



  • some configfiles (fstab,s92emulation,recalbox.conf,...) , themes files, retroarchconfigfiles, etc...



  • I managed, reinstalled everything and copied properly what i needed to, so problem solved.
    Yet It would be nice to have clues on what to do except reinstalling everything in case of this kind of problem ?

    Thanks in advance.



  • Maybe have a look in logs: /recalbox/share/system/logs/ and /recalbox/share/system/.emulationstation/es_log.txt


  • Staff
    Developer
    Team
    Global moderator
    Translator

    I'd recommend you to backup your share partition. Actually, te best would be using an external storage device for the share partition. That way is very unlikely that something corrupts it even if you unplug your recalbox like an animal (no offence).



  • corrupted gamelists ?



  • I had similar issue and I did a full re-install of Recalbox. I have all my games and configuration in an external WD Element HD connected to the RPI3 via USB. The good thing of this you don't need to mess about moving games and conf to the SD. All the configuration is inside the external HD. So, when reinstalling, you don't need to worry about the SD. Just reinstall and select the external HD as your preferred storage and all your roms and configuration will be there.



Want to support us ?

450
Online

81.5k
Users

22.3k
Topics

161.5k
Posts