problemas controles emulador mame



  • Buenas tardes,

    Os vengo a pedir ayuda, ya que desde hace unos días tengo problemas con el emulador de mame.

    Aclarar que tengo la placa the que convierte los botones como si se tratara de un teclado en una bartop con raspberry pi 3.
    Desde hace unos días, al entrar en cualquier juego, los botones no funcionan, no me deja meter créditos ni funciona el hotkey + b ni el hotkey + start. Si desde el archivo recalbox.conf quito la línea del archivo mamecustom.config que contiene las referencias metidas desde libreto, consigo que las rom interpreten el hotkey + a, hotkey + start y el joystick, pero sigo sin conseguir que el resto funcione o al menos el select.

    Aclarar que con el resto de emuladores funciona sin problemas, ya que por ejemplo en el emulador de la neogeo, meto créditos y funciona todo sin problemas.

    Hoy he borrado el archivo recalbox.conf para que se generará de nuevo, pero sigue existiendo el mismo problema.

    Puede ser que se me haya corrompido el software? Ya que si fuera del hardware, no me funcionaria con nada.

    Gracias por vuestra ayuda.


  • Moderator
    Team
    Moderator
    Translator

    Que significa tu "desde hace unos dias"? Que antes funcionaba y de un dia para otro dejo de hacerlo?



  • Si, es decir, desde que la tengo desde junio de 2016 hasta el 23 de diciembre que fue la penúltima vez que jugué, jugué con el emulador de mame sin problemas. Pero al ponerla este sábado, es cuando al jugar a alguna rom del mame me ha pasado esto. Aclarar que el sábado moví de sitio la bartop, pero como dije si fuese problema de hardware (claves sueltos, etc) no me funcionaria nada.



  • A mí me pasó algo parecido cuando se me actualizó de la 4.0.0beta3 a la 4.0.0beta5, los juegos MAME dejaron de funcionar (las teclas funcionaban correctamente), los lanzabas y te volvían a la pantalla principal. Al final lo corregí haciéndome una copia de las carpetas bios y roms y volviendo a instalar desde cero la 4.0.0beta5, aunque no es exactamente lo que te pasa a ti...

    ¿Se te ha actualizado?



  • No, a mi lo que me pasa es que llega a entrar a la rom y cuando estoy en la pantalla de presentación para meter los créditos, los botones, es como si no funcionasen, pero con el resto de emuladores funcionan los botones sin problemas. Decir que me ha pasado sin actualizar el recalbox la versión que tenia era la de verano. Pero al día siguiente actualice a la última versión y no ha habido mejoría.


  • Banned

    @winters23 Podrías probar borrando la configuración interna de mame,
    es el fichero smb://recalbox/share/roms/mame/mame2003/cfg/default.cfg .
    Prueba a cambiarle el nombre e inicia algún juego, si no cambia nada siempre puedes volver a dejar el default.cfg como estaba.



  • Solo por curiosidad ¿has vuelto a configurar todas las teclas de los mandos desde el menú? Desde ahí puedes volver a mapear todos los botones...



  • Solucionado. Gracias a todos. He probado a renombrar el default.cfg, desde el ordenador como ha dicho Phantis, he arrancado cualquier rom del mame, y ha funcionado sin problemas. he metido desde la bios, en el archivo recalbox.cnfg, la ruta del archivo de los botones de libretro y funcionando, el juegador 1 y 2 sin problemas.



  • @winters23 Hola, tengo el mismo problema que tú tenías en una bartop, me van la mayoría de los juegos con los controles de la maquina pero los de NEO GEO me dan problema, solo funcionan con un teclado de PC y no me reconoce cuando los quiero cambiar desde el menu. ¿puede servirme tu solución? De ser así te pediría que me lo explicases un poco más que todavía estoy muy verde.
    Muchas gracias


  • Banned

    @pachi22 que core usas?



  • @pachi22, puede ser que sea el mismo caso, para poder acceder, tienes que ir al menu en recalbox, opciones de red, y ahí veras una ip que empezera como 192.168....
    Coges esa ip o memorizala, y sin apagar la bartop, desde un ordenador, habres cualquier carpeta y en la barra de direcciones, pones \ y tu ip (\192.168....). Al darle a intro ya estarás dentro del sistema de la bartop y a partir de ahí buscar la ruta del archivo de configuracion que será smb://recalbox/share/roms/neogeo/.....



  • @winters23 said in problemas controles emulador mame:

    @pachi22, puede ser que sea el mismo caso, para poder acceder, tienes que ir al menu en recalbox, opciones de red, y ahí veras una ip que empezera como 192.168....
    Coges esa ip o memorizala, y sin apagar la bartop, desde un ordenador, habres cualquier carpeta y en la barra de direcciones, pones \\ y tu ip (\\192.168....). Al darle a intro ya estarás dentro del sistema de la bartop y a partir de ahí buscar la ruta del archivo de configuracion que será smb://recalbox/share/roms/neogeo/.....



  • Podrias explicarlo un poco mejor? estoy un poco pez en esto.

    Me pasa como a ti, en MAME desconfigurado y en los demas perfecto

    Yo lo desconfigure sin querer al usar un mando de xbox360 y me quedo como a ti, podia meter creditos pero el Start no me funcionaba, tampoco las conbinacion de Hotkey, creo que la lie en el INPUT THIS GAME y lo desconfigure.

    Un poco de ayuda por favor? llevo toda la semana con esto y no doy con la solucion



  • @asturcuthbert
    1.- Tienes que ir a las opciones y entrar en opciones de red. Verás un apartado que se llama Direccion IP. Debes apuntar ese número que será del tipo \\192.168....
    2.- Acto seguido sin apagar la maquina y con un ordenador encendido abres una de las carpetas de windows y en la barra de busqueda escribes la ip que copiastes (\\192.168.....) y pulsas intro.
    3.- entras en la carpeta recalbox, acto seguido en la carpeta share y te tiene que aparecer algo como esto:

    alt text
    A continuacion ya sigues esta ruta /roms/mame/mame2003/cfg/default.cfg, es decir, entras en la carpeta roms, acto seguido en mame, acto seguido en mame2003, acto seguido en cfg, y ahí ya tienes el cfg.

    Espero haber sido de ayuda.



  • Hola,tengo un problema diferente con los controles de mame,y es que sin haber tocado nada cuando pulso tengo recalbox en su última versión,el botón B que es el de disparos o salto dependiendo el juego,me salta el menu de controles configuración y tal del propio mame y al mismo tiempo dispara o salta o la función que haga,no he tocado nada anteriormente,he leido el post,pero en config no tengo nada,solo un archivo .keep que ocupa 0kb y no se como hacer el default, alguna idea???,he buscado por san google pero el unico post que he visto relacionado es este

    EDITO:ERA DEL MANDO QUE ME HA LLEGADO DEFECTUOSO



Want to support us ?

Join us on :

222
Online

28778
Users

14634
Topics

110627
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.