Can't Connect

  • Hi,

    I just installed Recalbox 4.0.0 and i can't connect to network (cable and wifi).
    It give me IP, and i can access it from browser and windows network, can upload roms.. but can't use SCRAPER ou UPDATE.

    Looking at the logs, looks like it cant ping

    --- ping statistics ---
    1 packets transmitted, 0 packets received, 100% packet loss
    PING ( 56 data bytes

    I tried to ping it at windows and get same error, but i can ping

    Any idea what is hapenning? i tried many things, like making static IP.. same error

    Please look the screenshot:

    alt text

  • How did your pi get ?

  • Have the same problem, others too on the german forums. Use 4.0 (Yolo Changelog) on a Pi2, I have access to shared and monitoring via Edimax Wlan Stick but have "no connection". It happens the last mh 4 Days? Before I had no Problems.

  • @Substring

    Thats the local IP (assigned by DHCP).. I think, maybe sobe ISP issue.. Still looking for a solution..

  • @mazur Do you have a DNS and a gateway set on your pi ? That's most probably an incomplete DHCP problem

  • @Substring Yes i tryed auto and static settings.. on PC i can't ping too.. maybe some router setting?

  • @mazur as i said : check your DNS and gateway on recalbox, and what happens on your router. If you set a static ip'on recalbox, you may have forgotten what i said

  • Already check everything.. dunno what to do 😞

  • @mazur cdan you paste the result of ifconfig? and route or route print ?

  • @Substring , please check:

    # ifconfig
    eth0      Link encap:Ethernet  HWaddr B8:27:EB:79:9E:06
              inet addr:  Bcast:  Mask:
              inet6 addr: fe80::ba27:ebff:fe79:9e06%1994427092/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:158 errors:0 dropped:0 overruns:0 frame:0
              TX packets:163 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:15499 (15.1 KiB)  TX bytes:24591 (24.0 KiB)
    lo        Link encap:Local Loopback
              inet addr:  Mask:
              inet6 addr: ::1%1994427092/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    # route
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    default         UG    0      0        0 eth0    *        U     0      0        0 eth0
    # /etc/resolv.conf
    search # eth0
    nameserver # eth0
    # /etc/network/interfaces
    auto lo
    iface lo inet loopback
    auto eth0
    iface eth0 inet dhcp
    auto wlan0
    iface wlan0 inet dhcp
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
    # ping
    PING ( 56 data bytes
    --- ping statistics ---
    75 packets transmitted, 0 packets received, 100% packet loss

    I changed resolv.conf and interfaces but that files keeping returning to the default DHCP settings, already tryed to make them readonly, no sucess..

  • Have you tried pinging google rather ?

  • @Substring Yes, pinging any other site works..

  • @mazur ok can you try a traceroute to, and ? Thank you

  • When i use my pc with firefox, i also get a timeout error to connect to sever.

  • itself means nothing, should try with And as your are on the forum, i guess the DNS does work

    ooops it does work for me :

    # ping
    PING ( 56 data bytes
    64 bytes from seq=0 ttl=53 time=7.614 ms
    64 bytes from seq=1 ttl=53 time=7.370 ms
    64 bytes from seq=2 ttl=53 time=7.448 ms
    64 bytes from seq=3 ttl=53 time=7.336 ms
    64 bytes from seq=4 ttl=53 time=7.521 ms
    64 bytes from seq=5 ttl=53 time=7.438 ms
    64 bytes from seq=6 ttl=53 time=7.607 ms
    64 bytes from seq=7 ttl=53 time=7.504 ms
    --- ping statistics ---
    8 packets transmitted, 8 packets received, 0% packet loss
    round-trip min/avg/max = 7.336/7.479/7.614 ms

  • try pinging instead please

  • Been searching : it pings to say if you're connected or not. I guess we'll change that in 4.1 as this DNS is not accurate and points to nothing special. So the message NOT CONNECTED is a mistake

  • @Substring Thanks very much!

  • @Substring

    Same problem.
    Network settings show "not connected".
    But connection via SSH is fine.

    Strange thing is that scraping of ROMs works and tracking with retroachievements server also work as it should. But no updates possible.

    Yes, w-lan settings are correct, also looked in the config.
    I can ping but not - same with firefox via laptop.

    recalbox pings to check if we're "connected".

    The "www" has to be in the address.

    So how do we update to 4.1 if we get no connection with 4.0?

  • @DannyOcean easy pal ...

    4.1 is not here, we are taking care of that dns thing. We'd still have a few tricks up our sleeve anyway. I'd like to say it should be solved by the weekend as we're working on it, but it does not only depend on us

Log in to reply

Want to support us ?