Famicon USB SNES controller resets game when pressing button A



  • I have one of those cheap knockoff usb SNES controllers. They are not recognized by default so I added the controller and it works fine within Recalbox OS. Once I enter a super nintendo game and as soon as I press the A button it resets the rom. While this happens a text overlay of "Reset" in yellow appears at the bottom left of the screen.

    What I have tried so far:
    Using ssh I checked share\system.emulationstation\es_input.cfg before and after adding the controller. The controller adds fine. I thought maybe it was one of the default inputConfigs so I made a backup of the original file. I then deleted all the input configs minus the keyboard. Rebooted and readded the controller. It adds fine and again works fine in the OS but in the game I still get "Reset" within any snes/nes game when I hit A button.

    I am pretty stumped. Has anyone else ran into this problem? Thanks for reading this. Been a long time fan / user of recalbox never had any issues until now. Keep up the great work regardless.


  • Moderator
    Team
    Moderator
    Translator

    Map your Hotkey to select and no to the A button.



  • Thank you paradadf! That worked amazing! I was not assigning a hotkey when setting up the controller because I thought there wasn't enough inputs on the controller. That is so cool how select still works in game and long press works for hotkey! I love recalbox!


  • Moderator
    Team

    @paradadf you're the man ... it's like "everywhere i touch with my finger, it hurts -> your finger is broken" hahaha



Want to support us ?

Join us on :

244
Online

25554
Users

13367
Topics

101282
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.