Netzwerkproblem mit Raspberry Pi 3



  • Hallo Leute,

    Ich hoffe ihr könnt mir helfen.

    Kurz zu meinem bisherigen Vorgehen: Wie in zahlreichen Anleitungen zu lesen ist habe ich die Recalbox heruntergeladen und installiert. Dann noch kurz die Sprache auf Deutsch umgestellt und anschließend wollte ich noch eine Verbindung mit dem Netzwerk herstellen um mit meinem PC auf das Pi 3 zugreifen zu können, doch leider komme ich hier nicht weiter.

    Zuerst habe ich versucht die Verbindung über Wlan herzustellen, was aber fehlschlug (habe schon oft gelesen, dass Sonderzeichen ein Problem sind, sind aber bei mir nicht vorhanden). Anschließend wollte ich eine Konfiguration über die recalbox.conf vornehmen. Also das Pi per Netzwerkkabel an den Router angeschlossen. Doch leider kann trozdem nicht per PC zugreifen. Auch die direkte Eingabe \RECALBOX zeigt kein Erfolg. Wenn ich die IP Adresse in den Netzwerkeinstellungen nachschaue steht dort nur ein HEX-Code, vermutlich die MAC-Adresse.

    Ich hoffe jemand kann mir weiterhelfen. Schon mal vielen Dank.

    Grüße Simon


  • Translator
    Translation Master

    @GutZi Starte dein Raspi neu, wenn du das LAN Kabel eingesteckt hast. Am besten überprüfst du dann mit Putty ob du darauf zugreifen kannst (username: root, password: recalboxroot). Um im Explorer darauf zugreifen zu können, gibst du dann \IP-ADRESSE oder Name ein. Doppelbackslash ist notwendig. In Putty kannst du der IP Adresse deines Rapsi einen Namen zuweisen.


  • Translation Master
    Team

    Darüber hinaus stellt sich mir die Frage, ob DHCP in deinem Router aktiv ist @GutZi. Denn wenn ja, dann sollte der PI sich automatisch eine IP Adresse per LAN ziehen. Zu deiner WiFi-Annahme. Sonderzeichen sind seit 2 Betas kein Problem mehr (nur zur Info) und mussten vorher mit / "escaped" werden.

    Zur WiFi-Verbindung: Sofern dein Router DHCP Aktiv hat, kannst Du über das Frontend einfach eine WLAN-Verbindung aufbauen.

    Sollte KEIN DHCP in deinem Router aktiv sein, aktiviere es, oder gib die MAC Adresse des PIs in deine Liste zugelassener Geräte ein, damit der sich auch verbinden kann.



  • Danke für eure Tipps.

    Hab es endlich geschafft das Raspberry per Lan mit dem Netzwerk zu verbinden. Das Problem was, dass von meinen Versuchen mit WLan noch enable wifi auf on war. Dieses auf Off umgestellt und die Verbindung wurde aufgebaut. Zugriff per Explorer über funktioniert ebenfalls problemlos.

    Eine WLan Verbindung konnte ich noch nicht herstellen, DHCP ist auf jeden Fall aktiviert.

    Grüße



  • Wie kann man am besten kontrollieren ob das WLan Modul überhaupt funktionstüchtig ist?



  • Habs inzwischen auch mit einem anderen Router probiert. Ohne Erfolg

    Jemand noch eine Idee?


  • Moderator
    Team
    Moderator
    Translator

    @GutZi versuche einen Wifi-Kanal kleiner als 10 zu benutzen. Davor könntest du aber bei den Netwerkeinstellungen von recalbox das Wifi aus und einzuschalten, dazwischen kurz eine Ebene höhen ins Menü gehen. Manchmal muss ich bei mir das ein paar mal versuchen, bis ich kein IPv6 mehr bekomme und endlich Wifi enabled kommt.



  • Ich verwende Kanal 6.
    Habe schon mehrfach versucht hin- und her zu switchen, ohne Erfolg.


  • Moderator
    Team
    Moderator
    Translator

    @GutZi kannst du bitte hier dein recalbox.conf hochladen? Eigentlich sind nur die Netzwerkeinstellungen (# ------------ B - Network ------------ #) davon wichtig.



  • Aber gerne doch ;)

    # ------------ B - Network ------------ #
    ## Set system hostname
    system.hostname=RECALBOX
    ## Activate wifi (0,1)
    wifi.enabled=1
    ## Wifi SSID (string)
    wifi.ssid=GutRiedlings
    ## Wifi KEY (string)
    ## Escape your special chars (# ; $) with a backslash : $ => \$
    wifi.key=*************
    ## Samba share
    system.samba.enabled=1
    ### Virtual Gamepads
    system.virtual-gamepads.enabled=1
    ### SSH
    system.ssh.enabled=1
    

    PW Hab ich mal durch die entsprechende Anzahl Sternchen ersetzt. Verwendet werden hier Klein- und Großbuchstaben, sowie Zahlen.

    Grüße


  • Moderator
    Team
    Moderator
    Translator

    @GutZi leider ist alles richtig da, also woanders suchen.

    Benutzt du WPA2 und dein SSID ist sichtbar?
    Bekommst du ein IPv6 (oder was Ähnliches) bei deinem IP in recalbox? Oder habe ich das falsch verstanden? WENN du sowas bekommst, dann muss es einfach mit dem Ein- und Ausschalten des WIFIs funktionieren. Bei der nächsten Version 4.1 wird ein "connection manager" installiert, die sowas nicht mehr zulassen sollte (nur als Hinweis, bringt dir gerade nichts).



  • @paradadf schon mal danke für die Hilfe.

    WPA ist nicht aktiv und SSID ist sichtbar.

    Nachdem ich das WLan aus- und wieder eingeschaltet habe kommt die Meldung WLAN EINSTELLUNGSFEHLER. Hinter IP Adresse ist dann eine IPv6 Adresse zu sehen. (fe80::ba27:ebff:fe25:9b3b)

    Habs einigemale versucht, aber jedes mal das Gleiche.

    Grüße


  • Moderator
    Team
    Moderator
    Translator

    @GutZi guck dieses:
    https://github.com/recalbox/recalbox-os/issues/788

    Ich habe schon vor Monaten ein Issue geöffnet, weil bei mir das gleiche Problem vorkommt. Ich kann mich nur wiederholen... WIFI auf ON stellen, Back drücken und hoffen, dass WIFI ENABLED kommt... Wenn nicht, nochmal rein, WIFI auf OFF, Back drücken (man muss auf jeden Fall eine Ebene drüber ins Menü gelangen, sonst gibt es keinen refresh), wieder rein, WIFI auf ON stellen, Back drücken... usw. Das ist das Einzige, was es bei mir funktioniert. Manchmal muss ich auch das 10 Mal machen :S
    Ansonstens... was ich immer noch mache... auf 4.1 warten und hoffen, dass das Problem mit connman gelöst wird.


Log in to reply
 

Want to support us ?

Join us on :

302
Online

28119
Users

14407
Topics

109067
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.