HDMI vs CRT ,a request .



  • I'm trying Retropie and Recalbox and a difference is that with Retropie 2.6 automatically detects if I have connected the raspberry to a TV via HDMI or RCA (composite) with Recalbox can not, Are you going to solve this problem in future versions? Thanks ,Regards


  • Staff
    Developer
    Global moderator
    Team



  • Not working ,delete the hdmi_drive=2 line in config.txt , plug a rca(composite cable ) and not work. I have this config.txt file:



  • If you just want to use recalbox with the composite output, here is my file /boot/config.txt:

    # uncomment if you get no picture on HDMI for a default "safe" mode
    #hdmi_safe=1
    
    disable_overscan=0
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1
    
    # comment to get jack audio
    #hdmi_drive=2
    
    #config_hdmi_boost=0
    #hdmi_force_hotplug=0
    
    # uncomment to ignore hdmi plug
    hdmi_ignore_hotplug=1
    
    # uncomment for composite PAL
    sdtv_mode=2
    
    # Overclock
    gpu_mem=512
    
    avoid_safe_mode=1
    
    kernel=zImage
    
    # NOOBS Auto-generated Settings:
    #hdmi_force_hotplug=1
    #config_hdmi_boost=4
    #overscan_left=24
    #overscan_right=24
    #overscan_top=16
    #overscan_bottom=16
    disable_overscan=0
    overscan_scale=1
    

    You have to comment some lines (with hdmi mention).



  • I want to use the recalbox on a hdmi and crt TV ,without edit the config.txt , like a retropie 2.6 iMaster ,with your config.txt works on crt but not work in a HDMi tv.



  • Okay. This is not possible for now.



  • Only for clarification: you would like to choose CRT or HDMI. so, they are not connected both at the same time?



  • For me it is working without a problem. I have the following config atm. When hdmi is connected at boot it uses hdmi If rca is connected at boot it uses rca. Just be sure to delete the noobs autogenerated settings at the bottom of the config file. For overscanning i just use the overscan option in the recalbox emulationstation settings. ---- disable_overscan=0 sdtv_mode=2 hdmi_group=1 hdmi_mode=16 #Overclock# gpu_mem=256 arm_freq=1100 sdram_freq=500 core_freq=500 over_voltage=5 temp_limit=75 ### kernel=zImage disable_overscan=0 overscan_scale=1



Want to support us ?

449
Online

81.5k
Users

22.3k
Topics

161.5k
Posts