AFTER 4 REBOOTS, NOT AUDIO WORKING



  • Hello!

    I always have had a lot of troubles with audio output since 7.x.x versions, but I "solved" it connecting the speakers to the audio jack connector instead of HDMI (Display Port) audio out... and I can hear my games, so nothing important 😉

    A few days ago, I made a fresh install of RB 7.1.1... Everything worked fine (network, games, bios, audio...) but, suddenly, audio stopped working. After a few hours checking configs I surrended, no way to hear sound.

    Ok, no problem, let's start again... I have made a (another) fresh install of RB 7.1.1 x86_64 and when I have rebooted 4 times in 5 minutes (for configuring system languaje, WIFI...) SOUND HAS STOPPED AGAIN!!!

    It has no sense for me, I don't understand why reason everything works fine but in a few reboots it has stopped.

    By the way, I have tried to solve audio output, but I can't create asound.conf at /etc (I have readed and followed all forum threads). If I reboot, asound.conf have dessapear!

    Any help please will be welcome, I am getting mad!



  • Hello @cookie_monster ,

    did you try this? --> https://forum.recalbox.com/topic/22614/no-sound-over-hdmi

    I play almost every day and I don't have any problem with the sound, after following the steps, that I wrote, of course... 😀

    Regards.



  • @Dekiste, thanks for your response. Of course I have readed and followed every step you said, but since 7.x.x I have no sound throught HDMI output.

    If I connect SSH and I create asound.conf in /etc, and reboot, the file is deleted by system.

    In 7.0.1 I have not HDMI audio, but I connect audio jack and it worked properly. I have been playing 15 days with no problem.

    When I updated to 7.1.1, everything seems to be ok: wifi, controllers, roms, bios... but if I reboot 4 times the PC, the sound goes off.

    I have tried a clean install today (again) but the problem appears again: no audio after 4 reboots.

    I use a i5-8th gen, integrated audio and graphics... any idea?

    Thanks for your time and efforts!



  • @cookie_monster I'm sorry, but I am not a linux expert...

    I only followed the steps from this forum (in french) and it worked for me.

    Im using an "old" Mini-ITX board from MSI, Model MS-9887, with an Intel core i5, 2nd Gen (64-bit). and it works without problems.
    I have some from this boards, if someone from the Recalbox-Team want to "play" with it, I could send it for free, but with an Intel Celeron B810 😅, just send me a DM. Anyway the audio controller is the same.

    @cookie_monster, It seems, that we have to wait for a new Recalbox release.

    Regards.


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @cookie_monster Have you tried, in the Emulationstation menu, change the audio output from AUTO to HDMI?



  • @Zing Yes, of couse I've tried 😕. As other users with related issues, in RB 7.x.x. I can only see 3 options (default, hdmi and Conexant(default)), but in RB 6.1.1 I had available at least 6 options (devices) for audio output and it worked for me.

    I have search in all directories and I have found some interesting in files located /proc/asound/ (running process). I supose that it means that hardware is recognized and installed, but by some reason not usable or available for me.

    /proc/asound/cards

    0 [PCH            ]: HDA-Intel - HDA Intel PCH
                         HDA Intel PCH at 0x4000100000 irq 126
    

    /proc/asound/devices

    2: [ 0- 0]: digital audio playback
    3: [ 0- 0]: digital audio capture
    4: [ 0- 2]: digital audio capture
    5: [ 0- 3]: digital audio playback
    6: [ 0- 7]: digital audio playback
    7: [ 0- 8]: digital audio playback
    8: [ 0- 9]: digital audio playback
    9: [ 0-10]: digital audio playback
    10: [ 0- 0]: hardware dependent
    11: [ 0- 2]: hardware dependent
    12: [ 0]   : control
    33:        : timer
    

    /proc/asound/pcm

    00-00: CX20632 Analog : CX20632 Analog : playback 1 : capture 1
    00-02: CX20632 Alt Analog : CX20632 Alt Analog : capture 1
    00-03: HDMI 0 : HDMI 0 : playback 1
    00-07: HDMI 1 : HDMI 1 : playback 1
    00-08: HDMI 2 : HDMI 2 : playback 1
    00-09: HDMI 3 : HDMI 3 : playback 1
    00-10: HDMI 4 : HDMI 4 : playback 1
    

    Now I am going to make a new (4th) fresh install of RB 7.1.1... may be my last attempt before going back to 6.1.1 😣 😣 😣



  • Finally I have solved the audio issue. I have used the proposed solution creating a file named asound.conf in /etc with the working config via SSH.

    If I reboot, the problem remains because system always deleted the asound.conf, so I use chattr bash command for make it "undeletable" for anyone, even root.

    So the solution has been:

    chattr +i /etc/asound.conf
    

    Thanks to everyone who helped me and thanks to RecalBox Team!


Log in to reply
 

Want to support us ?

293
Online

81.3k
Users

22.2k
Topics

161.1k
Posts